Author Topic: Painting Fantasy slideshow bug?  (Read 858 times)

0 Members and 1 Guest are viewing this topic.

Offline Foebane72

  • CPC464
  • **
  • Posts: 11
  • Country: gb
  • Liked: 1
  • Likes Given: 0
Painting Fantasy slideshow bug?
« on: 13:42, 23 February 17 »
When I run this slideshow in WinAPE: http://www.pouet.net/prod.php?which=1559

At the screen which is shown in the screenshot, the whole screen rolls like a CRT display, but try as I might, I cannot get it to stop rolling. I can still just about select the pictures in the gallery, but I wonder if this is an emulator glitch?

Offline robcfg

  • Supporter
  • 6128 Plus
  • *
  • Posts: 2.260
  • Country: se
  • 8-Bit Technomancer
    • index.php?action=treasury
  • Liked: 1002
  • Likes Given: 2334
Re: Painting Fantasy slideshow bug?
« Reply #1 on: 15:05, 23 February 17 »
It might be useful if you could tell us your WinAPE configuration.


It may have to do with the CPC model you're emulating or the selected CRTC chip.

Offline Foebane72

  • CPC464
  • **
  • Posts: 11
  • Country: gb
  • Liked: 1
  • Likes Given: 0
Re: Painting Fantasy slideshow bug?
« Reply #2 on: 15:25, 23 February 17 »
I can't post a config at the moment, but I tried ALL the CRTC chip options on WinAPE as it was running - no joy.

Offline robcfg

  • Supporter
  • 6128 Plus
  • *
  • Posts: 2.260
  • Country: se
  • 8-Bit Technomancer
    • index.php?action=treasury
  • Liked: 1002
  • Likes Given: 2334
Re: Painting Fantasy slideshow bug?
« Reply #3 on: 15:50, 23 February 17 »
I think you have to, at least, reset the emulation for the settings to apply.


I mean, changing it while it's already running will make no difference.


Anyone, please correct me if I'm wrong.

Offline arnoldemu

  • Supporter
  • 6128 Plus
  • *
  • Posts: 5.335
  • Country: gb
    • Unofficial Amstrad WWW Resource
  • Liked: 2260
  • Likes Given: 3478
Re: Painting Fantasy slideshow bug?
« Reply #4 on: 16:03, 23 February 17 »
I expect the frame time is not exactly 50hz on real cpc. You should need to adjust the vhold in the emulator.
My games. My Games
My website with coding examples: Unofficial Amstrad WWW Resource

Offline Foebane72

  • CPC464
  • **
  • Posts: 11
  • Country: gb
  • Liked: 1
  • Likes Given: 0
Re: Painting Fantasy slideshow bug?
« Reply #5 on: 20:37, 23 February 17 »
Thanks for the answers, but it's not exactly urgent, I was just curious, that's all.

However, if you could add an answer to my other thread today about Vsync, that would be helpful.

Offline Foebane72

  • CPC464
  • **
  • Posts: 11
  • Country: gb
  • Liked: 1
  • Likes Given: 0
Re: Painting Fantasy slideshow bug?
« Reply #6 on: 14:00, 25 February 17 »
I expect the frame time is not exactly 50hz on real cpc. You should need to adjust the vhold in the emulator.

Thank you, Arnoldemu, that's exactly what it was. I set it to -10, just as a test, and it stopped rolling! So that's that solved, then.

BTW, I tried CPC6128 and 6128 Plus profiles, both the same.