Author Topic: WinApe deleting DSKs...?  (Read 550 times)

0 Members and 1 Guest are viewing this topic.

Offline ASiC

  • Supporter
  • CPC664
  • *
  • Posts: 120
  • Country: gb
  • Liked: 75
  • Likes Given: 304
WinApe deleting DSKs...?
« on: 12:37, 31 May 19 »
Hi All,

I have noticed something rather troubling today:
WinApe seems to be deleting every second DSK I'm trying to mount.
When the emulator is launched, it will mount and use the DSK, no bother.
But when I'm trying to mount another one, I get an error (invalid dsk type or something similar) and then the "failed" DSK is gone!

Does anybody have noticed anything similar?

- DSKs are zipped, one archive per .dsk;- WinApe ver 2.0 Beta 2;
- Files on NAS (ZFS), SMB v1 disabled;
- Windows 10x64.

Cheers

Offline roudoudou

  • 6128 Plus
  • ******
  • Posts: 693
  • Country: fr
    • urban exploration
  • Liked: 968
  • Likes Given: 610
Re: WinApe deleting DSKs...?
« Reply #1 on: 14:22, 31 May 19 »

Many, many, many, many, many problems with Winape and network folders
Eject/Unmount DSK every time you can
Maybe the clever way is to reset the INI/CFG file at every launch
use RASM, the best assembler ever made :p

I will survive

Offline The_Mole_UK

  • CPC664
  • ***
  • Posts: 53
  • Country: gb
  • CPC 6128 / 6128 Plus / WinAPE 2.0 B2.
  • Liked: 20
  • Likes Given: 3
Re: WinApe deleting DSKs...?
« Reply #2 on: 02:04, 04 June 19 »
I've only ever used dsks as is, not zipped.

It is important to eject the dsk image before closing the emulator.  If you don't, the image on the disk will not be updated.  Sometimes, I've made a mistake and forced closed WinAPE in order that the dsk reverts back to how it was before I tweaked it!

Providing the image is not moved after closing WinAPE, or been updated in WinAPE, WinAPE will retain the last dsk loaded, if you do not eject.

The ParaDOS ROM allows for 3.5" formats (normally on B).  This can be modified though in the ROM or use the emulated ABBA.

Hi All,

I have noticed something rather troubling today:
WinApe seems to be deleting every second DSK I'm trying to mount.
When the emulator is launched, it will mount and use the DSK, no bother.
But when I'm trying to mount another one, I get an error (invalid dsk type or something similar) and then the "failed" DSK is gone!

Does anybody have noticed anything similar?

- DSKs are zipped, one archive per .dsk;- WinApe ver 2.0 Beta 2;
- Files on NAS (ZFS), SMB v1 disabled;
- Windows 10x64.

Cheers

Offline ASiC

  • Supporter
  • CPC664
  • *
  • Posts: 120
  • Country: gb
  • Liked: 75
  • Likes Given: 304
Re: WinApe deleting DSKs...?
« Reply #3 on: 10:14, 04 June 19 »
I've only ever used dsks as is, not zipped.

It is important to eject the dsk image before closing the emulator.  If you don't, the image on the disk will not be updated.  Sometimes, I've made a mistake and forced closed WinAPE in order that the dsk reverts back to how it was before I tweaked it!

Providing the image is not moved after closing WinAPE, or been updated in WinAPE, WinAPE will retain the last dsk loaded, if you do not eject.

The ParaDOS ROM allows for 3.5" formats (normally on B).  This can be modified though in the ROM or use the emulated ABBA.
Even ejecting the zip/dsk files, I end up with corrupted files.
It will not destroy all of them. It seems to be random.
I'm pretty sure that WinApe tries to re-write/re-create the archive as the damaged file is a 1KB zip.
I used winape (and all emulators) from network shares since the old days and never had an issue.
I cannot think of anything changing, apart from the win10 version upgrades (currently on 1903)

Offline The_Mole_UK

  • CPC664
  • ***
  • Posts: 53
  • Country: gb
  • CPC 6128 / 6128 Plus / WinAPE 2.0 B2.
  • Liked: 20
  • Likes Given: 3
Re: WinApe deleting DSKs...?
« Reply #4 on: 14:41, 03 July 19 »
Make all changes to .dsk
Eject .dsk
Close WinAPE
Back up .dsk
Run WinAPE again...

Note: If you are tweaking an original .dsk game with protection, it will corrupt.  If it looks messy, I tend to go with a trainer.
Especially, if in some cases, it fixes an issue that made it unplayable...
Trainers can be better in that you can tidy them up, the fix can make the game more playable and you can add more games to one disc image.  Some look quite nice.

I am looking forward to a new build though that is a bit more 10 friendly...
- In my build I have a couple of ROMs loaded I made from discs, that allow management...
« Last Edit: 14:45, 03 July 19 by The_Mole_UK »

Offline The_Mole_UK

  • CPC664
  • ***
  • Posts: 53
  • Country: gb
  • CPC 6128 / 6128 Plus / WinAPE 2.0 B2.
  • Liked: 20
  • Likes Given: 3
Re: WinApe deleting DSKs...?
« Reply #5 on: 14:49, 03 July 19 »
Currently using 1809.  Partly as friend modded it to make my notebook work with it...   I was getting issues installing.
It doesn't keep downloading updates all the time and messing up...  It soon will have a reinstall.

>Files on NAS (ZFS)
They're so small, I just have a WinAPE folder with my stuff in.  Not worth putting on a NAS, only as a zip backup.

>SMB v1 disabled...
BT Home Hub 6 uses this.  Consequently, unless I enable it (I just enable client bit), I cannot have my printer networked.
Any ideas anyone???

This is the only real annoyance.  No firmware update planned apparently.  Poor I think.

Is the BT Home Hub 7 any better?  But that does not split 2.4 and 5 GHz signals?
I could do with a brilliant new router and to upgrade my 10 installation...
« Last Edit: 15:00, 03 July 19 by The_Mole_UK »