Author Topic: [Solved] Winape Fullscreen Aspect ratio - ATI driver bug + Work around  (Read 5634 times)

0 Members and 1 Guest are viewing this topic.

Offline Sammi79

  • CPC464
  • **
  • Posts: 6
  • Country: wales
  • Liked: 1
  • Likes Given: 2
Hi,

When I switch Winape to fullscreen, the display is stretched to fit my LCD aspect ratio 16:9.

Is there any way to tell it to hold the correct aspect ratio (4:3?) and leave blank areas to the sides?

Currently I use it windowed and set DirectX stretch in the .ini file to 1152x810 which scales properly (all pixels are same) but it should be able to run fullscreen at 1536x1080 and keep the pixel rows/columns equal on my LCD. However, running in a window at this resolution doesn't quite work as the window title bar must take some of the 1080 Max vertical rows, thus some rows are squeezed leading to irregular pixels.

It's no big deal I guess, but maybe I'm missing something. Any ideas?

  :D

OK I found a solution. The problem (there actually was a problem!) is with the current Win7 ATI - driver, and causes the monitor settings controlling scaling to be stuck on 'Fullscreen' which stretches everything.

 Until it is fixed it can be got around by: changing the desktop resolution to anything below your max setting, then go back into your display setting in ATI Catalyst Control Centre and you can now set the screen to 'Keep Aspect Ratio' - then change the resolution back to your preference and the setting will stick.

Regards,
Sam.     

Sam.
« Last Edit: 15:57, 02 October 12 by Sammi79 »
ACER Aspire 8943G Laptop
i7-720QM 8 cores ~1.6GHz / 8GB / ATI Mobility Radeon 5850HD / Win 7x64 Home Premium

Offline Executioner

  • Supporter
  • 6128 Plus
  • *
  • Posts: 783
  • Country: au
  • WinAPE Developer
    • WinAPE
  • Liked: 391
  • Likes Given: 60
Re: Winape Fullscreen Aspect ratio
« Reply #1 on: 07:54, 01 October 12 »
In full screen mode it's probably determined by your graphics card and driver. WinAPE sets the resolution to 800x600 in full-screen mode. That's not a wide-screen format and the graphics card may need to be told to maintain the aspect ratio in those 4:3 modes.

Offline Devilmarkus

  • Vivid source of indefiniteness
  • 6128 Plus
  • ******
  • Posts: 4.035
  • Country: de
  • WebCPC / JavaCPC developer
    • index.php?action=treasury
    • CPC-Live website
  • Liked: 1011
  • Likes Given: 926
Re: Winape Fullscreen Aspect ratio
« Reply #2 on: 16:10, 01 October 12 »
Mainly this is a setting in your monitor menu.
Something like keep aspect ratio
When you put your ear on a hot stove, you can smell how stupid you are ...

Amstrad CPC games in your webbrowser

JavaCPC Desktop Full Release

Offline McKlain

  • 6128 Plus
  • ******
  • Posts: 867
  • Country: es
  • Programmable Sound Generator
    • www.mcklain.com
  • Liked: 338
  • Likes Given: 950
Re: Winape Fullscreen Aspect ratio
« Reply #3 on: 16:45, 01 October 12 »
In full screen mode it's probably determined by your graphics card and driver. WinAPE sets the resolution to 800x600 in full-screen mode. That's not a wide-screen format and the graphics card may need to be told to maintain the aspect ratio in those 4:3 modes.


Could Winape do fullscreen in a different way? Going fullscreen using the desktop resolution and then using DirectX stretch to fill the screen while maintaining the aspect ratio.
« Last Edit: 11:46, 02 October 12 by McKlain »

Offline Devilmarkus

  • Vivid source of indefiniteness
  • 6128 Plus
  • ******
  • Posts: 4.035
  • Country: de
  • WebCPC / JavaCPC developer
    • index.php?action=treasury
    • CPC-Live website
  • Liked: 1011
  • Likes Given: 926
Re: Winape Fullscreen Aspect ratio
« Reply #4 on: 18:16, 01 October 12 »

Could Winape does fullscreen in a different way? Going fullscreen using the desktop resolution and then using DirectX stretch to fill the screen while maintaining the aspect ratio.

In JavaCPC for example, no real fullscreen is possible.
So I use the following trick:
- I detect the screen resolution
- JavaCPC calculates left and right border widths for black area (or top/lower border, if necessary)
- I draw the border + screen on a full sized frame without decoration

Result for 1920*1080 pixels + bilinear filter:
 [ Invalid Attachment ]
When you put your ear on a hot stove, you can smell how stupid you are ...

Amstrad CPC games in your webbrowser

JavaCPC Desktop Full Release

Offline Executioner

  • Supporter
  • 6128 Plus
  • *
  • Posts: 783
  • Country: au
  • WinAPE Developer
    • WinAPE
  • Liked: 391
  • Likes Given: 60
Re: Winape Fullscreen Aspect ratio
« Reply #5 on: 02:16, 02 October 12 »
Could Winape does fullscreen in a different way? Going fullscreen using the desktop resolution and then using DirectX stretch to fill the screen while maintaining the aspect ratio.

It could do, optionally, and with most modern graphics cards there won't be much performance hit when doing it this way. This would be similar to the method used by JavaCPC.

Offline Sammi79

  • CPC464
  • **
  • Posts: 6
  • Country: wales
  • Liked: 1
  • Likes Given: 2
Re: Winape Fullscreen Aspect ratio
« Reply #6 on: 11:56, 02 October 12 »
 :D

OK I found a solution. The problem (there actually was a problem!) is with the current Win7 ATI - driver, and causes the monitor settings controlling scaling to be stuck on 'Fullscreen' which stretches everything. Until it is fixed it can be got around by changing the desktop resolution to anything below your max setting, then go back into your display setting in ATIs Catalyst Control Centre and you can now set the screen to 'Keep Aspect Ratio' - then change the resolution back to your prefernece and the setting will stick.

Regards,
Sam.
ACER Aspire 8943G Laptop
i7-720QM 8 cores ~1.6GHz / 8GB / ATI Mobility Radeon 5850HD / Win 7x64 Home Premium

Offline McKlain

  • 6128 Plus
  • ******
  • Posts: 867
  • Country: es
  • Programmable Sound Generator
    • www.mcklain.com
  • Liked: 338
  • Likes Given: 950
Re: Winape Fullscreen Aspect ratio
« Reply #7 on: 11:59, 02 October 12 »
That problem is not new and AMD doesn't fix it. Ridiculous.


I switched to nvidia when I bought my new graphics card and I can't be more happy with the change.

Offline Executioner

  • Supporter
  • 6128 Plus
  • *
  • Posts: 783
  • Country: au
  • WinAPE Developer
    • WinAPE
  • Liked: 391
  • Likes Given: 60
My current laptop has an ATI card, and there are a couple of minor niggles I have with it. One is that it defaults to underscan when you connect a monitor using HDMI, and you have to go searching for an obscure scaling setting to set it to 100% so it shows 1920x1080. The other problem is that I think it may be the cause of some of my Blue Screens and performance issues.

Offline McKlain

  • 6128 Plus
  • ******
  • Posts: 867
  • Country: es
  • Programmable Sound Generator
    • www.mcklain.com
  • Liked: 338
  • Likes Given: 950
I got tired of ATI breaking their drivers with every new release. They fixed something and then broke something else. I haven't had an nvidia card since the times of the geforce2 mx400. The tv output was terrible back then and it made me choose an ati card when I upgraded my pc, and I was a happy ATI user for many years. Now I'm back to nvidia mainly because of the poor ati drivers.

Offline Sammi79

  • CPC464
  • **
  • Posts: 6
  • Country: wales
  • Liked: 1
  • Likes Given: 2
I decided against NVIDIA when I bought this laptop, mainly because I had to replace the mainboard in my old HP laptop twice because of a burned out GPU.

Used to use them exclusively ever since the 3DFX cards went out. They've not been without their own driver issues.

Will be sticking with ATI for a while. Still very pleased at the way this one looks and works.

Regards,
Sam.
ACER Aspire 8943G Laptop
i7-720QM 8 cores ~1.6GHz / 8GB / ATI Mobility Radeon 5850HD / Win 7x64 Home Premium

Offline VincentGR

  • 6128 Plus
  • ******
  • Posts: 1.126
  • Country: gr
    • Parts from the past.
  • Liked: 615
  • Likes Given: 1586
Sorry for the necromancing.
4:3 works fine on AMD GPUs if you enable this: