- Top Stats

Top Posters Top Topic Starters Top Topics
Bryce 690
Audronic 237
CraigsBar 143
TFM 138
llopis 96
Audronic 34
Bignumbas 19
llopis 9
ComSoft612... 8
Querubin 6
X-Mass help please - 20255 Views 00WReX 15:29, 26 February 15
Fixing Floppy-Drives - 9927 Views Shining 00:45, 13 January 15
Interpreting u... - 9062 Views JonB 13:25, 05 April 15
CPC 464 blue s... - 7243 Views Alexandre ... 12:24, 29 July 15
Keyboard or Ma... - 5763 Views talrek 17:57, 21 October 14

Author Topic: 6128 not working  (Read 272 times)

0 Members and 1 Guest are viewing this topic.

Offline Joiquaf

  • CPC464
  • **
  • Posts: 4
  • Country: fi
  • Liked: 0
6128 not working
« on: 23:06, 23 April 19 »
I got my first CPC6128 and monitor this weekend. I only have prior experience from the Commodore and Sinclair world.

The machine was "probably not working", but from the outside it looked nice enough that I was hopeful.

It cleaned up nicely and I measured the output from the monitor power source which was OK before turning it on.

As I powered it up I saw a green square box, which means most of the important circuits should work.

There was some slight corrosion/flux/gunk around the RAM circuits which I cleaned thoroughly. All RAM chips get 5V.

I also removed the HAL chip and rigged the bank swap trick to see if it would start then - same green square.

I thought that either the RAM is very bad or there's something else.

I removed the ULA 40010, which had corroded legs between pins 1-5. I cleaned the chip and the socket best as I could,
and powered on again. Then things took a turn for the worse. Nothing - a black screen. I remove the ULA again and cleaned
it some more. A very distorted white box... Progress I guess... Cleaned it again... Back to black...

I get 4.9V between pins 25&26 + 36&25 on the ULA.

My plan forward is to replace the socket for the ULA and hope that it's not fried. I'm hoping the RAM is OK though...

Is there anything I can check w/ the ULA? Do you have any other suggestions?

Offline llopis

  • Supporter
  • CPC6128
  • *
  • Posts: 165
  • Country: es
    • Games from Within
  • Liked: 29
Re: 6128 not working
« Reply #1 on: 23:14, 23 April 19 »
You did a pretty good initial check. From what you're describing, my bet is still on the RAM. It's not unusual for multiple ICs to fail at the same time, so just trying the other bank doesn't always work.

A couple of things I would check:
- Are there any chips that are getting unusually hot? Those would be dead giveaways that they're bad.
- Check pin 14 on the RAM chips (which would be the data bus). If any of them are stuck at 0V or 5V, there's a problem (probably in a RAM chip, but maybe in a multiplexor).

As for removing the ULA and things getting worse... that's odd. Definitely a new socket would be good. Check that you have good clock signals everywhere (Z80, ULA, etc).

Keep us posted. Good luck.

Offline Bryce

  • The Hardware Guy.
  • Supporter
  • 6128 Plus
  • *
  • Posts: 10.754
  • Country: wf
  • It's not broken, it just hasn't been fixed yet.
    • index.php?action=treasury
  • Liked: 3743
Re: 6128 not working
« Reply #2 on: 10:47, 24 April 19 »
you seem to be on the right track, the 40010 socket is probably full of gunk and not making contact every time or may even have a bad solder joint. Swap it out first and see if things get better.


Offline Joiquaf

  • CPC464
  • **
  • Posts: 4
  • Country: fi
  • Liked: 0
Re: 6128 not working
« Reply #3 on: 17:52, 24 April 19 »
Thank you very much for your kind replies.
I will get back in a couple of weeks when I get the parts I ordered :)

Offline Joiquaf

  • CPC464
  • **
  • Posts: 4
  • Country: fi
  • Liked: 0
Re: 6128 not working
« Reply #4 on: 00:22, 18 May 19 »
I got the parts i needed and worked on the Amstrad again.

First the "good" part - I changed the socket for the ULA and I got the green screen w/ a border back. So, back to square one.
I removed all the RAM, cleaned the board and put sockets in place. I inserted memory chips from Aliexpress (KM4164B-12) which should (?) be compatible.
I held my breath and turned on the computer.... Same green screen...

Things tried:
  • all RAM chips get 5V between pins 16 and 8
  • all RAM chips get either 1,7V or 2.5V between pins 16 and 14, _except_ IC121 & IC129 (third ones from the top) which gets 0,07V
  • I put back the original RAM chips in the sockets and they behaved exactly the same way
  • removed CPU from socket - nice and clean
  • Only hot chip is IC108 which I suppose handles the display
  • If i touch R111 the screen goes dark temporarily - redid the solders - no change
Am I out of luck with this computer or could I try something more? Let me know if I can provide you with any more information or clues...

See images at
« Last Edit: 13:16, 18 May 19 by Joiquaf »

Offline LambdaMikel

  • 6128 Plus
  • ******
  • Posts: 1.318
  • Country: us
    • Homepage
  • Liked: 693
Re: 6128 not working
« Reply #5 on: 03:34, 18 May 19 »
Looking at your pictures closely, it seems that some of the PCB tracks / traces are corroded... they don't look good. Some even appear to be interrupted, but it probably just corrosion.

Did you check connectivity of all pins with a multi meter?

Offline Joiquaf

  • CPC464
  • **
  • Posts: 4
  • Country: fi
  • Liked: 0
Re: 6128 not working
« Reply #6 on: 08:54, 18 May 19 »
I inspected with a magnifying glass and the damage / discoloration is only in the coating of the board. I checked connectivity "vertically" with a multi-meter before and after I added the sockets (pin x on the lowest socket has connection to pin x on the ones above).

Offline gerald

  • Supporter
  • 6128 Plus
  • *
  • Posts: 1.346
  • Liked: 964
Re: 6128 not working
« Reply #7 on: 11:15, 18 May 19 »
IC118 is the PAL managing the RAM banking. It should not be hotter than the Z80 or the CRTC.
If there is a significant difference it may be your problem.
You can boot the CPC without it by doing a bit of wiring on the socket as explained there : http://www.cpcwiki.eu/forum/amstrad-cpc-hardware/need-some-help-fixing-cpc6128-not-booting/msg75204/#msg75204