CPCWiki forum

General Category => Off topic => Topic started by: ukmarkh on 22:37, 23 May 18

Title: Why won’t it turn on?
Post by: ukmarkh on 22:37, 23 May 18
My Amstrad CPC 6128 will not turn on, any ideas?

(https://uploads.tapatalk-cdn.com/20180523/23438d2dfea411165fa9d1fe8156b1bb.jpg)


Sent from my iPhone using Tapatalk
Title: Re: Why won’t it turn on?
Post by: robcfg on 22:54, 23 May 18
I'd try to clean the power switch with contact cleaner to begin with, and if that doesn't help, check for broken solder points.
Title: Re: Why won’t it turn on?
Post by: ukmarkh on 22:55, 23 May 18
I'd try to clean the power switch with contact cleaner to begin with, and if that doesn't help, check for broken solder points.

The power switch does feel a bit stiff as you flick it on and off [emoji848]


Sent from my iPhone using Tapatalk
Title: Re: Why won’t it turn on?
Post by: Duke on 23:01, 23 May 18
I'd try to clean the power switch with contact cleaner to begin with, and if that doesn't help, check for broken solder points.

Yes.

I just received a "not working" 464 today (cost down, yay).
Two problems. Power socket was slightly loose, re-solder it and then the power switch, although it passed the continuity test (beep!), it must have had too much resistance to power the CPC on. Opening and cleaning the switch and the machine is back to life :)
Title: Re: Why won’t it turn on?
Post by: ukmarkh on 23:05, 23 May 18
Yes.

I just received a "not working" 464 today (cost down, yay).
Two problems. Power socket was slightly loose, re-solder it and then the power switch, although it passed the continuity test (beep!), it must have had too much resistance to power the CPC on. Opening and cleaning the switch and the machine is back to life :)

What household stuff can I use to clean it?


Sent from my iPhone using Tapatalk
Title: Re: Why won’t it turn on?
Post by: Duke on 23:08, 23 May 18
IPA if no contact cleaner. In lack of anything chemical, just rub the two contact points clean with some toilet paper, whatever :)
Title: Re: Why won’t it turn on?
Post by: ukmarkh on 23:11, 23 May 18
Doesn’t look too bad, just wondering how I can strip it with my fat fingers

(https://uploads.tapatalk-cdn.com/20180523/c60bcd449509af4c139e151bd9abdb02.jpg)


Sent from my iPhone using Tapatalk
Title: Re: Why won’t it turn on?
Post by: Duke on 23:15, 23 May 18
Use a screwdriver to bend the metal legs slightly going around the plastic then you can get the cap off.
You could just try to short the two yellow wires, so you know if it's worth opening it or not.

Doesn’t look too bad, just wondering how I can strip it with my fat fingers

(https://uploads.tapatalk-cdn.com/20180523/c60bcd449509af4c139e151bd9abdb02.jpg)


Sent from my iPhone using Tapatalk
Title: Re: Why won’t it turn on?
Post by: ukmarkh on 23:22, 23 May 18
I shorted the two yellow wires and it turned on [emoji1303]


Sent from my iPhone using Tapatalk
Title: Re: Why won’t it turn on?
Post by: ukmarkh on 23:28, 23 May 18
The culprit, horrible vial red stuff...


(https://uploads.tapatalk-cdn.com/20180523/2fdeb90cf0d9d9fcd59dd15faa7e7305.jpg)


Sent from my iPhone using Tapatalk
Title: Re: Why won’t it turn on?
Post by: Duke on 23:37, 23 May 18
I think that part is supposed to have a bit of grease, what you want to clean is the "platin" knob on the little metal plate and below it in the contact.
Title: Re: Why won’t it turn on?
Post by: ukmarkh on 00:03, 24 May 18



Now all I’m getting is a blue or black screen [emoji22]

(https://uploads.tapatalk-cdn.com/20180523/4d82a37ffbdad6f5ce26abfd0b72cace.jpg)


Sent from my iPhone using Tapatalk
Title: Re: Why won’t it turn on?
Post by: Duke on 00:07, 24 May 18


Now all I’m getting is a blue or black screen (https://emoji.tapatalk-cdn.com/emoji22.png)

Maybe it's not cleaned good enough and still has too much resistance. Try to short yellow wires again.
Title: Why won’t it turn on?
Post by: ukmarkh on 00:08, 24 May 18
Maybe it's not cleaned good enough and still has too much resistance. Try to short yellow wires again.

Only blue screen with shorting [emoji17] But the lights and everything turn on... Maybe Rom chip has gone


Sent from my iPhone using Tapatalk
Title: Re: Why won’t it turn on?
Post by: Chinnery on 00:13, 24 May 18
(oops, replied to an old post without refresh)
Title: Re: Why won’t it turn on?
Post by: ukmarkh on 00:15, 24 May 18
First, see if it is the switch.
Unplug it from the board, then VERY CAREFULLY, bob a flat bladed screwdriver between the 2 newly exposed pins. And I do mean very carefully!!!
If it comes on, the switch is dirty/buggered. If not, the issue is elsewhere.

Yeah, I tried that, blue screen...


Sent from my iPhone using Tapatalk
Title: Re: Why won’t it turn on?
Post by: Duke on 00:16, 24 May 18
Only blue screen with shorting (https://emoji.tapatalk-cdn.com/emoji17.png) But the lights and everything turn on... Maybe Rom chip has gone

Does pressing DEL make a sound?
It seems to setup the proper colours with the blue screen (rom chip needs to work for that).
Title: Why won’t it turn on?
Post by: ukmarkh on 00:18, 24 May 18
Does pressing DEL make a sound?
It seems to setup the proper colours with the blue screen (rom chip needs to work for that).

Held Del key down, no noise. I forget, which is the Rom chip, I’m sure I’ve got spares...

Is it the 40010?

(https://uploads.tapatalk-cdn.com/20180523/6c8e307818663a5e4b93535ac79472e6.jpg)


Sent from my iPhone using Tapatalk
Title: Re: Why won’t it turn on?
Post by: Duke on 00:25, 24 May 18
Held Del key down, no noise. I forget, which is the Rom chip, I’m sure I’ve got spares...
Ok :/
Check if any of the RAM chips are hot, would be first thing that comes to mind, but tbh. I am not sure if it would get to setup the blue colours without working RAM, iirc. it will crash somewhere in lowerrom before that and leave you with a grey screen/black border.
40025 is the romchip.

No 40010 is the gate array.
Title: Re: Why won’t it turn on?
Post by: Duke on 00:34, 24 May 18
If none of the RAM chips are hot (small OKI chips), try to replace the Z80 first as it's in a socket, and they can have faults these days.
Title: Re: Why won’t it turn on?
Post by: ukmarkh on 01:06, 24 May 18
If none of the RAM chips are hot (small OKI chips), try to replace the Z80 first as it's in a socket, and they can have faults these days.

Ram chips cool to the touch, changed Z80, no difference, changed 40010, no difference. I’m thinking that bloody ROM chip [emoji22]


Sent from my iPhone using Tapatalk
Title: Re: Why won’t it turn on?
Post by: ukmarkh on 01:58, 24 May 18
So, after further investigation and sweating buckets, I found out that the ribbon cables from the keyboard are stopping the CPC from starting up!

(https://uploads.tapatalk-cdn.com/20180523/7f88a962d11c3806b9f5fad879472f18.jpg)


Sent from my iPhone using Tapatalk
Title: Re: Why won’t it turn on?
Post by: ukmarkh on 02:05, 24 May 18
Can’t see anything obvious, but will give it a clean and see how we go [emoji848]

(https://uploads.tapatalk-cdn.com/20180523/329eca9a1c00eb01c2d007ed3ca57134.jpg)


Sent from my iPhone using Tapatalk
Title: Re: Why won’t it turn on?
Post by: ukmarkh on 02:10, 24 May 18

This looks like the problem, it’s rusted at the keyboard base and has destroyed the membrane, I have a spare hopefully

(https://uploads.tapatalk-cdn.com/20180523/c8bf5f2d7625ee624a91f1bcfecc61a0.jpg)


Sent from my iPhone using Tapatalk