Recent Posts

Pages: [1] 2 3 ... 10
Amstrad CPC hardware / Re: Which mouse do you use?
« Last post by Scautura on Today at 18:14 »
I answered both "no mouse" and "AMX" - because back in the day I used an AMX mouse, but now? It's gone walkies, so I have no mouse. :( Plus I don't have the budget to hunt down a replacement, despite wanting one (of any variety; would probably use it mostly with FutureOS and SymbOS, so I don't even know what options I have at the moment. Best bet would be a Bryce/USB mod?).

That's essentially why I didn't vote previously.
Crazy stuff... I just repaired the floppy drive, and among other things (the damage to the PCB mentioned above), the "fixer" had resoldered the power wires the wrong way around!! Despite this, it now works again! Without anything having been damaged from the polarity mix-up. They don't make things like that any more.

Technical Support / Re: 464+ powers on, no picture
« Last post by Bryce on Today at 15:56 »
Unfortunately not. The ASIC was a custom IC made specially for Amstrad and isn't possible to get without removing one from a working machine.

Amstrad CPC hardware / Re: Which mouse do you use?
« Last post by mr_lou on Today at 13:12 »
I don't use any mouse yet, but since Bryce modified my CPC plus with a USB port for a mouse, that pretty much decides it for me.  :)
 Some day I wanna be using either SymbOS or FutureOS - or maybe both, and be online with my CPC and such.  :) Chatting on IRC and maintaining servers via SSH.  8)
Amstrad CPC hardware / Re: Which mouse do you use?
« Last post by GUNHED on Today at 13:09 »
Last call ... please participate  :)
I've been working on upgrading my 464+ to 6128+ spec, but, as usual, have stumbled at the first hurdle.
I've added the resistor required, the caps and the memory chips, but when I start up the CPC I get either a black screen (using a game cart), or a green screen with random hieroglyphs on. If I remove the extra 64k of ram, everything works as it should... What have I managed to mess up this time?
The memory chips I've tried are labelled NEC D41486C-10. Are these too quick or incompatible. I have 5 of them, and tried them all in different combinations, but don't really have a way of testing to see if they're good. I have gone "off road" by moving the two wires to C21 and C23 to under the PCB, but a continuity test/ohms reading suggests that I've not cocked that bit up.

h e l p!!!  :)
I would suspect the memory device.
Adding the 2nd bank even without the resistors should not prevent the cpc from working. Most of the resistors are only used to configure the ASIC and enable the 2nd bank, except R155 that route the second bank CAS from ASIC to DRAM.
If you have your additional RAM on socket, just test each additional ram individually in each socket.
If only one of the device is dead, it should prevent the CPC to start whatever the socket is.
If one socket has a problem (like CAS flying in the breeze), a device mounted on it will prevent the CPC to start.
If both device are dead, then there is no option ;)
Programming / Re: [cpctelera]Bit Arrays
« Last post by SpDizzy on Today at 12:31 »
If you are converting a lot of things, I shared my batch file to make it a lot easier.
Oh, thanks so much @EgoTrip , I hope you could finish your project  ;)
Games / Re: Toki conversion for CPC+ [ WIP ]
« Last post by XeNoMoRPH on Today at 12:10 »
maybe a ZX Spectrum version from other guy ...  8)
Amstrad CPC hardware / Re: Amstrad CPC WiFi
« Last post by Duke on Today at 09:38 »
@Duke, I am running 2.0.4 firmware, and I have a problem running "Roland in Space" from dsk:

Same thing happens when I try it, maybe there is some kind of disc protection on it, I didn't check (yet).
However the cracked version runs just fine:

Also you should really upload "Basic 1.1" + lowerrom, so you can use the RSX commands without variables :)
Amstrad CPC hardware / Re: Amstrad CPC WiFi
« Last post by LambdaMikel on Today at 07:33 »
@Duke, I am running 2.0.4 firmware, and I have a problem running "Roland in Space" from dsk:

I am using DSK A from the zip. With a$="rolspacea.dsk" (I renamed the "Side A" dsk file) , |cd,@a$, run"disc", after the "Are you using a green screen - Y / N " question (Y or N), the cassette interface relais clicks, and then the CPC basically stalls. Usually, after loading, you can hit space and the game starts. However, doesn't work with M4, space doesn't advance the game, and if I hit ESC, the CPC resets. I believe the relais click is a bad sign that somethign goes wrong on the bus. Indeed, Roladn in Space checks if the speech synth is present (SSA1 / DKtronics). It seems that this is causing a headache for M4. Notice that M4 is the only expansion being present, I got this with MotherX4 and LambdaBoard. And on 6128 and 464. Same behavior. I also tried with CPC supplied power to M4 and USB power.

I have no problem loading the same DSK file with DDI3 and speech synthesizer connected, but it "stalls" / resets the CPC with M4 and Roland in Space.

So, something is wrong....

On a second though - maybe it is trying to continue to load from tape?? In that case, how do I prevent that with M4? Sorry if this is a stupid  question.
Pages: [1] 2 3 ... 10