Author Topic: 464 black screen issue (SOLVED)  (Read 520 times)

0 Members and 1 Guest are viewing this topic.

Offline catenaccio

  • CPC464
  • **
  • Posts: 19
  • Country: es
  • Liked: 9
  • Likes Given: 8
464 black screen issue (SOLVED)
« on: 22:48, 19 January 19 »
Hi all,


This is my first post, thank you in advance


Question is that right now i only get a black screen without any border in my cpc464 after being working fine. Just a remark: some days ago i observed some video glitches, like blinking when playing (not frecuently)

Steps after turn on:
1- red light is on
2- black screen without borders, no sound pressing DEL
3- z80 chip is very hot after 2min
4- gate array chip also is hot, but i suppose this is normal because of the disipator
5- All rams chips are cold


Any chance that replacing z80 chip issue gets solved?
Tnx
« Last Edit: 18:34, 29 January 19 by catenaccio »

Offline Audronic

  • 6128 Plus
  • ******
  • Posts: 1.228
  • Country: au
  • I know RST3 . I now know a little More.
  • Liked: 280
  • Likes Given: 616
Re: 464 black screen issue
« Reply #1 on: 23:36, 19 January 19 »
@catenaccio


Please check the Voltage that is on the +5  Volt power lead First.


Good luck.  Ray
Procrastinators Unite,
If it Ain't Broke PLEASE Don't Fix it.
I keep telling you I am Not Pedantic.
As I Live " Down Under " I Take my Gravity Tablets and Wear my Magnetic Boots to Keep me from Falling off.

Offline rpalmer

  • 6128 Plus
  • ******
  • Posts: 546
  • Country: au
  • Liked: 362
  • Likes Given: 18
Re: 464 black screen issue
« Reply #2 on: 12:08, 20 January 19 »
catenaccio,The power LED comes on regardless on the state of system (it is driven by a simple transistor to let you know it is powered on).
Does the screen show any text? If it does is it garbled?

Is the CRTC chip hot or not?
Agree with Audronic, check voltages.
Also check if there is short on the elctrolytic capacitors (all of them, these are marked with stripes and a barrel in shape). These are prone to drying up resulting in a short.
rpalmer

Offline catenaccio

  • CPC464
  • **
  • Posts: 19
  • Country: es
  • Liked: 9
  • Likes Given: 8
Re: 464 black screen issue
« Reply #3 on: 12:22, 20 January 19 »
Hi again,


Voltage on the power lead is correct: 5,1v


Checking all the chips:

- ram IC119 to IC134  5v  pin 8 and 0v pin 16.
- z80 (IC111) 5v pin 11 and 0v pin 29.
- ROM (IC103)  5v pin 28 and 0v pin 14.
- IC108 5v pin 20 and 0v pin 1
- IC116 (Gate Array) 5v pin 6 and 25 and 0v in pin 15, 26, y 36,  (this is failing, I get 1v or 2,5v, never 5v)

EDITED: those values are for 40010, my ic116 is 40007. Should check again

I will check capacitors aswell
« Last Edit: 15:20, 20 January 19 by catenaccio »

Offline catenaccio

  • CPC464
  • **
  • Posts: 19
  • Country: es
  • Liked: 9
  • Likes Given: 8
Re: 464 black screen issue
« Reply #4 on: 15:20, 20 January 19 »
Edited prevoius post because my ic116 is 40007

Offline catenaccio

  • CPC464
  • **
  • Posts: 19
  • Country: es
  • Liked: 9
  • Likes Given: 8
Re: 464 black screen issue
« Reply #5 on: 17:48, 20 January 19 »
Gate array seems to be ok:

- IC116 (Gate Array) 5v pin 22 and 0v in pin 35 --> 5,12v

Online Bryce

  • The Hardware Guy.
  • Supporter
  • 6128 Plus
  • *
  • Posts: 10.945
  • Country: wf
  • It's not broken, it just hasn't been fixed yet.
    • index.php?action=treasury
  • Liked: 3860
  • Likes Given: 395
Re: 464 black screen issue
« Reply #6 on: 09:43, 21 January 19 »
There's a good chance the Z80 has failed. I'd swap it first.

Bryce.

Offline catenaccio

  • CPC464
  • **
  • Posts: 19
  • Country: es
  • Liked: 9
  • Likes Given: 8
Re: 464 black screen issue
« Reply #7 on: 12:39, 21 January 19 »

Does the screen show any text? If it does is it garbled?Is the CRTC chip hot or not?Agree with Audronic, check voltages.



Screen is totally black, no signal.
only z80 chip seems to be hotter than others



There's a good chance the Z80 has failed. I'd swap it first.

Bryce.



Yes, I already ordered a new one. Waiting to test it first before touching anything

Offline catenaccio

  • CPC464
  • **
  • Posts: 19
  • Country: es
  • Liked: 9
  • Likes Given: 8
Re: 464 black screen issue
« Reply #8 on: 22:08, 24 January 19 »
FIXED!


swapping z80 and CPC is working again!  ;D


Thanks guys for your support