CPCWiki forum

General Category => Technical Support => Topic started by: Blurredman on 23:16, 12 January 19

Title: 6128 turning on then off
Post by: Blurredman on 23:16, 12 January 19
Hey.

My final board to fix. I've had a quick look but I'm asking for any pointers to start me off.

6128 mobo.. Press the power button and the LED comes on for half a second. I've measured voltage at the 5v socket and don't seem to get anything. Obviously something, perhaps a short is cutting the power.

There is a jumper on the power switch connector, so the switch isn't a problem.

Have swapped out the easy things first, Z80, 40010 and HAL socketed chips.

Any ideas to start me off?
Title: Re: 6128 turning on then off
Post by: Bryce on 14:09, 13 January 19
Probably a short in some chip. Can you monitor the power to see if it's trying to pull a massive amount of current before it shuts down?

It's probably better to be testing this on a bench PSU, if you are using your standard CPC PSU, it may fail from this.

Bryce.
Title: Re: 6128 turning on then off
Post by: Blurredman on 13:10, 14 January 19
Unfortunately I can't really measure that with the tools I have.

Certainly, if the machine and monitor have not been turned on for a while, the LED is lit for up to 3 seconds before it goes out.
Title: Re: 6128 turning on then off
Post by: Bryce on 19:06, 15 January 19
If it’s a CPC Monitor the regulator may have failed. Do you have any other PSU to test it with?

Bryce.
Title: Re: 6128 turning on then off
Post by: Blurredman on 21:41, 15 January 19
I have an mp1 and an mp2 as well as two green screens other than my usual colour monitor. But I've not had a problem with my 464 and 3 other 6128s?

Edit: Tested the mainboard with other monitors and same problem.  ::)