Author Topic: Advice  (Read 340 times)

0 Members and 1 Guest are viewing this topic.

Offline Dagger

  • CPC664
  • ***
  • Posts: 122
  • Country: gb
  • Liked: 42
  • Likes Given: 29
Advice
« on: 15:09, 27 April 17 »
I had a CPC 464 which I that thought I would get round to seeing if I could repair. I had mentioned about this machine in the past and was told it was a faulty AY-3 Chip because of all the characters printing on the screen. My eyes are not to good  :(  but using a light with magnifying lens I managed(struggled) to remove the faulty chip. I have fitted a socket ready for a replacement chip. On removing the old chip I did damage 2 traces which run to the joystick port but I have repaired them with 2 links(wire). Anyway I thought that I would power it up with the chip removed and it still prints some 2 small lines of characters.


1st line 63RUN"
2nd Line a few numbers then symbols but then this deletes its self just leaving the 63RUN"


Should this be doing this with the Ay chip removed?
I have not tried a different AY chip yet







Life's a bitch. You marry one or two then you die !

Offline Bryce

  • The Hardware Guy.
  • Supporter
  • 6128 Plus
  • *
  • Posts: 10.976
  • Country: wf
  • It's not broken, it just hasn't been fixed yet.
    • index.php?action=treasury
  • Liked: 3874
  • Likes Given: 398
Re: Advice
« Reply #1 on: 15:13, 27 April 17 »
No, which means that something more than the AY is broken, most likely the 8255 or even the Z80.

Bryce.

Offline Dagger

  • CPC664
  • ***
  • Posts: 122
  • Country: gb
  • Liked: 42
  • Likes Given: 29
Re: Advice
« Reply #2 on: 15:21, 27 April 17 »
I don't think it is the Z80 as I am sure I changed this originally and the 40010 for working known working ones when I did'nt know about the AY chip. I will have another look tonight. So my struggle to remove the Ay was in vain  :(

Life's a bitch. You marry one or two then you die !