Author Topic: Cpc 664 sound not working  (Read 330 times)

0 Members and 1 Guest are viewing this topic.

Offline dragon

  • 6128 Plus
  • ******
  • Posts: 1.324
  • Country: es
  • Liked: 558
Cpc 664 sound not working
« on: 23:16, 22 April 18 »
I buy a (cheap 664 in ebay). It had been abandoned many years stored with other computers.


It have arrived in unkown funtionality status with the fdd dismounted.


Many keys not work, so i have order a new membrane, i have change the fdd drive belt, and i manage to generate a cat using the copy key stolen letters from the amstrad initial message, at beggining fdd return error(maybe de disk), but later it appear work and made cat with different disk o.k


But sound not appear work, del key sound in the tv using the 3,5mm jack. But internal speaker is in silence.


There is a manner i can try the speaker with a polymeter, and the two amplyfiers?. I don't have a osciloscopy.

Offline Bryce

  • The Hardware Guy.
  • Supporter
  • 6128 Plus
  • *
  • Posts: 10.430
  • Country: wf
  • It's not broken, it just hasn't been fixed yet.
    • index.php?action=treasury
  • Liked: 3610
Re: Cpc 664 sound not working
« Reply #1 on: 09:34, 23 April 18 »
Check the condition of the electrolytic capacitors around the amplifier circuitry, they might be bad.

Bryce.

Offline dragon

  • 6128 Plus
  • ******
  • Posts: 1.324
  • Country: es
  • Liked: 558
Re: Cpc 664 sound not working
« Reply #2 on: 15:03, 02 May 18 »
o.k maybe i go this friday  to change de  membrane,test the tape socket(that share 1 chip with the amp),test the fdd and sound with a game,check the speaker, check the volume roulete, chek the board connectors of volume and speaker, capacitators and in last case check the two la chips. (thats because the 664 is not in my house).

fun : D
« Last Edit: 15:05, 02 May 18 by dragon »

Offline dragon

  • 6128 Plus
  • ******
  • Posts: 1.324
  • Country: es
  • Liked: 558
Re: Cpc 664 sound not working
« Reply #3 on: 23:09, 05 May 18 »
I have the diagnostic.The speaker  is broken. I have buy one in ebay second hand spare from cpc 464, it have a pair of holes in the membrane but works!. So i in the search of a speaking in perfect state. The motheboard apperars fine, i go to mount the membrane.