3" drive...is it really dead...

Started by 00WReX, 02:39, 10 December 11

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

00WReX

Hi All,
For the last week my main 6128 (the one that sits permanaently on my desk) started giving "Read Errors" on it's internal 3" drive.
I put it down to the drive belt as it had been in since 2003.
Yesterday i fitted a brand new belt (genuine, not a rubber band or anything).
Initially it appeared OK, but then just like that it starts giving the "Read Error" again.

Ok so recently i wrote to some of these disks using the old belt, maybe that was it.
So i re-formatted these disks and again (using CPM via an external drive) and all went well and I could read the disk again...for a short period of time.
Once again the drive started giving "Read Error" when i tried to do anything.
The drive appaers to be mechanically fully functioning as I watched it with the case apart while I performed a format...disc spins up, stepper motor working...etc.
I threw another new belt in just to be sure, but same result.
Could the head alignment be out ??
Anybody got any thoughts or recommendations...I do not have any specialist test equipment...only a humble multi-meter.
Any help would be greatly appreciated as I would love to resurrect this drive.
Physically it is in great shape...inside it is spotless, no dust...it is very quiet in operation, and would be a shame if it has died.

Cheers,
Shane
The CPC in Australia...
Awa - CPCWiki

MacDeath

#1
clean the head with alcohol perhaps...

or get a 3"1/2 drive...

Also, don't store your Disk on a HiFi speacker... nor near electric cables...

Badstarr

You should try formatting the disks several times using DATA option in CPM. Do it at least 10-20 times per disk. It worked for me when I had loads of bad disks. I think writing to the disk with a failing belt causes the magnetic imprint on the disk to become a little skewed also I think a single format may leave a slight ghost 'image' of the previous data probably not much of a problem when the belt is ok but may become an issue when using a new belt after a failing one. Anyway that's my theory, whatever the reality, this method has worked great for me!
Proud owner of 464 GTM64 6128 GTM65, GX4128 and a 464/6128 Plus Hybrid a 20 year long ambition realised! :-)

Bryce

Firstly, MacDeaths advice is good. Clean the heads with a cotton bud with some vodka on it and it may solve the problem. But also remember that the disks also aren't the youngest, they may be starting to fail, not the drive.

Bryce.

00WReX

Thanks guys,
I always keep my disks away from anything magnetic. And I cleaned the head on the drive.
The drive is definately doing strange things.
I have a box of 3" disks that use day to day, all my others are safely packed and stored in a cupbaord away from any nasties.
Here is an example of what has happened...
Yesterday when I tuned off my 6128 the 3" drive was giving "Read Fail" on any disk I put in it.
I even tried a couple of my original disks that I have stored away and were written back in 1986/87/88/89. No good, same result.
I have other 6128's that read these disks fine, I now they are good.
This morning when I switched the 6128 on...same thing.
So I decided to format a couple of the disks. After that I could read the disks.
I grabbed one of the other disks that I did not format and I could now read it also.
I checked other disks, and also pulled out the old disks disks I mentioned previously and it could now read those.
So I copied a couple of those disks on the disks I'd formatted, and could read them & ran programs from them.
Later in the day the drive was half way through loading a program when I'm sure i heard a little click...then read fail again on every disk except the disks I not long ago copied can be read, but it is a though they are blank and reports 178K Free...
I had not wiped these disks, as when I copied to them earlier I then flicked the write protect tab.
If I format a disk a can write to it again...until the drive plays up again.
I think something is dying on this drive.
Cheers,
Shane
The CPC in Australia...
Awa - CPCWiki

Gryzor

I wonder, due to that click you heard... maybe the whole mechanism needs some lubing? Maybe the motor misses a step every now and then?

Badstarr

Years ago I put a little petroleum jelly on the (what you call it?) pinion? worm gear? spindle? I dunno, the bit that spins and guides the head back and forth. My 6128 was producing disks that it could read but my 464 couldn't. When I tried the same discs after that they were unreadable. Formatting the disks over and over and then writing to them produced disks that were readable in both machines. I would probably use some silicone based spray grease nowadays. This "formatting trick" also worked when I replaced the belt on my 464 drive. Its also worth checking that the guide pin that sits on the  spindle (?) hasn't come loose, I had a PCW where this had happened resulting in a click and horrible crunching sound if memory serves you just have to tighten a screw.
Proud owner of 464 GTM64 6128 GTM65, GX4128 and a 464/6128 Plus Hybrid a 20 year long ambition realised! :-)

00WReX

#7
Found some info here,

http://www.retro-zone.org/hosted_sites/ronsamstradpcwpage/index.php?menu_id=1&content_id=1

The drive issue I have seems something like this...

Head drift fault
  Another fault which is less common is when the drive appears to go out of adjustment,   and cannot find track 0 of a standard disc. The symptoms are that the head goes   to track 0, cannot identify it, so goes towards the centre of the disk. It then   returns to the outside of the disc where it again fails to find track 0 and   this cycle is repeated several times with the head travelling back and forth   across the disc until it gives up and an error message appears on the screen.   With this fault, the drive is often able to format a disc, but the disc cannot   be read by other drives as track 0 is in the wrong place. On rare occasions   it is possible to readjust the drive but I have never succeeded with a double-headed   drive yet.


I also tried moving the track 0 proximity switch. This did work for a bit but then went back.
So what I have at the moment is it will format & read disks created by itself, but will not read any other disks.When I got it working for a short period of time it would read all disks (except the ones it created as above).
I think something may be worn with the worm gear assemby...
Cheers,
Shane
The CPC in Australia...
Awa - CPCWiki

Powered by SMFPacks Menu Editor Mod