Author Topic: CPC464 works with monitor but no power with TV kit  (Read 4125 times)

0 Members and 1 Guest are viewing this topic.

Offline Macc

  • CPC6128
  • ****
  • Posts: 150
  • Country: gb
    • Awards
CPC464 works with monitor but no power with TV kit
« on: 13:18, 16 February 13 »
A mate of mine (I must get him registered here!) has another 464, this is all good until he tries to power it with the TV kit, no power, powers up every other 464 he has just not that one.  A green screen monitor powers up the CPC no problem, this sounds a bit weird!
like
0
No reactions

Offline IanS

  • Supporter
  • CPC6128
  • *
  • Posts: 198
  • Country: gb
    • index.php?action=treasury
    • Awards
Re: CPC464 works with monitor but no power with TV kit
« Reply #1 on: 14:08, 16 February 13 »
When using the TV Kit, does the red light on the CPC come on?

Does the CPC show a picture on the TV if powered from the green screen monitor? (so just using the monitor as a power supply).

Does the red light on the CPC come on or flicker (leave the CPC power switch on) when you wiggle or insert the TV kit power supply?
like
0
No reactions

Offline Macc

  • CPC6128
  • ****
  • Posts: 150
  • Country: gb
    • Awards
Re: CPC464 works with monitor but no power with TV kit
« Reply #2 on: 14:53, 16 February 13 »
no, yes and no mate
like
0
No reactions

Offline Munchausen

  • 6128 Plus
  • ******
  • Posts: 779
  • Country: gb
    • Awards
Re: CPC464 works with monitor but no power with TV kit
« Reply #3 on: 15:16, 16 February 13 »
So a PSU issue.


Maybe that is a slightly different PCB revision that needs slightly more voltage/current for some reason... what is the power rating on the PSU?
like
0
No reactions

Offline steve

  • Supporter
  • 6128 Plus
  • *
  • Posts: 1.263
  • Country: gb
    • Awards
Re: CPC464 works with monitor but no power with TV kit
« Reply #4 on: 15:16, 16 February 13 »
Since the power supply runs other 464s, it is logical to think that the power input socket on the one 464 that does not work, is not making proper contact with the power plug.
Adjusting the position of the socket contacts might help, or cleaning them and the plug.
like
0
No reactions

Offline IanS

  • Supporter
  • CPC6128
  • *
  • Posts: 198
  • Country: gb
    • index.php?action=treasury
    • Awards
Re: CPC464 works with monitor but no power with TV kit
« Reply #5 on: 15:21, 16 February 13 »
no, yes and no mate
If the TV kit is ok with other CPC's then I can only guess that the problem is a mismatch between the size of the power connector on the TV Kit and the socket on the 464. No idea why it only affects this one CPC.
like
0
No reactions

Offline BluesBrothers

  • CPC6128
  • ****
  • Posts: 269
  • Country: england
    • Awards
Re: CPC464 works with monitor but no power with TV kit
« Reply #6 on: 16:16, 16 February 13 »
Ok so I just regesitered after some bullying from Macc to do so. Cheers Macc for your help so far.
For those who haven't already guessed this is one of my CPC's that we're talking about so I'll fill you all in a bit more.
The power socket was a brand new replacement. There was actuallt nothing wrong with the original other than it was looking old and crusty so after reading the advice above I put it back on the board and unfortunately the results are the same.
What is weird is that with all my other CPC's all I have to do is insert power and switch on and the led lights up indicating power. With this one I also have to have the monitor connector inserted. Straight away this makes me think "is some current available through the monitor connection which is helping to power up". This would in turn explain why an external psu and TV scart lead are not working, or as Macc suggested to me, maybe a grounding issue?
I know faults to the board are not always visible but I'm struggling to see anything suspicious with the circuitry
Any advice welcome
like
0
No reactions

Offline steve

  • Supporter
  • 6128 Plus
  • *
  • Posts: 1.263
  • Country: gb
    • Awards
Re: CPC464 works with monitor but no power with TV kit
« Reply #7 on: 16:38, 16 February 13 »
I can only think that the plug is not making proper contact with the socket since the monitor does power the cpc, yet the ext.psu will power other cpc's suggesting that the difference in dimensions is tiny.

Maybe it is a prpblem with current supply, but I cannot advise there.
« Last Edit: 16:41, 16 February 13 by steve »
like
0
No reactions

Offline BluesBrothers

  • CPC6128
  • ****
  • Posts: 269
  • Country: england
    • Awards
Re: CPC464 works with monitor but no power with TV kit
« Reply #8 on: 16:43, 16 February 13 »
Ok I'm gonna try putting this socket on another working board and see what happens.
Still weirded out by the monitor video output though. It is definately odd that I'd need this to be connected just to get the CPC to power up and no other CPC I own (and I do have a fair few) acts this way
Anyway will report back with results
like
0
No reactions

Offline BluesBrothers

  • CPC6128
  • ****
  • Posts: 269
  • Country: england
    • Awards
Re: CPC464 works with monitor but no power with TV kit
« Reply #9 on: 16:59, 16 February 13 »
Put the power socket in another board and tried with both TV kit and monitor and both work fine so not the power socket
like
0
No reactions

Offline BluesBrothers

  • CPC6128
  • ****
  • Posts: 269
  • Country: england
    • Awards
Re: CPC464 works with monitor but no power with TV kit
« Reply #10 on: 17:03, 16 February 13 »
Since the power supply runs other 464s, it is logical to think that the power input socket on the one 464 that does not work, is not making proper contact with the power plug.
Adjusting the position of the socket contacts might help, or cleaning them and the plug.

The power rating on the PSU is 5V 3A (15W). It is one supplied by ebay seller Retro Computer Shack and I have never had any issues with it before and I have had dozens of CPC's running with it over the time I've had it
like
0
No reactions

Offline IanS

  • Supporter
  • CPC6128
  • *
  • Posts: 198
  • Country: gb
    • index.php?action=treasury
    • Awards
Re: CPC464 works with monitor but no power with TV kit
« Reply #11 on: 17:05, 16 February 13 »
What is weird is that with all my other CPC's all I have to do is insert power and switch on and the led lights up indicating power. With this one I also have to have the monitor connector inserted.
Sounds like a bad ground connection on the power connection. The monitor connector is probably acting as the ground path for the power supply.
like
0
No reactions

Offline BluesBrothers

  • CPC6128
  • ****
  • Posts: 269
  • Country: england
    • Awards
Re: CPC464 works with monitor but no power with TV kit
« Reply #12 on: 18:45, 16 February 13 »
Just ran a wire along one end of grd track to the other and success so yes it was a grounding issue as suspected.
Cheers fellas :D
like
0
No reactions

Offline TheCorfiot

  • CPC664
  • ***
  • Posts: 61
  • Country: wales
  • Amibay Administrator
    • Awards
Re: CPC464 works with monitor but no power with TV kit
« Reply #13 on: 18:49, 16 February 13 »
Sounds like a bad ground connection on the power connection. The monitor connector is probably acting as the ground path for the power supply.

Defnitely this


Oops just seen the response  :laugh:
like
0
No reactions

Offline BluesBrothers

  • CPC6128
  • ****
  • Posts: 269
  • Country: england
    • Awards
Re: CPC464 works with monitor but no power with TV kit
« Reply #14 on: 19:25, 16 February 13 »
Ouch! Just as everything looked ok I've now lost picture. Still got power but pic gone. Checked solder and looks good, reflowed again just to be sure. Aggggghhhhhhhhh :(
like
0
No reactions

Offline BluesBrothers

  • CPC6128
  • ****
  • Posts: 269
  • Country: england
    • Awards
Re: CPC464 works with monitor but no power with TV kit
« Reply #15 on: 23:31, 17 February 13 »
Had to walk away from this one for a bit before it became a missile but back looking at it again.
The monitor now only gives a white screen. It did flicker some other colours and once I got a proper screen although the text was scrambled, when I fiddled around with the connector. I then desoldered it, cleaned it up and put it back, now just white screen.
Also it now will not power the LED to indicate power. The LED has not gone because I tried it with a working board and everything was as it should be.
Before I go mad trying loads of stuff does anyone fancy offering up some pointers to help save me further frustration
like
0
No reactions

Offline Bryce

  • The Hardware Guy.
  • Supporter
  • 6128 Plus
  • *
  • Posts: 12.503
  • Country: wf
  • It's not broken, it just hasn't been fixed yet.
    • index.php?action=treasury
    • Awards
Re: CPC464 works with monitor but no power with TV kit
« Reply #16 on: 23:46, 17 February 13 »
Do you have a multimeter or oscilloscope?

Bryce.
like
0
No reactions

Offline BluesBrothers

  • CPC6128
  • ****
  • Posts: 269
  • Country: england
    • Awards
Re: CPC464 works with monitor but no power with TV kit
« Reply #17 on: 23:48, 17 February 13 »
I have a digital multimeter. oscilliscope - I wish!
like
0
No reactions

Offline Bryce

  • The Hardware Guy.
  • Supporter
  • 6128 Plus
  • *
  • Posts: 12.503
  • Country: wf
  • It's not broken, it just hasn't been fixed yet.
    • index.php?action=treasury
    • Awards
Re: CPC464 works with monitor but no power with TV kit
« Reply #18 on: 23:54, 17 February 13 »
Does the LED go on if the RGB cable to the monitor isn't connected?

Measure the voltage on each of the R,G, and B output pins with the monitor disconnected.

Bryce.
like
0
No reactions

Offline BluesBrothers

  • CPC6128
  • ****
  • Posts: 269
  • Country: england
    • Awards
Re: CPC464 works with monitor but no power with TV kit
« Reply #19 on: 00:24, 19 February 13 »
Sorry Bryce for the abscence. Just as you want to get on with fixing something life happens and you have to pack everything away again and deal with "stuff".
 
I'll be back on tomorrow evening with the readings but no to the LED question
 
Thanks for you're patience
like
0
No reactions

Offline manic23

  • CPC464
  • **
  • Posts: 35
  • Country: gb
    • Awards
Re: CPC464 works with monitor but no power with TV kit
« Reply #20 on: 01:57, 19 April 15 »
Hi BB I realise that this is an old thread but I was wondering if you ever got this fixed, only because I have a CPC464 with exactly the same issue as you and I have been looking for a fix for ages. Was it the earth line in the end?
like
0
No reactions