Author Topic: 464 video corruption.. CRTC ?  (Read 554 times)

0 Members and 1 Guest are viewing this topic.

Offline retro_4_ever

  • CPC464
  • **
  • Posts: 33
  • Country: gb
    • Awards
464 video corruption.. CRTC ?
« on: 16:53, 26 October 21 »
i have a strange fault with a 464, it has intermittent video corruption (ghosting of text, screen interference etc characters showing corruption) very intermittent can be fine for hours then just starts or can start from cold boot as well .. also noticed that when tape deck is played it has a similar effect, but it does it without the tape deck running as well..
also very occasional crash .. i have replaced the ram as they were faulty,, i have partially checked them and swopped them in the belief that if one is faulty it would have a different effect in a different bank .. was suspecting the CRTC but now  unsure .. tried different Z80 & ULA (40007) .. changed the rom as well , but it does it when running from rom board as well and passes the diagnostic ram test...
any ideas .. ? i was going to pull the CRTC but then realized it did it with the tape deck as well made me re consider i also believe the few times it has crashed was when i pressed the play on the tape  but this could be coincidence

like
1
Members reacted like:
retro_4_ever,

Offline llopis

  • Supporter
  • 464 Plus
  • *
  • Posts: 312
  • Country: es
    • Noel's Retro Lab
    • Awards
Re: 464 video corruption.. CRTC ?
« Reply #1 on: 23:47, 26 October 21 »
Something like ghosting of text makes me think of the kind of problem a slightly faulty Gate Array could create. I wonder if your power supply has trouble getting enough current and voltages are running slightly low (which would be even worse when you run the tape deck). Are you using the monitor as power supply or are you using an external one?

like
1
Members reacted like:
retro_4_ever,

Offline ajcasado

  • Supporter
  • CPC664
  • *
  • Posts: 91
  • Country: es
    • Awards
Re: 464 video corruption.. CRTC ?
« Reply #2 on: 23:54, 26 October 21 »
Have you ruled out dc power issues?
like
1
Members reacted like:
retro_4_ever,
CPC 664

Empiezas a envejecer cuando dejas de aprender.
You start to get old when you stop learning.

Offline lmimmfn

  • CPC464
  • **
  • Posts: 32
  • Country: ie
    • Awards
Re: 464 video corruption.. CRTC ?
« Reply #3 on: 03:35, 27 October 21 »
Have you ruled out dc power issues?
Yes, first thing i would check.
like
1
Members reacted like:
retro_4_ever,
6128 for the win!!!

Offline RetroCPC

  • CPC6128
  • ****
  • Posts: 150
  • Country: hk
    • Awards
Re: 464 video corruption.. CRTC ?
« Reply #4 on: 04:57, 27 October 21 »
Dirty power switch resulting in too much voltage drop across it?... you can bypass it for confirmation...
like
1
Members reacted like:
retro_4_ever,

Offline retro_4_ever

  • CPC464
  • **
  • Posts: 33
  • Country: gb
    • Awards
Re: 464 video corruption.. CRTC ?
« Reply #5 on: 12:16, 27 October 21 »
thanks for the replies ,, i am using a ATX power supply that provides 5v, 2amp on its stand by line and have used it on CPC's without problem, also used it yesterday on another cpc without problem  . i did replace the smoothing capacitor  but not the dc barrel (i will do this today) ..  i also have a more appropriate power supply that i will try just to be sure. i did clean the power switch contacts but i think i will bypass it to rule it out as suggested ..  unfortunately it has the tape deck with the later connector and i don't think i have one another one that works..
 
will update with the results .. many thanks mark.
like
0
No reactions

Offline retro_4_ever

  • CPC464
  • **
  • Posts: 33
  • Country: gb
    • Awards
Re: 464 video corruption.. CRTC ?
« Reply #6 on: 14:35, 27 October 21 »
ohh thats interesting .. i was running the dc through a cheap volt/amp meter to monitor the current draw .. this perhaps is a mistake .. when i measured the voltage at the power switch it was showing 4.55 volts with the computer active .. and when i removed the volt/amp meter it was showing 4.73v  (5.15 volts when the switch is off in both cases)  and 4.72 volts & 4.92 volts respectively at the actual power jack with & without the meter ..and so far with the meter removed all faults have gone .. oops silly me ...
like
0
No reactions

Offline 1024MAK

  • Supporter
  • 464 Plus
  • *
  • Posts: 364
  • Country: gb
  • Touching the hot end of an iron will hurt!
    • Awards
Re: 464 video corruption.. CRTC ?
« Reply #7 on: 17:53, 27 October 21 »
Ah, as you have discovered, current meters cause a voltage drop to the load that they are connected to.

You don’t get anything (much) for free, including with test equipment…

Mark
like
1
Members reacted like:
retro_4_ever,
Looking forward to summer in Somerset :-)

Offline Devlin

  • CPC6128
  • ****
  • Posts: 165
  • Country: gb
    • Magicbane
    • Awards
Re: 464 video corruption.. CRTC ?
« Reply #8 on: 19:29, 27 October 21 »
Ah, as you have discovered, current meters cause a voltage drop to the load that they are connected to.

You don’t get anything (much) for free, including with test equipment…

Mark


I got weird mode artifacting for a long time due to dirt in the DC power connector and power switch - also re-seated all socketed chips and cleaned them to guarantee a good connection and my 464's been rock solid since, even with the usifac2 connected to it.
like
1
Members reacted like:
retro_4_ever,
Amstrad fan! | CPC464 + USIfAC II | Administrator of Amstrad Discord : https://discord.gg/ksWvApv