Author Topic: GX4000 video-processing questions  (Read 8541 times)

0 Members and 1 Guest are viewing this topic.

Offline ArcadeTV

  • CPC664
  • ***
  • Posts: 50
  • Country: de
  • RGB or Nothing!
    • index.php?action=treasury
    • Me on circuit-board.de
    • Awards
Re: GX4000 video-processing questions
« Reply #25 on: 13:22, 24 March 15 »
I've been reading this
Digital to Analog Conversion

and I thought it would be related to the opamp when he wrote
Quote
Unfortunately, there are several practical problems with this circuit. First, most digital logic gates do not accurately produce 0 and +5 volts at their outputs. Therefore, the resulting analog voltages will be close, but not really accurate. In addition, the different input resistors will load the digital circuit outputs differently, which will almost certainly result in different voltages being applied to the summer inputs.

I have no experience in this - what values shall I use for the resistors to start with.
And I guess the circuit will look like this in the end...
like
0
No reactions

Offline Bryce

  • The Hardware Guy.
  • Supporter
  • 6128 Plus
  • *
  • Posts: 12.502
  • Country: wf
  • It's not broken, it just hasn't been fixed yet.
    • index.php?action=treasury
    • Awards
Re: GX4000 video-processing questions
« Reply #26 on: 14:54, 24 March 15 »
Let's take a similar circuit. I've used a general purpose Op-Amp (LM318) here, but any general purpose Op-Amp that's fast enough will do.

The R2R resistors: The actual values aren't that important as the R2R is a proportional circuit. The current is much more important than the voltage in this case. If the value of R is too low you'll be pulling too much current from the TTL outputs and you'll damage the chip (in this case the ASIC!). If the values are too high the current at the Op-Amps input will be below the Op-Amps Input bias current and the Op-Amp won't output anything. I've choosen 10K/20K (so as not to clutter the schematic), but 100K/200K would also be fine as the LM318 has an Ib of just 120nA. (Just for info: with 10K/20K you'll pull about 125µA per pin at 100K/200K you'll pull about 12.5µA per pin - both high enough to bias the Op-Amp).
The only resistor value you really need to calculate is Rf, the Op-Amp feedback resistor. I would suggest calculating this roughly and using a suitable variable resistor to tune the circuit when it's built. The calculation will only be rough because it's ignoring certain losses in the circuit etc.

The maths: You can calculate the voltage at Vout with: Vout = 1.66 x (Rf/2R) x Dec    where Dec is the decimal value on the bus.
So Vmax is approx. 25 x (Rf/2R)

Hope that helped.

Bryce.

Note: To those who are about to post "Aaargghh, that's all wild approximations and you've rounded off the figures" - Yes, This is a simple Video DAC with a variable resistor to tune it. I'm not trying to design the input stage of a Keithley precision DMM here, just some rough figures.


« Last Edit: 15:01, 24 March 15 by Bryce »
like
0
No reactions

Offline ArcadeTV

  • CPC664
  • ***
  • Posts: 50
  • Country: de
  • RGB or Nothing!
    • index.php?action=treasury
    • Me on circuit-board.de
    • Awards
Re: GX4000 video-processing questions
« Reply #27 on: 15:05, 24 March 15 »
Yes, that helped a lot. I can absolutely work with that.
A heartfelt THANK YOU to you Mr. Bryce ^^
like
0
No reactions

Offline Bryce

  • The Hardware Guy.
  • Supporter
  • 6128 Plus
  • *
  • Posts: 12.502
  • Country: wf
  • It's not broken, it just hasn't been fixed yet.
    • index.php?action=treasury
    • Awards
Re: GX4000 video-processing questions
« Reply #28 on: 15:07, 24 March 15 »
If you need to "sharpen the edges" (ie: picture is still blurred), try adding a 10pf capacitor in parallel with Rf.

Bryce.
like
0
No reactions

Offline ArcadeTV

  • CPC664
  • ***
  • Posts: 50
  • Country: de
  • RGB or Nothing!
    • index.php?action=treasury
    • Me on circuit-board.de
    • Awards
Re: GX4000 video-processing questions
« Reply #29 on: 12:49, 10 April 15 »
Could it be that the lines need to be inverted first?
I'm getting strange results and it all points to the 4 bits of each color coming from the ASIC.
Right now the TV-screen is veeery dark, when I turn up the brightness real hard I can see the image but it's inverted. This is definitely not related to the order of LSB to MSB.
I'm not a pro so I have to ask, when using a 74**04 logic ic to invert the signals first, do I need to add any parts besides the IC and maybe a 100nF bypass-cap?

Thanks!
like
0
No reactions

Offline Bryce

  • The Hardware Guy.
  • Supporter
  • 6128 Plus
  • *
  • Posts: 12.502
  • Country: wf
  • It's not broken, it just hasn't been fixed yet.
    • index.php?action=treasury
    • Awards
Re: GX4000 video-processing questions
« Reply #30 on: 13:20, 10 April 15 »
Try swapping pins 2 and 3 on the op-amp. To adjust the brightness vary the value of Rf slightly.

Bryce.
like
0
No reactions

Offline ArcadeTV

  • CPC664
  • ***
  • Posts: 50
  • Country: de
  • RGB or Nothing!
    • index.php?action=treasury
    • Me on circuit-board.de
    • Awards
Re: GX4000 video-processing questions
« Reply #31 on: 14:42, 07 January 16 »
Just wanted to say that I haven't abandoned this project...
2015 was a really tuff year and I just couldn't find the time and encouragement to dig deeper.

Anyways, I've had some results with the diy-DAC -
the pixels were as sharp as they could ever be :) but the colors felt wrong somehow.

I'll prepare a summary in the next couple'o'days so if you don't mind I'll be bugging you a little more with this  :D
like
0
No reactions

Offline Munchausen

  • 6128 Plus
  • ******
  • Posts: 779
  • Country: gb
    • Awards
Re: GX4000 video-processing questions
« Reply #32 on: 11:19, 18 February 16 »
Why is it that the outputs of the 40464 (which are also the monitor connectors) are so dark? I wired up an RGBs connector to the 40464 on my GX4000 to bypass most of the video circuitry yesterday and I also have to turn the brightness, contrast and saturation to 100% to see a picture, and it is still quite dark. I can put an amplifier there, but shouldn't they really be enough already? The original 6128/464 machines don't do this, and as far as I understand people are using SCART cables on plus machines without the issue?
like
0
No reactions

Offline Bryce

  • The Hardware Guy.
  • Supporter
  • 6128 Plus
  • *
  • Posts: 12.502
  • Country: wf
  • It's not broken, it just hasn't been fixed yet.
    • index.php?action=treasury
    • Awards
Re: GX4000 video-processing questions
« Reply #33 on: 11:24, 18 February 16 »
Can you explain exactly how you wired it up. Didi you disconnect the 40464 output pins from the PCB to isolate them from the rest of the circuit? How did you terminate the signals?

Bryce.
like
0
No reactions

Offline Munchausen

  • 6128 Plus
  • ******
  • Posts: 779
  • Country: gb
    • Awards
Re: GX4000 video-processing questions
« Reply #34 on: 11:43, 18 February 16 »
Can you explain exactly how you wired it up. Didi you disconnect the 40464 output pins from the PCB to isolate them from the rest of the circuit? How did you terminate the signals?

Bryce.

I've got 220 ohm in series from the 40464 RGB pins to the connector and have cut the traces from them after the diodes (D132-D134, which are actually pairs of diodes contrary to the schematic) so the diodes are still in circuit. It's wired from pins 17,16,15 as RGB, pin 10 as GND and direct to the ASIC (pin 118 IIRC) for sync (I don't have a resistor on the sync line, but I don't think that is the problem as it is syncing fine).

Is 220 ohm too much? Shall I try 75?
like
0
No reactions

Offline gerald

  • Supporter
  • 6128 Plus
  • *
  • Posts: 1.582
    • Awards
Re: GX4000 video-processing questions
« Reply #35 on: 11:47, 18 February 16 »
Why is it that the outputs of the 40464 (which are also the monitor connectors) are so dark? I wired up an RGBs connector to the 40464 on my GX4000 to bypass most of the video circuitry yesterday and I also have to turn the brightness, contrast and saturation to 100% to see a picture, and it is still quite dark. I can put an amplifier there, but shouldn't they really be enough already? The original 6128/464 machines don't do this, and as far as I understand people are using SCART cables on plus machines without the issue?
Some point to not forget :
- 40464 output level will be different whether you power the GX4000 with 5V or 12V. With 5V, they will be lower.
- The SCART output are buffered
- the CM14 monitor has 100 ohm input, a TV or normal monitor usually have 75 ohm input.
like
0
No reactions

Offline Munchausen

  • 6128 Plus
  • ******
  • Posts: 779
  • Country: gb
    • Awards
Re: GX4000 video-processing questions
« Reply #36 on: 12:03, 18 February 16 »
Some point to not forget :
- 40464 output level will be different whether you power the GX4000 with 5V or 12V. With 5V, they will be lower.
- The SCART output are buffered
- the CM14 monitor has 100 ohm input, a TV or normal monitor usually have 75 ohm input.

Yeah, so I'm not using the SCART buffering. I'm powering with 12V. I also tried with no resistors and it has the same effect. This is to a GBS8200 in fact, but I also tried on an LCD monitor and it has the same issue.
like
0
No reactions

Offline Munchausen

  • 6128 Plus
  • ******
  • Posts: 779
  • Country: gb
    • Awards
Re: GX4000 video-processing questions
« Reply #37 on: 14:26, 18 February 16 »
So I tried with:

75ohms
75ohms and 220uF cap

No change. Also, I tried through one of Bryce's s-video converters, and I get no picture with that. Think I need to make an amp.
like
0
No reactions