Author Topic: Issue 3" drive rotation speed  (Read 1324 times)

0 Members and 1 Guest are viewing this topic.

Offline Kris

  • 6128 Plus
  • ******
  • Posts: 557
  • Country: fr
  • Team Impact
  • Liked: 220
  • Likes Given: 844
Issue 3" drive rotation speed
« on: 15:49, 27 April 17 »
Hello all,


I just face a strange behaviour with my 3" drive: I just change the drive belt and run "RPM" software to set up the rotation speed.
Result is that rotation is read as "600 RPM" instead of 300; the soft display in continue 600 600 300 600 600...Etc

Edit: I just try this drive into another CPC and it works perfectly (RPM gave about 300 Rpm).
It means that a component into the CPC is defective but which one ? FDC ?

Any idea about what is wrong  ?
Thank you
« Last Edit: 16:00, 27 April 17 by Kris »

Offline Bryce

  • The Hardware Guy.
  • Supporter
  • 6128 Plus
  • *
  • Posts: 11.795
  • Country: wf
  • It's not broken, it just hasn't been fixed yet.
    • index.php?action=treasury
  • Liked: 4249
  • Likes Given: 446
Re: Issue 3" drive rotation speed
« Reply #1 on: 16:33, 27 April 17 »
Crazy RPM readings can be caused by an intermittent 12V rail. Check for dry joints on all the connectors, especially the ones to the motor. Also make sure that you have removed all the old gunk on the two belt wheels.

Bryce.

Offline Kris

  • 6128 Plus
  • ******
  • Posts: 557
  • Country: fr
  • Team Impact
  • Liked: 220
  • Likes Given: 844
Re: Issue 3" drive rotation speed
« Reply #2 on: 16:41, 27 April 17 »
The drive is working perfectly onto another CPC so it does not come from the motor etc... but from the CPC itself.
Everything welding point are good on the drive side and old drive belt wheels have been fully cleaned.


I also use the same monitor and 12V from it is good and stable.

Offline Bryce

  • The Hardware Guy.
  • Supporter
  • 6128 Plus
  • *
  • Posts: 11.795
  • Country: wf
  • It's not broken, it just hasn't been fixed yet.
    • index.php?action=treasury
  • Liked: 4249
  • Likes Given: 446
Re: Issue 3" drive rotation speed
« Reply #3 on: 16:49, 27 April 17 »
Yes, but even moving the drive from one computer to the other can be enough to temporarily "re-join" a dry joint.

Bryce.

Offline Kris

  • 6128 Plus
  • ******
  • Posts: 557
  • Country: fr
  • Team Impact
  • Liked: 220
  • Likes Given: 844
Re: Issue 3" drive rotation speed
« Reply #4 on: 17:44, 27 April 17 »
To be sure, I just rework 100% of the welding point on the drive: results is the same: not OK on the original CPC but works perfectly on all the other ones.


Offline Bryce

  • The Hardware Guy.
  • Supporter
  • 6128 Plus
  • *
  • Posts: 11.795
  • Country: wf
  • It's not broken, it just hasn't been fixed yet.
    • index.php?action=treasury
  • Liked: 4249
  • Likes Given: 446
Re: Issue 3" drive rotation speed
« Reply #5 on: 17:46, 27 April 17 »
That's wierd. Possibly a crack in the wires from the mainboard? Or dodgy terminals in the power connector? Try spinning up the disk and see if you can get it to stop by moving the power wires.

Bryce.

Offline Kris

  • 6128 Plus
  • ******
  • Posts: 557
  • Country: fr
  • Team Impact
  • Liked: 220
  • Likes Given: 844
Re: Issue 3" drive rotation speed
« Reply #6 on: 18:42, 27 April 17 »
The issue is coming from the CPC : I installed a drive from another fully working 6128 and got the same result of 600-610 RPM....
VEry strange, I continue to investigate.


Offline Kris

  • 6128 Plus
  • ******
  • Posts: 557
  • Country: fr
  • Team Impact
  • Liked: 220
  • Likes Given: 844
Re: Issue 3" drive rotation speed
« Reply #7 on: 14:07, 30 January 18 »
Back on this issue, I still don't have any idea how to fix it....help wanted  ;)

Offline Bryce

  • The Hardware Guy.
  • Supporter
  • 6128 Plus
  • *
  • Posts: 11.795
  • Country: wf
  • It's not broken, it just hasn't been fixed yet.
    • index.php?action=treasury
  • Liked: 4249
  • Likes Given: 446
Re: Issue 3" drive rotation speed
« Reply #8 on: 14:23, 30 January 18 »
Send me the CPC (just PCB) if you like.

Bryce.

Offline Kris

  • 6128 Plus
  • ******
  • Posts: 557
  • Country: fr
  • Team Impact
  • Liked: 220
  • Likes Given: 844
Re: Issue 3" drive rotation speed
« Reply #9 on: 20:46, 30 January 18 »
Why not; let's continue on PM

Offline gerald

  • Supporter
  • 6128 Plus
  • *
  • Posts: 1.501
  • Liked: 1045
  • Likes Given: 257
Re: Issue 3" drive rotation speed
« Reply #10 on: 22:04, 30 January 18 »
Did you check the index signal from the drive to the FDC ?

Offline Kris

  • 6128 Plus
  • ******
  • Posts: 557
  • Country: fr
  • Team Impact
  • Liked: 220
  • Likes Given: 844
Re: Issue 3" drive rotation speed
« Reply #11 on: 15:09, 07 February 18 »
At the moment, I did not take time to check any components but I will do it this evening (I own an oscilloscope but any help would be grateful) :)


Here are what RPM soft give me as results (602 RPM - note that this drive has been correctly calibrated @300RPM - track 19 with an other CPC ).