Author Topic: Problem screen border black and paper blue  (Read 6887 times)

0 Members and 1 Guest are viewing this topic.

Offline Livingstone

  • CPC464
  • **
  • Posts: 10
  • Country: es
  • Opera Soft forever
  • Liked: 1
  • Likes Given: 5
Problem screen border black and paper blue
« on: 20:25, 23 March 09 »
Hello, I have a problem with a two Amstrad CPC 464. When light is shown as black border and the wallpaper of a blue and green. What can cause this?  ???
 Thanks for answering
I can upload photos. :P

Offline Gryzor

  • Administrator
  • 6128 Plus
  • *****
  • Posts: 15.707
  • Country: gr
  • CPC-Wiki maintainer
    • CPCWiki
  • Liked: 3250
  • Likes Given: 5910
Re: Problem screen border black and paper blue
« Reply #1 on: 20:34, 23 March 09 »
Please do upload fotos... I, for one, cannot understand the problem :D

Offline arnoldemu

  • Supporter
  • 6128 Plus
  • *
  • Posts: 5.336
  • Country: gb
    • Unofficial Amstrad WWW Resource
  • Liked: 2269
  • Likes Given: 3478
Re: Problem screen border black and paper blue
« Reply #2 on: 22:00, 23 March 09 »
Hello, I have a problem with a two Amstrad CPC 464. When light is shown as black border and the wallpaper of a blue and green. What can cause this?  ???
 Thanks for answering
I can upload photos. :P
Hmm... I think that the connection to the monitor/tv is dodgy.
Try moving the connector from the monitor up and down a bit.
I think one of the colours (probably red) is not comming through.
My games. My Games
My website with coding examples: Unofficial Amstrad WWW Resource

Offline Livingstone

  • CPC464
  • **
  • Posts: 10
  • Country: es
  • Opera Soft forever
  • Liked: 1
  • Likes Given: 5
Re: Problem screen border black and paper blue
« Reply #3 on: 18:17, 25 March 09 »
Hello, sorry for the delay, upload your photos here.  :-\
 You will see that I thought the problem would be in the memory modules. I installed sockets to fit the memory chips.  :'(
 Remember:
 1) A switch on the computer displays a blue background and black border.
 2) Another switch on the computer displays a green background and black border.
 3) I choose to put sockets on both computers to fit the memory chips.
 4) Make sure the memory chips reposition the result is the same.
 5) Exchange the memory chips of a computer (4164-B15) and (LH 2164-15), and the result is the same.

 As you will see I have photographed the underside of the chips, do you have anything to do with the numbers printed next to the order of position? Does the same as the chips are placed?
 I think that the computer shows me the green screen problem can be the ULA but I'm not sure, I can not verify it.
 Is there any way to replace the 4164-B15 by current chips?




Offline arnoldemu

  • Supporter
  • 6128 Plus
  • *
  • Posts: 5.336
  • Country: gb
    • Unofficial Amstrad WWW Resource
  • Liked: 2269
  • Likes Given: 3478
Re: Problem screen border black and paper blue
« Reply #4 on: 11:44, 26 March 09 »
Hello, sorry for the delay, upload your photos here.  :-\
 You will see that I thought the problem would be in the memory modules. I installed sockets to fit the memory chips.  :'(
 Remember:
 1) A switch on the computer displays a blue background and black border.
 2) Another switch on the computer displays a green background and black border.
 3) I choose to put sockets on both computers to fit the memory chips.
 4) Make sure the memory chips reposition the result is the same.
 5) Exchange the memory chips of a computer (4164-B15) and (LH 2164-15), and the result is the same.

 As you will see I have photographed the underside of the chips, do you have anything to do with the numbers printed next to the order of position? Does the same as the chips are placed?
 I think that the computer shows me the green screen problem can be the ULA but I'm not sure, I can not verify it.
 Is there any way to replace the 4164-B15 by current chips?




Hmmm.. that is not good.
Ok if you press delete with the volume turned up do you hear anything?
if so the computer is working ok and there is a problem between video and monitor.
Do you have a multimeter or oscilloscope?
could you check the clocks going into CRTC (6845 chip should be 1Mhz, AY-3-8912 chip should be 1Mhz, Z80 should be 4Mhz, and Gate-Array 40010 or 40009 or 40007 should be 16Mhz).
As for being ULA that is possible, and if it is your going to have trouble replacing. Have you tried swapping the z80 out and putting another in that is working?
 
My games. My Games
My website with coding examples: Unofficial Amstrad WWW Resource

Offline Livingstone

  • CPC464
  • **
  • Posts: 10
  • Country: es
  • Opera Soft forever
  • Liked: 1
  • Likes Given: 5
Re: Problem screen border black and paper blue
« Reply #5 on: 20:11, 26 March 09 »
Hmmm.. that is not good.
 
Ok if you press delete with the volume turned up do you hear anything?
 
if so the computer is working ok and there is a problem between video and monitor.
Do you have a multimeter or oscilloscope?
could you check the clocks going into CRTC (6845 chip should be 1Mhz, AY-3-8912 chip should be 1Mhz, Z80 should be 4Mhz, and Gate-Array 40010 or 40009 or 40007 should be 16Mhz).
 
As for being ULA that is possible, and if it is your going to have trouble replacing. Have you tried swapping the z80 out and putting another in that is working?


 
- Yes that is not good.  :'(

- I can not hear anything. Then the problem is the computer not the monitor.
- I have a multimeter but I do not know how to measure the clock.  ???
- Nor is the Z80, I have tested with a processor that works ok.

Offline arnoldemu

  • Supporter
  • 6128 Plus
  • *
  • Posts: 5.336
  • Country: gb
    • Unofficial Amstrad WWW Resource
  • Liked: 2269
  • Likes Given: 3478
Re: Problem screen border black and paper blue
« Reply #6 on: 20:37, 26 March 09 »

 
- Yes that is not good.  :'(

- I can not hear anything. Then the problem is the computer not the monitor.
- I have a multimeter but I do not know how to measure the clock.  ???
- Nor is the Z80, I have tested with a processor that works ok.
My multimeter has a HZ setting.
You can switch it to that and then put one connector to the clock pin and other to ground and get a read out.
 
http://www.grimware.org/doku.php/documentations/repository#manuals
 
Service Manual for cpc464 here.
 
Have you tried swapping the ULA (40007/40010) between the 464's in case one ULA is good and there are different problems with each computer?
 
With the "beep" I was wondering if the computer is actually running and executing instructions but the display was broken.
 
another thing to check, is that there is power going to each of the chips (rom, ula, crtc).
rom is something like 40032, ula is 40007 or 40010, crtc is 6845 and could be HD6845, UM6845 or MC6845.
 
 
My games. My Games
My website with coding examples: Unofficial Amstrad WWW Resource

Offline Livingstone

  • CPC464
  • **
  • Posts: 10
  • Country: es
  • Opera Soft forever
  • Liked: 1
  • Likes Given: 5
Re: Problem screen border black and paper blue
« Reply #7 on: 21:02, 27 March 09 »
My multimeter has a HZ setting.
You can switch it to that and then put one connector to the clock pin and other to ground and get a read out.
 
http://www.grimware.org/doku.php/documentations/repository#manuals
 
Service Manual for cpc464 here.
 
Have you tried swapping the ULA (40007/40010) between the 464's in case one ULA is good and there are different problems with each computer?
 
With the "beep" I was wondering if the computer is actually running and executing instructions but the display was broken.
 
another thing to check, is that there is power going to each of the chips (rom, ula, crtc).
rom is something like 40032, ula is 40007 or 40010, crtc is 6845 and could be HD6845, UM6845 or MC6845.
I will try it now.  :) 
« Last Edit: 21:06, 27 March 09 by Livingstone »

Offline samas

  • CPC464
  • **
  • Posts: 4
  • Country: gr
  • Liked: 1
  • Likes Given: 1
Re: Problem screen border black and paper blue
« Reply #8 on: 10:18, 22 December 10 »
Hello
I have the same problem (i have french amstrad). I connect (my mystake) inside board 12v to 5v pin. The result was disastrous .The big problem is which chip are burn (z80 , 4164 , 40015 , 40051 , 40226 sound etc).
If burn 40226 if thing amstrad is dead . :'( :'( :'(

First i change all tranzistors , but nothing. :(
I detachment all dram chip 4164 . I put socket and replace the 4164 with 41256 (32kb) from a broken amiga 500 board .Amstad starting and show only logo and stuck ( it can't execute basic ) .  ??? ???
Then i detachment the 40015 and starting ok . The problem was burning chips (4164 and 40015).
(sorry for my bad english) .
 ;D ;D ;D ;D ;D ;D ;D ;D ;D ;D ;D ;D ;D ;D ;D

Offline arnoldemu

  • Supporter
  • 6128 Plus
  • *
  • Posts: 5.336
  • Country: gb
    • Unofficial Amstrad WWW Resource
  • Liked: 2269
  • Likes Given: 3478
Re: Problem screen border black and paper blue
« Reply #9 on: 12:30, 22 December 10 »
Hello
I have the same problem (i have french amstrad). I connect (my mystake) inside board 12v to 5v pin. The result was disastrous .The big problem is which chip are burn (z80 , 4164 , 40015 , 40051 , 40226 sound etc).
If burn 40226 if thing amstrad is dead . :'( :'( :'(

First i change all tranzistors , but nothing. :(
I detachment all dram chip 4164 . I put socket and replace the 4164 with 41256 (32kb) from a broken amiga 500 board .Amstad starting and show only logo and stuck ( it can't execute basic ) .  ??? ???
Then i detachment the 40015 and starting ok . The problem was burning chips (4164 and 40015).
(sorry for my bad english) .
 ;D ;D ;D ;D ;D ;D ;D ;D ;D ;D ;D ;D ;D ;D ;D
I am happy that you fixed your cpc.

I think you are lucky that more damage was not done.

You did well to find and fix the problems and to give it life again.
Thankyou for the info, it will help others in the future.

BTW, Welcome to cpcwiki forums!
« Last Edit: 12:39, 22 December 10 by arnoldemu »
My games. My Games
My website with coding examples: Unofficial Amstrad WWW Resource

Offline MacDeath

  • Chaotic post writer and mock-up specialist
  • Supporter
  • 6128 Plus
  • *
  • Posts: 4.059
  • Country: fr
  • Liked: 1164
  • Likes Given: 648
Re: Problem screen border black and paper blue
« Reply #10 on: 14:53, 23 December 10 »
Quote
I choose to put sockets on both computers to fit the memory chips.
 4) Make sure the memory chips reposition the result is the same.
Fun customisation.

Perhaps the RAM that is usedd for the video is not good.

it is supposed to be the 4th memory Bank from the central 64K.

The Ram used by the standard screen is from &C000 to &FFFF.

You put 32K chips from an Amiga ? are you sure this fit ? is this really PIN compatible ?

I was wondering if this could be possible to put faster memory but isn't the existing Firmware/Basic/whatever then screwed up ?


Are the chips pins clean ? if the contact is bad, thi may not help.
« Last Edit: 14:56, 23 December 10 by MacDeath »

Offline samas

  • CPC464
  • **
  • Posts: 4
  • Country: gr
  • Liked: 1
  • Likes Given: 1
Re: Problem screen border black and paper blue
« Reply #11 on: 18:20, 23 December 10 »
soon i"ll upload photo's.

Offline samas

  • CPC464
  • **
  • Posts: 4
  • Country: gr
  • Liked: 1
  • Likes Given: 1
Re: Problem screen border black and paper blue
« Reply #12 on: 11:29, 24 December 10 »
I  bought a French cpc 6128 before 6 month with problem to drive (no working).
I make a mistake to connect 12v to 5v on board.The problem was like this as describe in this forum .
Before 4 days bought 2 amstrad cpc (6128 , 464 )
http://cgi.ebay.co.uk/ws/eBayISAPI.dll?ViewItem&item=280606477197&ssPageName=STRK:MEWNX:IT
http://cgi.ebay.co.uk/ws/eBayISAPI.dll?ViewItem&item=280606479756&ssPageName=STRK:MEWNX:IT
I hope working (buy as untest.)

I found in ebay vevy very cheap 2 broken pieces from amiga 500.
http://img713.imageshack.us/i/94388164.jpg/
One of then (left piece) had 16 drams nec 41256 (32kb) 16 pin (in photo memory detachment).The other (right) has 20 pin 128k x 4 (for the moment i don't care.maybe with the correct wirring works. maybe..... )

the datasheet for 4164
http://pdf1.alldatasheet.com/datasheet-pdf/view/167176/PANASONIC/MN4164-15.html
and the datasheet for 41256
http://pdf1.alldatasheet.com/datasheet-pdf/view/147566/NEC/UPD41256.html

The pin is exactly the same.

photo's

http://img109.imageshack.us/i/10102662.jpg/

http://img510.imageshack.us/i/95176171.jpg/

http://img545.imageshack.us/i/23378753.jpg/

http://img63.imageshack.us/i/87637637.jpg/

http://img703.imageshack.us/i/72560331.jpg/

http://img607.imageshack.us/i/39848405.jpg/

http://img255.imageshack.us/i/40464865.jpg/

http://img31.imageshack.us/i/98989541.jpg/

As you can see work with 8 banks 8x32=256
And work without 40015 , without 74ls38 multiplexer , without 74hc14 (for drive)

I have to work on amstrad up 20 years i don't remember nothing.
I have many question .

first : how check the banks and how check how much memory i have ?