Problems with CPC 6128

Started by 6128user, 19:33, 27 September 10

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

MacDeath

#25
 
QuoteI also saw some weird stain like something would have leaked at the   mainboard and I think it's not something that was spilled over the   keyboard because the keyboard itself is working fine and no sticky keys   at all.
Were they looking porn on this CPC ? ???
Quote
the keyboard layout is completely normal (UK standard?)
Easy : QWERTY or AZERTY ?

Does it features a Ñ key ?


Concerning the disc drive, perhaps your disks are dead...



I wish we had Amstrad at school instead or Thomsons MO5 and TO7... even MO6 and TO8 would have been better...

6128user

It's qwerty, of course. And no, can't find that special key.


And I checked that disk are no dead because I tried NEW disk and still the amstrad says bad command.


I have two packets of Maxell CF2 10 unopened 3" disks... now totally 19 unopened disks left  ;)

Aapo

Quote from: 6128user on 12:03, 28 September 10
anyway, the current disc drive seems to be failed because it can't read discs at all... I had 3 drives as a backup but both were having broken belt and making obvious noise but this one sounds to work properly, and it does even say if there's no disk in the drive... but no matter what, typing |a or cat or |dir.... it always says "bad command" althought otherwise the drive seems to work.

I know this is old topic but I just fixed my own CPC6128 by replacing old disc belt. After the replacement the drives sounds to work properly but I had the same problem: it always says "bad command" (unless trying to drive it empty, the it says no disc).

After few hour thinking I noticed that guider between read/write head and stepper motor drive worm was little misplaced. I slightly moved it (be careful!) and after that the driver worked correctly (it could have been also that the drive worm had just got stuck after all these year in closet).

I hope this tip helps someone.

endangermice

#28
One of the first things I usually do to eliminate or confirm its a power switch problem is to disconnect the original switch and place a jumper over the pins. If the cpc powers up normally each time the jumper is attached then the switch is as fault. If not there's something else wrong.


One of my spare 6128s is currently only powering up randomly. On the times it doesn't power up properly I get a white screen. I suspect the caps need replacing and that the fault lies in the reset circuit. Once the machine is one it behaves perfectly and will soft reset all day long, it's the hard resets that kill it!


Sounds likes you're well on the way to getting it fixed - definitely replace the caps as Bryce says if they're faulty they can cause a whole host of random issues!


Arnoldemu - do you live in Gloucestershire still? I'm Cheltenham based - so you might be just up the road from me!
For all the latest Starquake remake news check out my website - www.endangermice.co.uk

Powered by SMFPacks Menu Editor Mod