ULIfAC:Usb Mass storage,WiFi, 512KB Ram/32XROM Board/256K Ram+16X Rom Board!

Started by ikonsgr, 11:39, 24 March 23

Previous topic - Next topic

0 Members and 2 Guests are viewing this topic.

Josip


ikonsgr

Quote from: Josip on 22:25, 21 January 24No freezes after reset, regardless which mode i use
This happened with the last previous firmware too?
If previous fw had the same cold booting behavior, but it didn't freeze upon subsequent resets, then better keep the previous fw...  ::)

Josip

I did not see any difference between those two firmware, both behave same.
Without autoboot to CPC6128, one reset is needed upon cold boot, afterwards works without problem
With autoboot to CPC6128, no reset needed on cold boot.

So will stay on this firmware

ikonsgr

Quote from: Josip on 09:26, 22 January 24I did not see any difference between those two firmware, both behave same.
Without autoboot to CPC6128, one reset is needed upon cold boot, afterwards works without problem
With autoboot to CPC6128, no reset needed on cold boot.

So will stay on this firmware
:picard: mea culpa, how i understand the opposite (that it freezes after reset), only God knows...  ::)

Josip

Just got another CPC464, this one is some strange mix, grey keys like Schneider, but in Amstrad case, on power led is label EIN, sticker on bottom is in german, on joystick port and audio output writing is in spanish :D

So i will have another to test Ulifacusb, i hope because machine is bought as untested, but price was excellent.







Regulus

Hi

Someone know if command line tools exist that allow you to send a bin or a dsk via the USB connection to Ulifac, and which the amstrad will execute automatically?

Or any tools that allow you to control the ULIFAC from the command line (always via USB), it's interesting for automating tasks !

Josip

Fixed this Amstrad, GateArray was bad.

Just for info, ulifac works on this revision of board (MC0046A Z70378) without any problems, no need for any additional restart.

steph072

Hello,

HDCPM do not want to boot with my CPC 6128 (ULIFAC 3B). Just see the loading of boths HDs, if using the HDCPM program (the ROM doesn't work at all).
After that: crash of the ULIFAC. Power off at CPC power switch necessary. several attempts. 
Isn't it working with all CPC 6128 ?

Thank you.

ikonsgr

Quote from: steph072 on 19:17, 04 March 24Hello,

HDCPM do not want to boot with my CPC 6128 (ULIFAC 3B). Just see the loading of boths HDs, if using the HDCPM program (the ROM doesn't work at all).
After that: crash of the ULIFAC. Power off at CPC power switch necessary. several attempts.
Isn't it working with all CPC 6128 ?

Thank you.
Make sure that the switch is set to "6128", otherwise you can't load CPM+. Other than that, i suppose the best person to consult is @d_kef that created HDCPM and test it with ULIfAC board too.

linuxkostik64

Dear @ikonsgr,
dear CPC friends,

After testing my ULIfAC extensively for a while, I can really recommend it to every CPC user. Basically, the device does what it is supposed to do very well, even if it seems to have a few "teething troubles" here and there, at least in my case. I'll list these little "problems" one by one here:

Firstly: This is version 3 of the ULIfAC, when switching on the screen shows that the device is equipped with version 3b.

The user manual states that automatic activation of USB is activated by default, this is apparently not the case with my ULIfAC and I have not yet been able to find out how to change this. I have copied the ROM configuration 464-to-6128 along with a few games onto a USB stick. The config.txt is created correctly according to the description. After switching on the CPC with the ULIfAC connected and the USB stick inserted, I get a message on the screen that no USB device is present. If I then type |usb, I get confirmation that the stick is now active. If I now press the reset button on the ULIfAC, the CPC boots directly into the 6128-Rom, as desired. Normally this should work automatically, but how do I do this? Is there any way to completely reset the ULIfAC to the default settings? 

Since the file ULIFAC_FINAL3b.zip in the dropbox of @ikonsgr was apparently updated, I had the idea to reflash the firmware as described in the current version of the user manual. Unfortunately, this did not work, or I am doing something wrong. I connected the PL2303TA to the ULIfAC as shown in the first attached picture. Windows apparently also recognizes the ULIfAC with usb2serial cable as a device with virtual COM port (COM3), it is listed in the device manager as "Prolific USB-to-Serial Comm Port (COM3)".


If I now try to carry out the flashing by selecting the corresponding COM port and the baud rate of 115200 bps specified in the user manual and clicking on "Write Device" and then immediately pressing the reset button on the ULIfAC, the process does not start. Instead, the "Tiny Multi Bootloader+" displays the error message "No Device Detected", as can be seen in the second picture. It does not work under Windows 10 or Windows 11. What is the reason for this? Maybe because the same firmware is already installed? Or is the actual bootloader missing on the ULIfAC? As I said, the installed version is version 3b and I haven't done anything to the device yet.
Apart from these rather minor problems, the device has worked pretty well so far. Nevertheless, the problems bother me a little.

Btw: The joyport adapter from @ikonsgr is also excellent. It ensures that my ArcadeR joystick now works properly on the CPC, including auto-fire, even if I rarely use the latter. I am very pleased. :)

Many thanks in advance for your help.

Best regards from Germany

Constantin

Josip

Tried with many programmers and non of them work, except Pickit 3.
With PL2303 had sam issues like you.
So try to find if some of your friends have Pickit.

Devlin

Quote from: Josip on 07:31, 18 April 24Tried with many programmers and non of them work, except Pickit 3.
With PL2303 had sam issues like you.
So try to find if some of your friends have Pickit.
it's a crapshoot trying to find a pl2303 that works - the drivers for modern systems have code to brick fake pl2303 devices - your best bet is to find a cheap (and known genuine) one, or get a pickit3 and program it that way.
CPC464 & CPC6128 + USIfAC II + Revaldinho 512k(universal cpld ver) - Schneider CRT TV
Administrator of Amstrad Discord : https://discord.gg/ksWvApv

pelrun

Quote from: Devlin on 08:17, 18 April 24the drivers for modern systems have code to brick fake pl2303 devices

You're confusing it with FTDI's very shortlived attempt at doing that - they got so much bad publicity from wrecking customer devices they rolled it back almost instantly. I refuse to use their hardware if I can avoid it to this day.

The PL2303 drivers don't brick devices, they just corrupt the link with periodic "unauthorized hardware" messages. I'm not even legitimate old pl2303 devices work - Prolific discontinued the part and moved onto another part number/usb id iirc. The old driver actually still works, if you can find a copy.

Of course, this only matters on Windows; linux doesn't need third-party drivers to talk to serial hardware.

ikonsgr

@linuxkostik64, about the non-recognize of usb stick upon booting, most probable the usb stick you use, takes too long to initialize, so Amstrad can't access it on time, it gives you the "no USB device found" message, but after a few seconds, when you give |USB by hand, it's activated as it should. Try a different usb stick and most probable the problem will solve.
About flashing PIC, first let me note 2 important things:
- Check that Tx and Rx are correctly plugged,a typical cause for "No device found" error, is misplacement of these 2 pins, you can even try to swap them and see if it works.
- You MUST have the ULIfAC plugged into usb2serial cable, BEFORE plugging it to a usb port of your PC.
Having said that, maybe the prolific PL2303TA doesn't function correctly on Windows 10/11,as i had same issues with it too. Although it seems that driver is installed correctly and serial port is functioning, in reality it didn't... The best alternative i found for windows 10 (and possibly windows 11), is CP102:
https://www.ebay.ie/sch/i.html?_from=R40&_nkw=6pin+cp2102+usb+2+ttl
This is tested many times, works perfect, and as you can see, costs almost nothing  ;)
Finally ,a hint i discover lately: pressing constantly reset button on ULIfAC, and then click on Write Device button, 99% will start re-program without problems.

Powered by SMFPacks Menu Editor Mod