Printed Amstrad Addict magazine announced, check it out here!

Main Menu

ManageDsk heeelp

Started by Optimus, 12:42, 16 February 11

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.


I am using ManageDsk to add a binary file to a dsk and now I have to do this frequently with the command line, because I compile with SDCC to bin and I want to not have to manually run managedsk and do it with the gui each time I compile.

So, I tried ManageDsk -C -Amain.bin -Stest.dsk as noted in the french readme file.
main.bin is my file, managedsk.exe is in the same folder, everything is there

The result? A DSK with nothing in it! Arghh!!!
If I try to do this with the GUI it works, I have a DSK with the binary file inside.

I have tried managedsk -C A*.bin -Stest.dsk, I have tried also *.BIN if it was case sensitive, I have tried to figure out why it doesn't work.

Then I also tried ManageDsk -Ltest.dsk -A*.bin -Snew.dsk
which is the other style, to add all binary files to the already created test.dsk
Result? New.dsk is also empty and identical to test.dsk

What am I doing wrong? This works from the GUI but not with command line and I need this to speed up the process of compiling and testing.

I open the dsk in Winape32 and I use Windows. Maybe the commandline style works only for the linux version of managedsk?

p.s. I am attaching the whole folder so that you can test it yourself and possibly find something that works, with the binary file, managedsk, and batch files doing each of the two types (I care about mdisk.bat, but ndisk.bat doesn't work either after mdisk.bat as it should).


This is a bug in the old version of ManageDsk.

I've try with the lastest version of ManageDsk (v0.19, attached to this post) and its works

By the way, you should use the -Ifilename instead of -Afilename if you want to add an amsdos header to your file in the dsk.

The -I parameter must be provided with
-PC file, with complete path if not in the same directory of ManageDsk,
-Cpc filename,
-File type,
-File start,
-File length,
and in option, file execution
separated by a / character





For a basic file:



Even if you still use the old 0.16 version (as I do), you can get around the bug by putting in the full path of the BIN file ie:

ManageDsk -C -AC:\Folder_of_binfile\*.BIN -Stoto.dsk



Oh,. I was looking for this -I switch.
  Now that -A worked, I needed the -I to load from basic.
  Now, -A works diferently than -I, very strange.
  For example ManageDsk -C -Imain.bin/BIN/16384/16384 -Stest.dsk produces a file called "BIN."
  I managed to get it working with this:
  ManageDsk -C -Imain.bin/main.bin/BIN/16384/16384 -Stest.dsk
  Anyway, it's like selecting main.bin once and then telling it once again   to save it as main.bin in the disk too, but this second definition was   missing from some of the -I examples.
  Anyway, thanks. I think I can manage it this way but if there is another problem I will ask again here.


Mmm... Yes the documentation is a bit messy...

You should provide two filename because, the first is the "real" filename from the pc, and the second is used to fill in the amsdos structure.


QuoteYou should provide two filename because, the first is the "real" filename from the pc, and the second is used to fill in the amsdos structure.
Yeah, this is the good thing to do.  :-\


Manage DSK : just let NewYork justice do their job... ;D

Powered by SMFPacks Menu Editor Mod