CPCWiki forum

General Category => CPCWiki Discussion => Topic started by: Fessor on 19:53, 19 January 20

Title: Error Uploading Attachments
Post by: Fessor on 19:53, 19 January 20
Quote
Sorry! There is already an attachment with the same filename as the one you tried to upload. Please rename the file and try again
Get this Errormessage if i try to Post a Reply with Attachments. The Message sends me back to the post. I can then edit the Message and Remove the attachments but the "Post"-Button refuses to work...Don't know  why i got this Message because none of the previous Posts had Attachments with this Filenames.

BLEdit090.zip
unmodifiedSource190120.zip
Screenshot_20200119_080347.png
Title: Re: Error Uploading Attachments
Post by: GUNHED on 22:12, 19 January 20
Well, somebody else used the names before, it's a pain. And when I upload in the German forum and post a link here, it gets moved to the Hall of Shame. Solution: Try to rename the files. And yes, it take time...  :(
Title: Re: Error Uploading Attachments
Post by: Gryzor on 23:03, 19 January 20
Can you email me the files so I can check? Will send you a pm...
Title: Re: Error Uploading Attachments
Post by: Fessor on 00:12, 20 January 20
Hi,gmail blocked them.Put them into one Archive
Title: Re: Error Uploading Attachments
Post by: Gryzor on 10:32, 20 January 20
Well, what probably happened was that your initial post failed for some reason but the files were uploaded, so when the system tried to upload them again the filenames were already there... So indeed do try renaming them, that would probably be the easiest.
Title: Re: Error Uploading Attachments
Post by: Fessor on 12:55, 20 January 20
Ok, gmail then blocked the mail completely.
The error message of the software was unfortunately too generic and did not specify a file name. I almost suspected that they were all orphaned on the server, because I wanted to edit the files individually to a post afterwards and every time I got the error message. It seemed very unlikely that someone would have uploaded a screenshot with the same timestamp

Thanks for your help
Title: Re: Error Uploading Attachments
Post by: Gryzor on 15:34, 20 January 20
Yes, I did notice the filenames - no way someone else had uploaded the same ones. As I said, they were probably uploaded, the post failed and then the system was finding them already there... Rather buggy, I know. I also see in the error logs you tried to reup them multiple times and of course they failed each time, which makes sense.