General Category > Emulators

CPCEPower v2105

(1/3) > >>

megachur:
v2105 - Windows 10 x86 & x64  - MacOS x64 - Linux x64 and Raspberry Pi4

OSD: Added files selection for A: B: TAPE: SNA: and CART: !
FDC: Corrected the sector order when formating track
ALL: Code refactoring and correcting some little bugs
RAW: Better correcting of bad sectors
IPF: Major refactoring/rewrite of the decode Engine and now it is bit aligned (was byte aligned before (8 bits)) 
SDL2: Updated to the last version 2.0.14

Enjoy  !

SkulleateR:
Is the Pi4 Version 32 or 64Bit ?


I cannot get it to work on my Pi 400, I even did a new install of SDL 2.0.14 from scratch ....



--- Code: ---error while loading shared libraries: libSDL2-2.0.so.0: wrong ELF class: ELFCLASS64

--- End code ---

SkulleateR:
Ok, just wanted to test on Raspbian OS 32 Bit .... no output here, no error message, nothing ....


Just quits back to Terminal ...  ???

megachur:

--- Quote from: SkulleateR on 14:34, 04 June 21 ---Ok, just wanted to test on Raspbian OS 32 Bit .... no output here, no error message, nothing ....


Just quits back to Terminal ...  ???

--- End quote ---
On my Pi4 B, I use normal Raspberry Pi OS (32-bit) with last updates and SDL 2.0.13 by default (if I remember well).
Have you dezipped all the file in the same directory (cpcemu.ini file, IMG, ROM, WAVE, directories and CPCEPower_SDL_Pi4 executable) ?

You should have a nice welcome msg if you execute it from shell by ./CPCEPower_SDL_Pi4...

Same on PI400, no need of SDL 2.0.14 ... last approved 2.0.13 should work...

SkulleateR:
Ok, still no joy ... tried a fresh Raspbian OS 32Bit install ... extracted all into "cpc"


Getting the same as before :



--- Code: ---
pi@raspberrypi:~ $ cd cpc
pi@raspberrypi:~/cpc $ ./CPCEPower_SDL_Pi4
pi@raspberrypi:~/cpc $

--- End code ---


It just exits back to the pi prompt .....

Navigation

[0] Message Index

[#] Next page

Go to full version
Powered by SMFPacks Media Embedder
Powered by SMFPacks Alerts Pro Mod
Powered by SMFPacks Mentions Pro Mod