General Category > Emulators

emulator with PlayCity support?



After the HG101 broadcast about Xevious I was checking out all the ports to 80's micros and of course checked the Amstrad port as well, which brought me to a french CPC fanpage which had a post abut a free remake of Alcon/Slap Fight* called "Alcon2020". I was very impressed by the performance of the game, similarly to Ghosts'N Goblins and R-Type remakes (re-ports?).

Even more impressed that Alcon2020 supports custom sound hardware, the PlayCity, with 6 voice audio!

I tried a few different emulators:
EP128emu (only get a red screen in CPC mode)
WinApe (the one I use the most, oddly it doesn't have support for DirectInput or XInput joysticks, so I use XPadder with it)

So far I have not been able to figure out how to enable PlayCity support in any of these, can someone here help me how to do it? Besides Alcon2020, are there any other PlayCity-compatible games?

P.S. I'm using a Windows 10 machine, also have a Raspberry Pi 400, though I'm still waiting for the PSU for that one.

Thanks in advance!

8-bit forever!

you forgot one ... CAPRICE FOREVER


in Emulator menu then Device Settings you can activate PlayCity

and enjoy playing with alcon2020 !!!

IIRC CPCEC also does emulation of the PlayCity :)



--- Quote from: SkulleateR on 17:05, 01 September 21 ---IIRC CPCEC also does emulation of the PlayCity :)

--- End quote ---
Yes that one worked very nicely, PlayCity and PC joystick were enabled by default, and I could just select
the .CPR cartridge file to run the game immediately. It plays quite nicely! Also I think it is the only version of
the game with a story intro.

--- Quote from: breiztiger on 17:01, 01 September 21 ---you forgot one ... CAPRICE FOREVER CPC-POWER, CPCArchives in Emulator menu then Device Settings you can activate PlayCity
--- End quote ---

I could not figure out how to load a cartridge image in Caprice Forever, so I tried making a custom config with a new blank X-Mem file and using the Alcon2020 installation .DSK, and RUN"INSTALL" as described on the Alcon2020 homepage.
I pressed 'W' for WinBond X-Mem type, it runs for a while, displaying red, white,black,grey garbled graphics, then stalls.

Correction: After installing the game to X-Mem board (as above) in Emulator > Device settings..., tick the Boot checkbox next to X-Mem checkbox -- this will replace Low-mem BASIC 1.1 with X-Mem LowerROM, click Apply, and the CPC will reset and game will start.

There is a longer thread of people having difficulty running this game in an emulator:

I am happy being able to play this unique, rare port in CPCEC.

Thanks to everyone who replied!  ;D

You guys are champs!  :laugh:

Are there any other Amstrad games using custom hardware like this?
Like the memory expansion? Or Digiblaster?

I enjoy the meta of getting stuff like Space Dust for SuperCPU to work, it's like solving a puzzle, with the reward that you get to play a cool retro game at the end.


[0] Message Index

Go to full version
Powered by SMFPacks Reactions Mod
Powered by SMFPacks Alerts Pro Mod
Powered by SMFPacks Mentions Pro Mod