Author Topic: 6128 plus sound problem  (Read 877 times)

0 Members and 1 Guest are viewing this topic.

Offline AxelStone

  • CPC664
  • ***
  • Posts: 107
  • Country: es
  • CPC 464+
  • Liked: 43
  • Likes Given: 11
6128 plus sound problem
« on: 00:33, 24 July 19 »
Hello everyone, I've a weird sound problem with my CPC 6128 plus: it seems like some channel doesnt's sound. If I use the original monitor, the left speaker doesn't sound correctly, I ear a strange and glitchy sound. Same problem using external speakers, so it's not something related to the RGB output.


Could it be the sound chip AY? Thanks.

Offline GUNHED

  • 6128 Plus
  • ******
  • Posts: 2.693
  • Country: de
  • Reincarnation of TFM
    • FutureOS - The quickest OS for the CPC and Plus
  • Liked: 1265
  • Likes Given: 2961
Re: 6128 plus sound problem
« Reply #1 on: 00:46, 24 July 19 »
Check:
- for dirt (it's 30 years old)
- for cold solder spot (may happen on main pcb)


Move the Video/Sound plug a bit, does the sound come back (for few parts of second)?

http://futureos.de --> Get the revolutionary FutureOS (Update: 2021.01.24)
http://futureos.cpc-live.com/files/LambdaSpeak_RSX_by_TFM.zip --> Get the RSX-ROM for LambdaSpeak :-) (Updated: 2021.07.15)

Offline AxelStone

  • CPC664
  • ***
  • Posts: 107
  • Country: es
  • CPC 464+
  • Liked: 43
  • Likes Given: 11
Re: 6128 plus sound problem
« Reply #2 on: 00:55, 24 July 19 »
Hello, the sound never comes back even moving it, RGB and audio jack. I've tried first step, complete cleaning, still drying so tomorrow I'll retry.


I'm not sure it's a cold solder, mainly because it happens in both audio outputs. Or perhaps you mean cold solder un AY chip? In this case, is there any way to identify it?


Thanks!