Bluish screen on startup

Started by llopis, 23:16, 03 January 19

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

llopis

When I turn on this Amstrad, it instantly displays this bluish rectangle on the screen. It's not the deep blue of the BASIC screen, and it's not the greenish-grey that most CPCs output when they have some memory issue. It's a slightly violet hue of blue, somewhat desaturated (see picture).


Nothing gets hot. The Z80 is fine, and it won't boot from X-Mem with the dirty RAM test. I'm suspecting it's a bad GA, but unfortunately it's a version 3 motherboard, so I can't just try out a different GA. Can anyone think of anything it could be, or some other test I could perform? (I have plenty of working 6128s, just not version 3s).


Bryce

Someone here recently had exactly the same problem which turned out to be a damaged trace to the RAM. The issue was solved by removing the original RAM, but installing the 4 chip alternative RAM instead of replacing the originals. Maybe worth a try?


Bryce.

llopis

Quote from: Bryce on 11:31, 04 January 19
Someone here recently had exactly the same problem which turned out to be a damaged trace to the RAM. The issue was solved by removing the original RAM, but installing the 4 chip alternative RAM instead of replacing the originals. Maybe worth a try?
I must have missed that thread. Do you have a link to it or remember something about it that I can use to search for it?


Also, do you know what kind of DRAM I would need for the 4 alternative chips? I see in this picture that it uses M41464 chips, which seem pin compatible with the 4464 RAM from Spectrum +2. Does that sound about right? (which would be great because I have a bunch of those around).

llopis

I ended up removing all the RAM chips, and the screen continued blue, but now without vsync somehow. I removed the ROM as well and tried running an external ROM from X-Mem or Dandanator and nothing. So I'm leaving this one for dead assuming it's the GA (I hate those non-replaceable chips) and using it for parts :-(

Powered by SMFPacks Menu Editor Mod