CPCWiki forum

General Category => Technical Support => Hardware related => Topic started by: geebus on 03:12, 16 January 21

Title: Bryces MegaRom
Post by: geebus on 03:12, 16 January 21
Hey folks, I'm learning electronics and thought i'd have a go at making Bryces MegaRom board (http://www.cpcwiki.eu/index.php/MegaROM). After going over every single line and matching it up to the circuit image (http://www.cpcwiki.eu/imgs/9/95/MegaROM_Bridges.pdf) that was on the how to, I'm getting nothing.the cpc464 turns on to a normal screen even though i've programmed (and verified) Protext to 04000 and maxam 1.5 to 08000.
I'm using a Winbond W27c01-70 EEPROM. is that not compatible?
Driving myself nuts here trying to find an issue and I just can't find any.
I did have a few to start with as the schematic and the circuit image don't match up (assuming the schematic is aimed at experienced people as the chips didn't have any gnd lines attached).
I've noticed that pin 4 (A14) from the amstrad isn't connected to anything on the schematic or circuit image. Is that required?
Title: Re: Bryces MegaRom
Post by: Bryce on 12:20, 16 January 21
Hi geebus,

cool idea. Here's a few answers and tips:

- A14 isn't used. The MegaROM only does partial decoding using A13 and A15.

- The 27C0170 should work fine.

- Troubleshooting. Start with the enable signal (CE) of the EPROM. This pin should be normally high, but will drop to zero every time the MegaROM is being accessed. If it doesn't go low a few times during startup then there's a problem in the decoding section. If it does go low like it should, then...

- Either the MegaROM doesn't think it should answer or is unable to answer. The "Answer" comes on pin 43 (the cathode of the diode) D1. This should go high when the MegaROM wants to activate itself.

- If CE isn't going low on boot, then you'll have to work backwards through the logic, starting with the 74LS20. For CE to go low, four inputs need to go high: Pins 1,2, 4 and 5. Pin 1 is monitoring A15, so it should be ok. Pin 2 is the ROM 7 select switch, this should always be high if the jumper (J1) is set correctly. Pins 4 is the complicated one. Pin 4 goes high if the ROM being selected is within the range of ROMs on the MegaROM (ie: ROM 0-7 or 0-15) depending on the position of J3. Pin 5 is like Pin 2, but checking whether ROM 0 on the MegaROM is to be used, this should also be permanently high if the jumper (J2) has be set correctly.

After you have found out which of the four signals is missing, the problem will be narrowed down significantly.

Title: Re: Bryces MegaRom
Post by: geebus on 14:39, 16 January 21
Thanks Bryce. I'll have a poke about with my scope later.Only issue I can foresee is that I only have an old analogue scope so won't be able to store the signal as the computer turns on.
I'll record the scope screen so I can get some pictures.Will post them up and you can see how badly I have my scope set. I have no idea what I'm doing with that either. Every day is a school day!

Title: Re: Bryces MegaRom
Post by: geebus on 02:56, 17 January 21
Ok. Got a quick moment to check this out.

I used the scope and seen that the CE pin was going "high" with fussy activity (can't get it clear on the scope screen), then the fuzzyness stops for a moment, then goes again.

I also checked the 74ls20 pins 1,2,4 and 5. all of which were showing an increase when i checked them with the scope.
The issue I think is in fact with the voltage that is showing on them. it seems that it is only around 1.5v which wont be a high signal at all will it? it should be around 4.6v and up or so?
Edit: I just checked the voltage from pin 27 and it's showing ~1.4v.Something must be shorting somewhere right?
Title: Re: Bryces MegaRom
Post by: Bryce on 13:48, 17 January 21
Shorting would also cause the CPC not to boot, it might be a bad solder joint or really dirty contacts on the expansion port.

Title: Re: Bryces MegaRom
Post by: geebus on 20:05, 17 January 21
I took the chips out and measured the voltage again. Was around 3.24v
I can't remember if it was measuring lower to start with then changed.
Without the board attached I'm definitely getting the 5v on the edge connector. Well, just under. I think it was about 4.98v

When my daughter is in bed I'll hopefully get another chance to check again tonight.
I'll test over the cable I made (same as what is described in the how to page) to make sure that's not the problem.

If I still have an issue I might disconnect the 5v and ground lines on all the sockets, then connect one at a time and test each one to see if I can find an issue.

Maybe I should check the voltage going into the resistor first, just to see what the drop over it is.

I have 5 cpc's so I can check over a couple to make sure it's not one machine that's causing the problem.
Title: Re: Bryces MegaRom
Post by: geebus on 21:52, 13 February 21
Well, I decided that my birds nest of wiring was probably the issue.
So I drew up the schematics in a way that doesn't leave out any lines at all (like the one on the wiki page) to then have some PCB's made.
I've attached the Schematics and the gerbers for anyone interested.I'd love to hear if anyone spots any errors or would think it'd work better in any different way.I'm a complete beginner at this stuff.

I'm going to order 10 of these soon as it's $4 for 5 or $5 for 10 ordered from JLCPCB (where I have had my other boards made).

@Bryce (https://www.cpcwiki.eu/forum/index.php?action=profile;u=225) would you like your logo on there as it's your designs that I've copied. I understand if you don't. In fact do you want your name on there at all?
I put it on as I didn't want to take credit for making something I didn't create myself.
Title: Re: Bryces MegaRom
Post by: Bryce on 11:38, 14 February 21
Hi geebus,
       I've no problem with my name or logo being on them. I'll try to take a look at the board later to see if there are any issues, but we are about to lose power here for a few hours, so no idea when I can do this.

As for the "missing" wires, they are only missing in the graphic, the schematic file contains all connections. Many schematic / layout programs hide the power lines to make the schematic less cluttered and easier to read.

Title: Re: Bryces MegaRom
Post by: geebus on 19:49, 27 March 21
Ordered a batch of 10 (as the price was similar to 5). i'll let you all know how I get on with them when they arrive.
Title: Re: Bryces MegaRom
Post by: geebus on 22:01, 21 April 21
Hi all,
Got the boards. Other than me fudging up the silkscreen, the boards seem to work fine.
If anyone would like one, let me know and i'll post it at cost.
Edit: I just loaded up Noels diagnostics lower ROM into &0000 and then changed the jumper to force it to look on the ROM chip for &0000 instead of the CPC itself.The CPC goes in a boot loop. so I must've messed something up.I also couldn't get Chuckie Egg rom to work, but that going to be a different story I think.  ;D 
Title: Re: Bryces MegaRom
Post by: Bryce on 23:57, 21 April 21
The ROM0 position on the MegaROM replaces the upper ROM0 (BASIC). Noel's Diagnostic ROM needs to replace the lower ROM (Firmware). I made a very simple device to do this, which you can find here: http://www.cpcwiki.eu/index.php/LowerROM

However, there are many newer boards that can do the job of both more comfortably.

Title: Re: Bryces MegaRom
Post by: geebus on 13:08, 29 April 21
So i've noticed something strange happening.
I put protext and Maxam 1.5 onto the ROM and the seem to load ok. (&4000 &8000).
They haven't been thoroughly tested yet though.
However, if i put anything else on there it doesn't seem to work.
If i put chuckie egg rom on there (one of my fav games) and use |chuck it gives me an error like it doesn't exist.
Prospell seems to freeze the machine when I use |spell.
This was all the testing i done on a 464. When I tried it on a 6128, the computer wouldn't even turn on.The power seemed to drop to ~3.6v on the 6128, whereas on the 464 it was just under 5v.
I've attached the circuit diagram to see if anyone else can see whats gone/going wrong.
Edit: Just realised the schematic is already in a post up above. Just deleted it from this post             
Title: Re: Bryces MegaRom
Post by: Bryce on 14:34, 29 April 21
What slots were Chucky and Prospell in? Also, I'm not sure (someone else will have to confirm), but I think Prospell needs Protext to be installed for it to work.
Also, regarding the strange behaviour on the 6128. Are you sure you have wired the ROM 7 Enable/Disable jumper correctly?

Title: Re: Bryces MegaRom
Post by: geebus on 16:46, 29 April 21
Using prospell within protext causes a freeze. I'm sure it's in the 4th slot (Rom 3 &C000)
Chuckie was in slot 1 and then slot 3.. tried it in a couple of different ROMS (all w27c01-70 chips)

I've just double checked that I have the lines on the PCB the same as what is on the schematic.
What I will do however is double check my schematic against yours on the DIY pages.
As i'm a newbie to electronics I thought i'd fire in every line and mark any non connected lines on the schematic too.
I was confused with some when looking at yours as I had next to zero experience of reading schematics.
Title: Re: Bryces MegaRom
Post by: GUNHED on 17:33, 29 April 21
Can you read the EPROMs and post their content here? Maybe the content is a problem?
Title: Re: Bryces MegaRom
Post by: geebus on 10:03, 30 April 21
Hey, I was going to do just that for you @GUNHEAD but whilst messing around I discovered that I could get the board working with my 6128. then it stopped working with it. The same with another 464.

SOO! I'massuming there is a loose connection somewhere, and I think it might be where my ribbon cable from the back of the CPC connects.
I have a few more boards, so i'm currently mounting an edge connector directly onto the board in the hopes that solves any possibility of connection issues.
Title: Re: Bryces MegaRom
Post by: GUNHED on 20:23, 02 May 21
Good luck! Pressing thumbs and nose. Hope you'll catch the problem soon!