Author Topic: Tape drive repairs  (Read 993 times)

0 Members and 1 Guest are viewing this topic.

Offline lazycrypt

  • Speccy
  • *
  • Posts: 1
  • Country: gb
    • Awards
Tape drive repairs
« on: 18:13, 14 June 19 »
I've recently gotten a CPC464 and after some minor repairs, the main tape deck drive belt and wonky on/off switch, got it working. However there are still one, or possibly two issues with it.
Rewinding and fast forwarding tapes works fine but if I try to play them normally the deck just eats up the tape. The issue is the right take-up wheel turns very slowly and irregularly. I've searched the forums and found out it's probably the idler tyre that's the culprit. The issue is I have no idea where to source a replacecment. I'd prefer not to canibalize the part from old faulty units since it would still be replacing old cracked/kinked/broken rubber with soon to be faulty old rubber. I tried looking around if instead something like a plumbing o-ring could be used but from what I've seen they seen to all be round while the CPC464 belt guide uploaded on the wiki lists the part as having a flat section.
The (possible) issue the unit has is the record button appears to be stuck. From the guides I've read it's supposed to be pressed down with the Play button but it doesn't really seem to budge. I tried looking online to see how it's supposed to work but couldn't really find any videos of the button being used. How should I go about fixing this? I really don't want to use too much force on the button and risk breaking something.

Offline Animalgril987

  • Supporter
  • CPC6128
  • *
  • Posts: 224
  • Country: gb
    • Awards
Re: Tape drive repairs
« Reply #1 on: 21:36, 29 November 20 »
Record can only be pressed if you insert a cassette with the write protect tab intact. Preceded games tapes will have the tabs snapped off. There are 2 tabs ( or notches where tabs were) on each cassette (1 per side).
With your 464 right way up and facing you, open the cassette deck and feel along the back of the tape bay, near the left side. You will find a lightly spring-loaded pin. Press the pin with your finger, and you should now be able to press the record key.