CPC 464 : garbage symbols from keyboard (MC0044D board)

Started by reno, 01:55, 12 March 23

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.


Hi there,

I just bought a 464 in great condition.
It's medium-sized board (MC0044D) with a membrane keyboard (Z70211)

Unfortunately, at power-up (and later) the keyboard is sending complete garbage.
Power up :

+  8 different symbols + reversed "?" repeated until the buffer fills... then I can press Esc

Here's a sample of what the keys do, there seems to be some logic here :

Esc : works normally, *break*
Tab : nothing (caps lock, shift too but that's normal)
Large Enter : *break*
Copy, keypad 0, 1, 2, 5, 8 : " 85120"
keypad 7, Del, Clr: working !
keypad 3,4,6,9,enter : nothing
P,Q: nothing
W,C : 5 symbols (the same)
T,V: 5 other symbols
Y : 4 symbols
E,R,U,O : 1 symbol
I : 3 symbols + return
M,',' : 3 symbols (the same)

What I tried :
- fully cleaned the membrane
- tried without keyboard plugged in : no garbage characters

If I read some other threads well, it may not be the AY because there's no issue when the keyboard isn't plugged in.
What should I try next ?

Thanks !


Answering myself : it's the membrane !

I swapped it with another 464 and all the problems disappeared.

I can't see where the damage is on it, it's a shame. Given the symptoms, would it be hard to repair ?


Sometimes they have just got sticky from dirt. Clean it with a soft cloth and soapy water and it may work again normally.


Powered by SMFPacks Menu Editor Mod