CPCWiki forum

General Category => Technical Support => Hardware related => Topic started by: falken on 15:49, 08 March 15

Title: CPC 464 red light but no picture output :[
Post by: falken on 15:49, 08 March 15
Hello :)

I'm having a problem with my cpc 464, and would be very grateful for any help. It was working ok aside from one thing, the audio would drop out from some of the channels - the same thing happened on the internal speaker and the headphone out. The CPC hadn't been used for 20 years, and was stored in a garage, it was very very dusty! So I planned to clean it and try to troubleshoot the audio problem.

I disassembled it, and using a cotton bud with isopropyl removed all the dust. I use a multimeter continuity test and found that the A, B and C chans were connected to the resistors R121, R122 and R123.

I re-assembled the machine, plugged it in and switched it on. I had intended to use basic to determine which channels were failing, but the red light came on but this time I had no picture output. I tested the monitor and it works with my Saturn, so that isn't the problem. I disassembled and re-assembled the cpc again, but couldn't see anything I'd forgot to plug in.

Thanks
Title: Re: CPC 464 red light but no picture output :[
Post by: falken on 16:05, 08 March 15
...and after unplugging and replugging the scart cable in my scart switch box, it's working!  ;D must have been some dust or something making a bad connection  :laugh: :laugh: :laugh: :laugh: :laugh:

best wishes ...
Title: Re: CPC 464 red light but no picture output :[
Post by: Gryzor on 22:48, 23 March 15
...marked solved :D