Author Topic: 6128 Plus Picture issue on Sony PVM  (Read 3225 times)

0 Members and 1 Guest are viewing this topic.

Offline beaker

  • 6128 Plus
  • ******
  • Posts: 810
  • Country: ie
  • Terrible at soldering...
    • index.php?action=treasury
  • Liked: 163
  • Likes Given: 244
6128 Plus Picture issue on Sony PVM
« on: 17:01, 16 March 15 »
Can anyone help, I've still got issues with my 6128+. I had the membrane replaced so they keyboard is working but the image quality on my Sony PVM is shocking as can be seen in the picture compared to the Pioneer Plasma TV. Anyone got any ideas what it might be? I've replaced the home made scart cable with one from CoolNovelties but the image is exactly the same. I have the original monitor in the loft I can bring down to test out on but I was hoping to use it with the Sony PVM which I use for about 40 other machines no problem...

Offline beaker

  • 6128 Plus
  • ******
  • Posts: 810
  • Country: ie
  • Terrible at soldering...
    • index.php?action=treasury
  • Liked: 163
  • Likes Given: 244
Re: 6128 Plus Picture issue on Sony PVM
« Reply #1 on: 17:12, 16 March 15 »
Here's it running an Oric and C64 over the last week to prove the TV is fine...

Offline Bryce

  • The Hardware Guy.
  • Supporter
  • 6128 Plus
  • *
  • Posts: 12.442
  • Country: wf
  • It's not broken, it just hasn't been fixed yet.
    • index.php?action=treasury
  • Liked: 4712
  • Likes Given: 488
Re: 6128 Plus Picture issue on Sony PVM
« Reply #2 on: 21:34, 21 March 15 »
Hi beaker,
     sorry, missed this thread for some reason. How do other computers that use RGB look on the PVM. I assume the Oric and C64 are using different inputs?
It looks like you have capacitance on the RGB lines that's making the colours run.

Bryce.

Offline beaker

  • 6128 Plus
  • ******
  • Posts: 810
  • Country: ie
  • Terrible at soldering...
    • index.php?action=treasury
  • Liked: 163
  • Likes Given: 244
Re: 6128 Plus Picture issue on Sony PVM
« Reply #3 on: 23:32, 21 March 15 »
Hi Bryce,

No worries, thanks for responding  :D

The Oric is using the RGB scart like the 6128+ but the C64 is using S-Video. I was also testing the Dreamcast tonight which uses the RGB scart and that seems fine as well.

 [ You are not allowed to view attachments ]   [ You are not allowed to view attachments ]

and an RGB modded NES using the scart

 [ You are not allowed to view attachments ]

Roy Bates also suggested caps on Amibay...

Andy, from CoolNovelties got back to me on Thursday saying

Quote
I’ve checked our wiring diagram for the Amstrad plus cable.  We use luminance as the video input signal which is more compatible with standard TVs, but on your Sony PVM I would imagine it would prefer Composite SYNC or Composite Video.  This *could* be the problem.  You could try swapping over the wire from the centre pin (purple) with the yellow wire which is composite SYNC.  This may cure the problem for you.   There are no resistors on the colour lines or video output, just a capacitor on the blanking (RGB switching) pin.

I know the monitor can use an external sync or syncs on green, if that makes any difference?

Offline kevin.c

  • CPC664
  • ***
  • Posts: 50
  • Country: pl
  • Liked: 17
  • Likes Given: 4
Re: 6128 Plus Picture issue on Sony PVM
« Reply #4 on: 01:08, 22 March 15 »
Hi beaker,
about 6128+ and Sony issue: try to solder 3 terminating resistors 100 Ohm on each of RGB lines. You can do it inside SCART connector case, directly to the pins. Pin 15 is Red, and 13 -Red's ground. Green 11, ground on 9. Blue  7, ground  on 5.
Quote
I know the monitor can use an external sync or syncs on green, if that makes any difference?

No difference. "Sync on green" was developed just to spare 4-th sync cable.

Offline roy bates

  • CPC664
  • ***
  • Posts: 77
  • Country: gb
  • Liked: 12
  • Likes Given: 5
Re: 6128 Plus Picture issue on Sony PVM
« Reply #5 on: 12:32, 22 March 15 »
i never mentioned caps bud,if i remember correctly ;D

try the resistor method from above,and switching in the composite sync for luma,i think that monitor will be expecting that instead.

Offline beaker

  • 6128 Plus
  • ******
  • Posts: 810
  • Country: ie
  • Terrible at soldering...
    • index.php?action=treasury
  • Liked: 163
  • Likes Given: 244
Re: 6128 Plus Picture issue on Sony PVM
« Reply #6 on: 13:05, 22 March 15 »
lol, sorry my bad. I'm not really technically minded so easily confused  :laugh:

Offline Bryce

  • The Hardware Guy.
  • Supporter
  • 6128 Plus
  • *
  • Posts: 12.442
  • Country: wf
  • It's not broken, it just hasn't been fixed yet.
    • index.php?action=treasury
  • Liked: 4712
  • Likes Given: 488
Re: 6128 Plus Picture issue on Sony PVM
« Reply #7 on: 15:26, 22 March 15 »
Ah, you don't have the resistors installed? You really need them on the PVM (on Atari ST too).

Bryce.

Offline beaker

  • 6128 Plus
  • ******
  • Posts: 810
  • Country: ie
  • Terrible at soldering...
    • index.php?action=treasury
  • Liked: 163
  • Likes Given: 244
Re: 6128 Plus Picture issue on Sony PVM
« Reply #8 on: 15:52, 22 March 15 »
Thanks all, that's great to know as the ST RGB lead I have from Retro Computer Shack is pin sharp on the PVM so must have them in :thumbsup: