464 Plus hangs when tape keys pressed

Started by domr, 10:02, 21 May 22

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

domr

Hi all, wondering if anyone has any insights that can help me. I recently purchased a 464 Plus that semi-works. It boots and cartridge games work fine. Basic works, although there are a few issues with keys, which I guess is the keyboard membrane.

Biggest issue is that whenever I press a play key on the tape (play, FF or Rewind), garbled characters appear on the screen and it immediately hangs. It doesn't need to be trying to load anything, pressing the buttons at any time causes the same issue.

The 464 Plus came with a 3rd party power supply, and I've purchased a powered RGB to SCART cable. 

It feels to me like it might be a power supply issue, probably not producing enough current? Does that seem logical? I'd love to have a bit more insight before investing in a new power supply. 

eto

Quote from: domr on 10:02, 21 May 22Hi all, wondering if anyone has any insights that can help me. I recently purchased a 464 Plus that semi-works. It boots and cartridge games work fine. Basic works, although there are a few issues with keys, which I guess is the keyboard membrane.

Biggest issue is that whenever I press a play key on the tape (play, FF or Rewind), garbled characters appear on the screen and it immediately hangs. It doesn't need to be trying to load anything, pressing the buttons at any time causes the same issue.

The 464 Plus came with a 3rd party power supply, and I've purchased a powered RGB to SCART cable.

It feels to me like it might be a power supply issue, probably not producing enough current? Does that seem logical? I'd love to have a bit more insight before investing in a new power supply.

Sounds plausible. How much power does the power supply deliver? The plus needs 2.4A at 5V if I remember correctly. 

domr

Current rating on the power adaptor was too tiny to read even with a macro lens!

However I did find a 2 amp power supply with an appropriate barrel jack and as I suspected, it works perfectly now and all my tape games load fine.

Now just gotta sort out the keyboard membrane... oh, and 'left' on the controller!

eto

#3
Quote from: domr on 23:03, 21 May 22Current rating on the power adaptor was too tiny to read even with a macro lens!

However I did find a 2 amp power supply with an appropriate barrel jack and as I suspected, it works perfectly now and all my tape games load fine.

Now just gotta sort out the keyboard membrane... oh, and 'left' on the controller!
As long as it's just dirty and no lane is broken, it's quite easy. Just clean it with a clean, wet cloth. Maybe a tiny little bit of washing-up liquid. The membrane has 2 layers, make sure to clean only the outside, don't try to open the two layers. 


domr

Quote from: eto on 21:17, 22 May 22
Quote from: domr on 23:03, 21 May 22Current rating on the power adaptor was too tiny to read even with a macro lens!

However I did find a 2 amp power supply with an appropriate barrel jack and as I suspected, it works perfectly now and all my tape games load fine.

Now just gotta sort out the keyboard membrane... oh, and 'left' on the controller!
As long as it's just dirty and no lane is broken, it's quite easy. Just clean it with a clean, wet cloth. Maybe a tiny little bit of washing-up liquid. The membrane has 2 layers, make sure not to clean only the outside, don't try to open the two layers. 


Thanks. I did that and it made no difference.  I did end up actually pulling the layers apart and cleaning the metal contacts with alcohol, which made it slightly better, but there's still issues with some keys producing noting and others producing multiple key presses.  I guess I have to source a new membrane.

Powered by SMFPacks Menu Editor Mod