CPC 6128 not working, hangs after a few seconds

Started by DrDoom, 00:19, 15 June 22

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

DrDoom

Ok, I see this is the CRTC: UM6845:

pin 40 (VS) gives me this:

but pin 39 (HS) nothing as you can see :



Bryce

Then there's a very high chance that it has failed.

Bryce.

DrDoom

Now I see that my oscilloscope has a 200kHz bandwidth only,  :-[ so I will need a better one at least 8MHz? Could you suggest me one just for this task?

Bryce

How much are you prepared to spend?

Bryce.


Bryce

You don't get much scope for €200, but this one might be a step up from what you have: https://www.amazon.de/Hanmatek-Oszilloskop-HO52-Oscilloscope-Multimeter/dp/B08VRDG94N

Bryce.

DrDoom

Ok, now I've got an FNIRSI 1014d "100MHz" oscilloscope for 200€! and got some measurements:
Crystal oscillator: 16MHz


Z80 pin 6 (clock): 4MHz


Gatearray pin 4 (clock): 1MHz


CRT pin 21 (clock) 1MHz


CRT pin 40 (Vsync) 5v


CRT pin 39 (Hsync) 0v


I also have now a faulty Amstrad PCW board to get components from, and I changed the Z80 with same results. I hope no PCW fans will get angry.


How can I be sure what is wrong? the CRT? am I measuring it right?
Thanks!

DrDoom

I keep trying.
I disoldered two 6845 (CRTC) from some old CGA/Parallel Port boards.
Can I piggyback a 6845?

Bryce

Are you sure you have the timebase set properly when reading pins 39 and 40 on the CRTC?

Bryce.

DrDoom

I tested again and no activity reading  39 and 40 on the CRTC. Tryed on diferent timebases.
But, I have now a Dandanator CPC mini, and when connected there's activity in pin 40, but not on 39.
Anyway no image and no keyboard sounds when the Dandanator is connected.

Powered by SMFPacks Menu Editor Mod