CPC6128 disk drive doesn't work with switcher

Started by naujoks, 23:19, 20 July 22

Previous topic - Next topic

0 Members and 2 Guests are viewing this topic.

naujoks

I'm in the process of putting together a Jan Beta style universal PSU.
For that purpose I have two Meanwell switchers, one +5 and one +12; using the correct polarity.
The computer works just fine (no picture distortion either), but the disk drive isn't doing anything: disk missig error.
I measured 12v coming from that respective PSU.
Any idea why it's not working?

eto

I'm using that setup and it works for me. 

Just to be 100% sure polarity is correct: 12V has + on the outside.

Did you check the belt of the drive?

naujoks

Yes, polarity is correct.
I just tried another PSU for the +12 that I had lying around, same result though.
It works fine when I use the Amstrad MP2 for power.

Bryce

Using two switched mode supplies can cause problems. Check that both GND's are at the same potential. If the are offset, the voltages may be wrong (relative to each other).

Bryce.

naujoks

Turns out the (new!) cable between the PSU and the CPC was faulty...
Ah well, at least we have an explanation. All working now.
Thanks for the help!

Powered by SMFPacks Menu Editor Mod