Printed Amstrad Addict magazine announced, check it out here!

Main Menu

CTM640 no power problem

Started by Whinger, 15:09, 10 December 23

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.


I have tried to bring my childhood CPC464 back to life after spending the last 15 or so years in my cold, damp and dirty loft.
After stripping down and cleaning everything it initially worked and after a couple of power cycles I had a beautiful crisp image. The datacorder didn't read the tapes at all, not even a read error message, but that is for another day.

The next day when I powered on, there was nothing, not even the initial crack of sound you get straight after pressing the monitor button.
I found that the 2 amp fuse had blown and replaced it, hoping it was just old and weak, but it blew again as soon as I sent power to it.

I have since done some checking and there is a short on the 400 volt 100 uf capacitor. I further traced this to 2 pins on what I would call a transformer but I believe it is more correctly known as a flyback. I guess the pins would be 10 and 12, they are the 2 closest to the cap with pin 12 going directly to the positive leg of the cap, they are short on a continuity test at 0.5 Ohms.

Can someone confirm that this is indeed defected and also is there a pin out diagram suggesting what reading I should get from the other pins?
The part number is 8142005 and a source for a replacement would be appreciated, because all my searches are coming up blank.

Thanks in advance.


I would send a mail to donberg and check if they have a  HR6355 which is a replacement for the LOTP3714004 you need.

Check this thread:

However there might be a lot of other components now faulty and shorted in the way.
Check out this thread:

The flyback should be available here:
Proud owner of 2 Schneider CPC 464, 1 Schneider CPC 6128, GT65 and lots of books
Still learning all the details on how things work.


Thank you so much for taking the time to reply to this  :D
I had read the thread with all the faulty components and so far everything else seems to be OK.
Thanks to your link, I now see that it is not a flyback that I need so I'll just go back to calling it a transformer until I know better.

I don't think the insert image is working for me, so here are the direct links to images.

The part number is 8142005 29A
It seems to be the 2 legs closest to the 400v cap that are dragging it down to earth.
Any advice on how to measure the pins on this or where to find a replacement would be greatly appreciated.


What is the input Voltage?
Proud owner of 2 Schneider CPC 464, 1 Schneider CPC 6128, GT65 and lots of books
Still learning all the details on how things work.


According to the service manual it is supposed to be an 8142004 (220V input power). But that does not help any further, as also there is no information about that available. 

The only way would be measuring it - but I do not have a 640 to measure it.
Proud owner of 2 Schneider CPC 464, 1 Schneider CPC 6128, GT65 and lots of books
Still learning all the details on how things work.


So recently I've developed way too much experience with the CTM640 circuit board (on those other threads) so I can see if I can help

The CTM640 flyback is not available at Donberg. The only place is Tuli Electronics in Italy

The transformer itself has two separate groups of coils, one for the 5V output and the other for the 130V output.  Make sure the groups have about 0.5 ohm or so continuity whilst you have it out. Make sure the separate groups don't short to each other

Same deal with the flyback. There is a group of input coils and output coils. Make sure the pins on the input coil 130V and ~18V are not showing continuity and make sure all pins in each group still have continuity to each other

The main problem I've seen on my CTM640 after repair is it blowing the STK regulator again, due to potential overvoltage on the 5V output. Note: There is also 18V from the flyback going into the 5V regulator and out to your CPC

Check for shorts in the STK regulator. I would think this could be the problem if you are seeing a short between ground and one of the transformer lines
CPC464/GT64, CPC464 Plus/CTM640, 2 x CPC6128/CTM644

Powered by SMFPacks Menu Editor Mod