Author Topic: Fix broken Symbiface II?  (Read 346 times)

0 Members and 1 Guest are viewing this topic.

Offline Emu

  • CPC664
  • ***
  • Posts: 59
  • Country: de
    • CPCemu
  • Liked: 55
  • Likes Given: 1
Fix broken Symbiface II?
« on: 17:10, 13 March 21 »
Hi all,
a few days ago I bought a Symbiface II at eBay.

Unfortunately, it's not working. I connected it to different power supplies (providing up to 12 V / 4 A), but it doesn't do anything, no initial LED, no ROM messages. If I turn on the CPC with anyone of the power supplies connected to the SF, there are strange rythmic noises from the CPC speaker.

If I disconnect the power supply (the SF still connected to the expansion port) the noises are gone, but the CPC is working normally.

Does anyone know a way to find the problem and perhaps to fix it?

One thing that caught my attention is one of the electrolytic capacitors, the central one at the front edge (on my SF it's also the smallest one). It's top looks dark and open, with two small holes, not metallic and shiny as the two others do.

Does anyone have a large-scale photo of a working SF II to compare the look of the central capacitor?


Offline Bryce

  • The Hardware Guy.
  • Supporter
  • 6128 Plus
  • *
  • Posts: 12.345
  • Country: wf
  • It's not broken, it just hasn't been fixed yet.
    • index.php?action=treasury
  • Liked: 4631
  • Likes Given: 484
Re: Fix broken Symbiface II?
« Reply #1 on: 17:37, 13 March 21 »
You can send it to me for repair if you like (I'm in Germany).

Bryce.

Offline gerald

  • Supporter
  • 6128 Plus
  • *
  • Posts: 1.557
  • Liked: 1111
  • Likes Given: 265
Re: Fix broken Symbiface II?
« Reply #2 on: 18:24, 13 March 21 »
One thing that caught my attention is one of the electrolytic capacitors, the central one at the front edge (on my SF it's also the smallest one). It's top looks dark and open, with two small holes, not metallic and shiny as the two others do.
From the picture I've seen of the Symbiface II, that looks more like the self of the switching regulator.

Offline Bryce

  • The Hardware Guy.
  • Supporter
  • 6128 Plus
  • *
  • Posts: 12.345
  • Country: wf
  • It's not broken, it just hasn't been fixed yet.
    • index.php?action=treasury
  • Liked: 4631
  • Likes Given: 484
Re: Fix broken Symbiface II?
« Reply #3 on: 19:51, 13 March 21 »
I've fixed several of these in the past where the regulator had fried itself. One even had a hole in the case.

Bryce.

Offline Emu

  • CPC664
  • ***
  • Posts: 59
  • Country: de
    • CPCemu
  • Liked: 55
  • Likes Given: 1
Re: Fix broken Symbiface II?
« Reply #4 on: 00:45, 15 March 21 »
@Bryce : Would you really do that? I would be happy to accept your offer.

Offline Bryce

  • The Hardware Guy.
  • Supporter
  • 6128 Plus
  • *
  • Posts: 12.345
  • Country: wf
  • It's not broken, it just hasn't been fixed yet.
    • index.php?action=treasury
  • Liked: 4631
  • Likes Given: 484
Re: Fix broken Symbiface II?
« Reply #5 on: 09:40, 15 March 21 »
@Bryce : Would you really do that? I would be happy to accept your offer.

Yeah sure. That's what I do here - Fix "Things"  :)
I'll send you a PM.

Bryce.