Author Topic: GX4000 LED on but no video over scart  (Read 626 times)

0 Members and 1 Guest are viewing this topic.

Offline berks

  • CPC464
  • **
  • Posts: 11
  • Country: gb
    • Awards
GX4000 LED on but no video over scart
« on: 13:48, 02 September 21 »
Hi folks,


I have recently got my hands on a battered gx4000. I tested it today with one of those multi-voltage adapters (positive in, 11v on the 11v port) and a scart cable to an old LCD that seems to support RGB over scart. The console powers on (green LED on) but there is no signal on the TV at all. I power it on with a Robocop 2 cartridge in the slot.


Any ideas what could be the problem here?

Edit to add: I have a CTM640 on my CPC464 and the thought just crossed my mind... would I be able to use the CTM640 with the GX4000?
« Last Edit: 13:50, 02 September 21 by berks »
like
0
No reactions

Offline Bryce

  • The Hardware Guy.
  • Supporter
  • 6128 Plus
  • *
  • Posts: 12.538
  • Country: wf
  • It's not broken, it just hasn't been fixed yet.
    • index.php?action=treasury
    • Awards
Re: GX4000 LED on but no video over scart
« Reply #1 on: 13:53, 02 September 21 »
Yes, you can use it on the monitor, but you'll need an adapter. Are you getting any picture on the screen? Blue background or whatever?

Bryce.
like
0
No reactions

Offline berks

  • CPC464
  • **
  • Posts: 11
  • Country: gb
    • Awards
Re: GX4000 LED on but no video over scart
« Reply #2 on: 22:35, 02 September 21 »
Hi Bryce,


Unfortunately there's nothing on screen and the TV shows the "no signal" message.


I'll spend some time with it this weekend and report back any progress, but I'm not too hopeful :-)
like
0
No reactions

Offline Marian

  • CPC464
  • **
  • Posts: 5
    • Awards
Re: GX4000 LED on but no video over scart
« Reply #3 on: 23:00, 16 January 22 »
Hi Guys,
having exactly the same symptoms however trying via Scart to an old Sony CRT. But unfortunately no luck ;( Have checked Voltages on the Diode D183 and C128 as well LM8705 and having 9V and 5V. Just black screen. What else can I check ? (Revision A -board PAL without TV modulator ;(
like
0
No reactions

Offline Bryce

  • The Hardware Guy.
  • Supporter
  • 6128 Plus
  • *
  • Posts: 12.538
  • Country: wf
  • It's not broken, it just hasn't been fixed yet.
    • index.php?action=treasury
    • Awards
Re: GX4000 LED on but no video over scart
« Reply #4 on: 10:37, 17 January 22 »
What test equipment do you have?

Bryce.
like
0
No reactions

Offline Marian

  • CPC464
  • **
  • Posts: 5
    • Awards
Re: GX4000 LED on but no video over scart
« Reply #5 on: 12:00, 17 January 22 »
Hi Bryce,


Just a regular Multimeter/Soldering Iron and C4CPC however as no video it`s quite hard for me ;(
like
0
No reactions

Offline dragon

  • 6128 Plus
  • ******
  • Posts: 1.565
  • Country: es
    • Awards
Re: GX4000 LED on but no video over scart
« Reply #6 on: 12:24, 17 January 22 »
Try put the burning rubber in a slot directly in the c4cpc.


Then put a headphone in the audio jack and view if you can hear the burning rubber sound.


Thats little easy test to know if the console is working in some manner and if the problem is in the dac, the sony chip or something in the out video part...


The headphone jack is connected practically directly to the ay chip same as the monitor connector.


It there is not sound the problem is more back, asic, RAM, z80.. Or something else.
« Last Edit: 12:45, 17 January 22 by dragon »
like
0
No reactions

Offline Marian

  • CPC464
  • **
  • Posts: 5
    • Awards
Re: GX4000 LED on but no video over scart
« Reply #7 on: 16:45, 17 January 22 »
Hi Guys,
[/color] [/size]Have tried that out ...I see red light flashing for 1-2sec on the C4CPC (D3)and hear a short 0.1sec. short electric buzz trough the headphones however no real sound ;( Any other suggestions what I could try out ?
[/size][size=78%]Ps>thanks already for all your knowledge and help.[/size]
like
0
No reactions

Offline dragon

  • 6128 Plus
  • ******
  • Posts: 1.565
  • Country: es
    • Awards
Re: GX4000 LED on but no video over scart
« Reply #8 on: 17:28, 17 January 22 »
That's because the z80 try read de c4cpc at least.


The gx4000 the first do was read the cartridge.


Try these ram test and view if something is displayed.


https://www.cpcwiki.eu/forum/amstrad-cpc-hardware/quick-and-dirty-ram-test-for-cpc/
like
0
No reactions

Offline Marian

  • CPC464
  • **
  • Posts: 5
    • Awards
Re: GX4000 LED on but no video over scart
« Reply #9 on: 19:05, 17 January 22 »
Hi,


Have tried this RAM test...
https://www.cpcwiki.eu/forum/amstrad-cpc-hardware/quick-and-dirty-ram-test-for-cpc/msg106676/#msg106676

however unfortunately still nothing just black screen ;(
like
0
No reactions

Offline Bryce

  • The Hardware Guy.
  • Supporter
  • 6128 Plus
  • *
  • Posts: 12.538
  • Country: wf
  • It's not broken, it just hasn't been fixed yet.
    • index.php?action=treasury
    • Awards
Re: GX4000 LED on but no video over scart
« Reply #10 on: 20:09, 17 January 22 »
Where are you located?

Bryce.
like
0
No reactions

Offline Marian

  • CPC464
  • **
  • Posts: 5
    • Awards
Re: GX4000 LED on but no video over scart
« Reply #11 on: 00:01, 18 January 22 »
Hi Bryce,


Slovakia...(east of Czech)
like
0
No reactions

Offline Bryce

  • The Hardware Guy.
  • Supporter
  • 6128 Plus
  • *
  • Posts: 12.538
  • Country: wf
  • It's not broken, it just hasn't been fixed yet.
    • index.php?action=treasury
    • Awards
Re: GX4000 LED on but no video over scart
« Reply #12 on: 19:58, 18 January 22 »
Hi Bryce,


Slovakia...(east of Czech)

Ok, if it turns out to be something other than the ASIC (ie: fixable), you can send it to me (in  Germany) for repair without any customs issues. However at the moment it sounds like an ASIC problem.


Bryce.
like
0
No reactions