Author Topic: I think my 6128's expansion port is bad :(  (Read 7358 times)

0 Members and 1 Guest are viewing this topic.

Offline Bryce

  • The Hardware Guy.
  • Supporter
  • 6128 Plus
  • *
  • Posts: 12.345
  • Country: wf
  • It's not broken, it just hasn't been fixed yet.
    • index.php?action=treasury
  • Liked: 4631
  • Likes Given: 484
Re: I think my 6128's expansion port is bad :(
« Reply #25 on: 09:18, 16 March 18 »
Have you measured the voltage on the PCB? Is it getting 5V?

Bryce.

Offline Duke

  • Supporter
  • 6128 Plus
  • *
  • Posts: 1.253
  • Country: dk
    • spinpoint.org
  • Liked: 1464
  • Likes Given: 1184
Re: I think my 6128's expansion port is bad :(
« Reply #26 on: 09:28, 16 March 18 »
Also to make sure your replating job is OK, probably it would be best to connect ie. MotherX4 to the expansion port and measure signals directly from the Z80 & GA to the male pin header on the rear of the MotherX4.

Offline blackdalek

  • Supporter
  • CPC6128
  • *
  • Posts: 232
  • Country: au
  • Fraser
  • Liked: 98
  • Likes Given: 292
Re: I think my 6128's expansion port is bad :(
« Reply #27 on: 09:57, 16 March 18 »
@Bryce My multimeter read 4.92 +V off pin 27 with nothing connected to the expansion port.

@Duke where is the GA? I know where the Z80 is at least ;) ...and which pins on the Z80 or GA do I test etc?
CPC6128 modded with ABBA switch. External 5.25" floppy drive with side switch and Multiface 2. Now also sporting a joystick splitter and M4 WiFi board.

Offline Bryce

  • The Hardware Guy.
  • Supporter
  • 6128 Plus
  • *
  • Posts: 12.345
  • Country: wf
  • It's not broken, it just hasn't been fixed yet.
    • index.php?action=treasury
  • Liked: 4631
  • Likes Given: 484
Re: I think my 6128's expansion port is bad :(
« Reply #28 on: 10:00, 16 March 18 »
Have you ever opened and cleaned the power switch? 4.92V is ok with no further load, but connecting extra hardware might pull it below the limit (4.75V is where TTL ICs will start glitching).

Bryce.

Offline blackdalek

  • Supporter
  • CPC6128
  • *
  • Posts: 232
  • Country: au
  • Fraser
  • Liked: 98
  • Likes Given: 292
Re: I think my 6128's expansion port is bad :(
« Reply #29 on: 10:07, 16 March 18 »
I never even knew it was possible to open the power switch.  :o
It does not look easy to take apart and get back together again. Perhaps I should just solder a new switch in if it is the culprit?
CPC6128 modded with ABBA switch. External 5.25" floppy drive with side switch and Multiface 2. Now also sporting a joystick splitter and M4 WiFi board.

Offline Duke

  • Supporter
  • 6128 Plus
  • *
  • Posts: 1.253
  • Country: dk
    • spinpoint.org
  • Liked: 1464
  • Likes Given: 1184
Re: I think my 6128's expansion port is bad :(
« Reply #30 on: 10:08, 16 March 18 »
@Bryce My multimeter read 4.92 +V off pin 27 with nothing connected to the expansion port.

@Duke where is the GA? I know where the Z80 is at least ;) ...and which pins on the Z80 or GA do I test etc?

Check the expansion port pinout here:
http://www.cpcwiki.eu/index.php/Connector:Expansion_port

Z80 pinout:
http://static.righto.com/images/z80/pinout.png

As for the gate array it's the 40010 chip on your motherboard, check signals ramrd and romen.
http://www.cpcwiki.eu/index.php?title=Gate_Array_and_ASIC_Pin-Outs



Offline Bryce

  • The Hardware Guy.
  • Supporter
  • 6128 Plus
  • *
  • Posts: 12.345
  • Country: wf
  • It's not broken, it just hasn't been fixed yet.
    • index.php?action=treasury
  • Liked: 4631
  • Likes Given: 484
Re: I think my 6128's expansion port is bad :(
« Reply #31 on: 10:31, 16 March 18 »
I never even knew it was possible to open the power switch.  :o
It does not look easy to take apart and get back together again. Perhaps I should just solder a new switch in if it is the culprit?

You can short the pins of the power switch at the PCB (small 2 pin header) to see if the switch is the culprit (short with jumper and then re-measure the 5V rail). There are pictures somewhere here in the forum of how to open and clean the switch if it does turn out to need cleaning.

Bryce.

Offline blackdalek

  • Supporter
  • CPC6128
  • *
  • Posts: 232
  • Country: au
  • Fraser
  • Liked: 98
  • Likes Given: 292
Re: I think my 6128's expansion port is bad :(
« Reply #32 on: 12:30, 16 March 18 »
I've made a new discovery...

I just spent the last half hour soldering my MotherX4 board together (I got mailed a kit by mistake :P ) to enable me to plug in more than one device at a time.

This is what I found:

M4 board in slot 1 & slot 2 empty = CPC boots OK with M4 message

M4 board in slot 1 & slot 2 Z-Mem card = CPC blank monitor. Will not boot.

Z-Mem in slot 1 & slot 2 empty = CPC boots OK

MF2 board in slot 1 and Z-Mem in slot 2 = CPC blank. No boot.

MF2 Board in slot 1 & slot 2 empty = CPC boots OK and MF2 works

M4 board in slot 2, slot 1 empty = CPC boots OK

MF2 board in slot 2, slot 1 empty  CPC boots OK

So as you have probably gathered, I can run 1 board (unstable and glitchy), in any slot of the MotherX4 board.
But if I add 2 boards to any slot of the MotherX4 board, the CPC refuses to start.

Sound like a voltage issue?
« Last Edit: 12:32, 16 March 18 by blackdalek »
CPC6128 modded with ABBA switch. External 5.25" floppy drive with side switch and Multiface 2. Now also sporting a joystick splitter and M4 WiFi board.

Offline Duke

  • Supporter
  • 6128 Plus
  • *
  • Posts: 1.253
  • Country: dk
    • spinpoint.org
  • Liked: 1464
  • Likes Given: 1184
Re: I think my 6128's expansion port is bad :(
« Reply #33 on: 12:53, 16 March 18 »
Sound like a voltage issue?
Yes, try to connect an external 5V PSU to the MotherX4

Offline blackdalek

  • Supporter
  • CPC6128
  • *
  • Posts: 232
  • Country: au
  • Fraser
  • Liked: 98
  • Likes Given: 292
Re: I think my 6128's expansion port is bad :(
« Reply #34 on: 13:19, 16 March 18 »
Yes, try to connect an external 5V PSU to the MotherX4

Sadly, I have no 5V PSU with a connector that fits. All the PSU I could find in the house output 8V or 12V or somewhere in between.

The best I can do at this time is power the M4 board through its USB port. I have no idea if other cards on the MotherX4 board can share this USB power from the M4.

** edit: OK, I connected the M4 to USB power and put the Multiface 2 card into the MotherX4 board as well. At first the CPC did not turn on again, but after I pressed the reset M4 board button, it sprang to life and both the M4 and MF2 are working normally.
I ran a test program executing the |time rsx command on a loop. That ran stable for 5 minutes before I manually aborted it. Much longer than ever before.
I then loaded Chibi Akumas Episode 1 from the M4's SD card. Now this game I have NEVER been able to run any longer than 30 seconds before it crashed the whole CPC spectacularly. This time it ran stable and lasted through to the 4th stage without glitching or crashing. Again I had to manually terminate the program instead of having it crash the CPC.
Putting more power through to devices on my expansion port seems to at least be making the CPC run stable, so this voltage loss does indeed appear to be at the root of my CPC's problems.

I guess the next step is to follow Bryce's advice and test the power switch to see if it needs a clean (or replace).
« Last Edit: 14:08, 16 March 18 by blackdalek »
CPC6128 modded with ABBA switch. External 5.25" floppy drive with side switch and Multiface 2. Now also sporting a joystick splitter and M4 WiFi board.

Offline Bryce

  • The Hardware Guy.
  • Supporter
  • 6128 Plus
  • *
  • Posts: 12.345
  • Country: wf
  • It's not broken, it just hasn't been fixed yet.
    • index.php?action=treasury
  • Liked: 4631
  • Likes Given: 484
Re: I think my 6128's expansion port is bad :(
« Reply #35 on: 14:28, 16 March 18 »
Definitely a power problem. Either your PSU can't supply enough amps (for that setup I would advise you to use a PSU that can supply at least 3A or more), or there is too much voltage drop across things like the power switch.

Bryce.

Offline blackdalek

  • Supporter
  • CPC6128
  • *
  • Posts: 232
  • Country: au
  • Fraser
  • Liked: 98
  • Likes Given: 292
Re: I think my 6128's expansion port is bad :(
« Reply #36 on: 14:33, 16 March 18 »
I also have an ABBA drive swapping switch which I soldered in myself about 30 years ago. Should I also check that or would it not affect the voltage?

My PSU is currently the CTM 644 Colour monitor ;)
« Last Edit: 14:35, 16 March 18 by blackdalek »
CPC6128 modded with ABBA switch. External 5.25" floppy drive with side switch and Multiface 2. Now also sporting a joystick splitter and M4 WiFi board.

Offline blackdalek

  • Supporter
  • CPC6128
  • *
  • Posts: 232
  • Country: au
  • Fraser
  • Liked: 98
  • Likes Given: 292
Re: I think my 6128's expansion port is bad :(
« Reply #37 on: 15:34, 16 March 18 »
Found this on ebay... https://www.ebay.com.au/itm/351567502313
Does this look suitable to power the motherx4 board?
CPC6128 modded with ABBA switch. External 5.25" floppy drive with side switch and Multiface 2. Now also sporting a joystick splitter and M4 WiFi board.

Offline remax

  • 6128 Plus
  • ******
  • Posts: 1.137
  • Country: fr
  • Liked: 421
  • Likes Given: 471
Re: I think my 6128's expansion port is bad :(
« Reply #38 on: 16:00, 16 March 18 »
At first the CPC did not turn on again, but after I pressed the reset M4 board button, it sprang to life and both the M4 and MF2 are working normally.


I have to do this everytime since i have my M4 Board, and then everything always works well...

Offline Audronic

  • 6128 Plus
  • ******
  • Posts: 1.452
  • Country: au
  • I know RST3 . I now know a little More.
  • Liked: 321
  • Likes Given: 738
Re: I think my 6128's expansion port is bad :(
« Reply #39 on: 01:11, 17 March 18 »
@blackdalek


Just fold back the 4 tabs.
Disassemble carefully.
Straighten the little silver contact.
Clean all contact points with MILD abrasive, Cotton bud to clean the ones in the Body of the Switch.
Reassemble.
And away you go.
Good Luck


Ray
Procrastinators Unite,
If it Ain't Broke PLEASE Don't Fix it.
I keep telling you I am Not Pedantic.
As I Live " Down Under " I Take my Gravity Tablets and Wear my Magnetic Boots to Keep me from Falling off.

Offline chinnyhill10

  • Supporter
  • 6128 Plus
  • *
  • Posts: 1.395
  • Country: 00
    • https://www.youtube.com/user/chinnyhill10
  • Liked: 771
  • Likes Given: 522
Re: I think my 6128's expansion port is bad :(
« Reply #40 on: 02:46, 17 March 18 »
Have you ever opened and cleaned the power switch? 4.92V is ok with no further load, but connecting extra hardware might pull it below the limit (4.75V is where TTL ICs will start glitching).

Bryce.


I found a good soaking of contact cleaner followed by some switching and it was good as new without needing to open it.
--
ChinnyVision - Reviews Of Classic Games Using Original Hardware
chinnyhill10 - YouTube

Offline blackdalek

  • Supporter
  • CPC6128
  • *
  • Posts: 232
  • Country: au
  • Fraser
  • Liked: 98
  • Likes Given: 292
Re: I think my 6128's expansion port is bad :(
« Reply #41 on: 03:17, 17 March 18 »
I seem to be taking 1 step forward, 2 steps back.

I found a 5V 2A power supply with the correct plug size for the Motherx4 board.

It seems to work with these combinations:
Multiface 2 & M4 board = OK
Z-Mem card & M4 board = Crashes horribly
Z-Mem card & Multiface 2 board = OK

I wanted to run SymbOS 3 off the SD card in the M4, but that's not going to happen because it crashes when the Z-Mem card is in place.
SymbOS loads perfectly with the Z-Mem card removed, but is unusable because there is no free memory available to the system.

To make matters worse... I just made voltage measurements off the expansion port with the power switch shorted at the main board PCB... 3.2V. This is not good. I reconnected the power switch. 3.2V again. Yet I was getting 4.92V last night :( I don't know what could have changed since last night to cause this massive drop. All I've done is plug in a 5V supply I found this morning.  :'(

**edit: I just measured the voltage direct from the 5V monitor cable - it is outputting 5.27V, so plenty on that end of things. Measured the voltage off the expansion port again... still at a crippling 3.2-3.3V
« Last Edit: 03:25, 17 March 18 by blackdalek »
CPC6128 modded with ABBA switch. External 5.25" floppy drive with side switch and Multiface 2. Now also sporting a joystick splitter and M4 WiFi board.

Offline Audronic

  • 6128 Plus
  • ******
  • Posts: 1.452
  • Country: au
  • I know RST3 . I now know a little More.
  • Liked: 321
  • Likes Given: 738
Re: I think my 6128's expansion port is bad :(
« Reply #42 on: 03:56, 17 March 18 »
**edit: I just measured the voltage direct from the 5V monitor cable - it is outputting 5.27V, so plenty on that end of things. Measured the voltage off the expansion port again... still at a crippling 3.2-3.3V



As Bryce indicated Probably the Power switch is dirty.


If the volts at the expansion PORT is 3.3v  then maybe ADD a WIRE lead from the Expansion port back to the Output of the SWITCH.


Just some thoughts


Good Luck    Ray
Procrastinators Unite,
If it Ain't Broke PLEASE Don't Fix it.
I keep telling you I am Not Pedantic.
As I Live " Down Under " I Take my Gravity Tablets and Wear my Magnetic Boots to Keep me from Falling off.

Offline blackdalek

  • Supporter
  • CPC6128
  • *
  • Posts: 232
  • Country: au
  • Fraser
  • Liked: 98
  • Likes Given: 292
Re: I think my 6128's expansion port is bad :(
« Reply #43 on: 04:12, 17 March 18 »
As Bryce indicated Probably the Power switch is dirty.

If I am getting the same bad voltage reading both with the switch connected AND shorting the board pins directly, then wouldn't that mean the power switch is having no impact on the voltage problem and therefore not in need of a clean?
CPC6128 modded with ABBA switch. External 5.25" floppy drive with side switch and Multiface 2. Now also sporting a joystick splitter and M4 WiFi board.

Offline Audronic

  • 6128 Plus
  • ******
  • Posts: 1.452
  • Country: au
  • I know RST3 . I now know a little More.
  • Liked: 321
  • Likes Given: 738
Re: I think my 6128's expansion port is bad :(
« Reply #44 on: 04:21, 17 March 18 »
OK.


Can you measure the Voltage on Both sides of the SWITCH with the switch turned on ?
It should be the same on both sides.


Ray
Procrastinators Unite,
If it Ain't Broke PLEASE Don't Fix it.
I keep telling you I am Not Pedantic.
As I Live " Down Under " I Take my Gravity Tablets and Wear my Magnetic Boots to Keep me from Falling off.

Offline blackdalek

  • Supporter
  • CPC6128
  • *
  • Posts: 232
  • Country: au
  • Fraser
  • Liked: 98
  • Likes Given: 292
Re: I think my 6128's expansion port is bad :(
« Reply #45 on: 04:45, 17 March 18 »
Can you measure the Voltage on Both sides of the SWITCH with the switch turned on ?

I'll have a go, but not sure where i should put the probes, so I tried the following:

Pin 27 to 49 = 3.35V
Pin 27 to left side terminal on power switch = -1.63V
Pin 27 to right side terminal on power switch = -1.62V
Pin 49 to left side terminal on power switch = 4.99V
Pin 49 to right side terminal on power switch = 4.99V
left side switch to right side switch = 0V

Let me know where else I should put the probes and I will post results.

CPC6128 modded with ABBA switch. External 5.25" floppy drive with side switch and Multiface 2. Now also sporting a joystick splitter and M4 WiFi board.

Offline Audronic

  • 6128 Plus
  • ******
  • Posts: 1.452
  • Country: au
  • I know RST3 . I now know a little More.
  • Liked: 321
  • Likes Given: 738
Re: I think my 6128's expansion port is bad :(
« Reply #46 on: 05:03, 17 March 18 »
I'll have a go, but not sure where i should put the probes, so I tried the following:

Pin 27 to 49 = 3.35V
Pin 27 to left side terminal on power switch = -1.63V
Pin 27 to right side terminal on power switch = -1.62V
Pin 49 to left side terminal on power switch = 4.99V
Pin 49 to right side terminal on power switch = 4.99V
left side switch to right side switch = 0V

Let me know where else I should put the probes and I will post results.




Ok Lets go.


Pin 27 to 49 = 3.35V   
Not Good
-===========-
Pin 27 to left side terminal on power switch = -1.63VPin 27 to right side terminal on power switch = -1.62V

Can you measure from the Small connector BOTH SIDES to Pin 27 Please


-==========-

Pin 49 to left side terminal on power switch = 4.99VPin 49 to right side terminal on power switch = 4.99Vleft side switch to right side switch = 0V


This area is GOOD.


-===========-

Procrastinators Unite,
If it Ain't Broke PLEASE Don't Fix it.
I keep telling you I am Not Pedantic.
As I Live " Down Under " I Take my Gravity Tablets and Wear my Magnetic Boots to Keep me from Falling off.

Offline Audronic

  • 6128 Plus
  • ******
  • Posts: 1.452
  • Country: au
  • I know RST3 . I now know a little More.
  • Liked: 321
  • Likes Given: 738
Re: I think my 6128's expansion port is bad :(
« Reply #47 on: 05:11, 17 March 18 »
Notes I Made earlier


Power Problem CPC6128/464

1)  POWER SOCKET is the soldering in good condition ?

    Resolder the pins on the POWER Socket


2)  The Flying lead from the Power Switch plugs into Connector
     CP305 SW POWER is the soldering Good under the board ?

     Resolder the 2 pins on the CP305 SW POWER connector


3)   Now re test:-
 
     How many volts are you reading on PIN 27 on the EXPANSION CONNECTOR ?
     -ve Probe on 0 Volts. +ve Probe on Pin 27
Procrastinators Unite,
If it Ain't Broke PLEASE Don't Fix it.
I keep telling you I am Not Pedantic.
As I Live " Down Under " I Take my Gravity Tablets and Wear my Magnetic Boots to Keep me from Falling off.

Offline blackdalek

  • Supporter
  • CPC6128
  • *
  • Posts: 232
  • Country: au
  • Fraser
  • Liked: 98
  • Likes Given: 292
Re: I think my 6128's expansion port is bad :(
« Reply #48 on: 05:18, 17 March 18 »

Can you measure from the Small connector BOTH SIDES to Pin 27 Please

By small connector, I assume you mean the connector on the PCB which I shorted earlier to turn the CPC on?

Pin 27 to left side of PCB power pin = 0V

Pin 27 to right side of PCB power pin = -5.09V
CPC6128 modded with ABBA switch. External 5.25" floppy drive with side switch and Multiface 2. Now also sporting a joystick splitter and M4 WiFi board.

Offline blackdalek

  • Supporter
  • CPC6128
  • *
  • Posts: 232
  • Country: au
  • Fraser
  • Liked: 98
  • Likes Given: 292
Re: I think my 6128's expansion port is bad :(
« Reply #49 on: 05:22, 17 March 18 »
Notes I Made earlier


Power Problem CPC6128/464

1)  POWER SOCKET is the soldering in good condition ?

    Resolder the pins on the POWER Socket


2)  The Flying lead from the Power Switch plugs into Connector
     CP305 SW POWER is the soldering Good under the board ?

     Resolder the 2 pins on the CP305 SW POWER connector


3)   Now re test:-
 
     How many volts are you reading on PIN 27 on the EXPANSION CONNECTOR ?
     -ve Probe on 0 Volts. +ve Probe on Pin 27

Would you like me to resolder CP305 SW POWER and POWER SOCKET now?
CPC6128 modded with ABBA switch. External 5.25" floppy drive with side switch and Multiface 2. Now also sporting a joystick splitter and M4 WiFi board.