Author Topic: I think my 6128's expansion port is bad :(  (Read 8541 times)

0 Members and 1 Guest are viewing this topic.

Offline Audronic

  • 6128 Plus
  • ******
  • Posts: 1.466
  • Country: au
  • I know RST3 . I now know a little More.
    • Awards
Re: I think my 6128's expansion port is bad :(
« Reply #50 on: 05:32, 17 March 18 »

Would you like me to resolder CP305 SW POWER and POWER SOCKET now?



Yes please.
After you re solder the above items.
Can you do a test of Pin 27 WITHOUT any expansion items connected.    AND WITH expansion items connected.

I am confused by This :-[

Pin 27 to left side of PCB power pin = 0V
Pin 27 to right side of PCB power pin = -5.09V


Could do the same test with respect to 0 Volts Please


Thanks
Ray
like
0
No reactions
Procrastinators Unite,
If it Ain't Broke PLEASE Don't Fix it.
I keep telling you I am Not Pedantic.
As I Live " Down Under " I Take my Gravity Tablets and Wear my Magnetic Boots to Keep me from Falling off.

Offline blackdalek

  • Supporter
  • CPC6128
  • *
  • Posts: 232
  • Country: au
  • Fraser
    • Awards
Re: I think my 6128's expansion port is bad :(
« Reply #51 on: 06:39, 17 March 18 »
I have just desoldered connector cp305 and 5V power socket. Now soldered back into place.

retesting...

Pin 27 to left pin of connector cp305 = 0.01V (it was actually 0.01V last time too but I rounded it off to 0V)

Pin 27 to right pin of connector cp305 = -5.09V (same as before)

WITH Z-Mem board only attached to the expansion port....

Pin 27 to left pin of connector cp305 = 0.05V

Pin 27 to right pin of connector cp305 = -4.82V

like
0
No reactions
CPC6128 modded with ABBA switch. External 5.25" floppy drive with side switch and Multiface 2. Now also sporting a joystick splitter and M4 WiFi board.

Offline Audronic

  • 6128 Plus
  • ******
  • Posts: 1.466
  • Country: au
  • I know RST3 . I now know a little More.
    • Awards
Re: I think my 6128's expansion port is bad :(
« Reply #52 on: 06:45, 17 March 18 »
Ok Well done i think that you have fixed it


One last test


 Pin 27 to 0 Volts (Pin 2 ) on the expansion connector what does that read.


Ray



like
0
No reactions
Procrastinators Unite,
If it Ain't Broke PLEASE Don't Fix it.
I keep telling you I am Not Pedantic.
As I Live " Down Under " I Take my Gravity Tablets and Wear my Magnetic Boots to Keep me from Falling off.

Offline Audronic

  • 6128 Plus
  • ******
  • Posts: 1.466
  • Country: au
  • I know RST3 . I now know a little More.
    • Awards
Re: I think my 6128's expansion port is bad :(
« Reply #53 on: 06:47, 17 March 18 »





Pin 27 to 0 Volts (Pin 2 ) on the expansion connector what does that read

Place Probe on Pin 27 and the other on Pin2.

Ray
like
0
No reactions
Procrastinators Unite,
If it Ain't Broke PLEASE Don't Fix it.
I keep telling you I am Not Pedantic.
As I Live " Down Under " I Take my Gravity Tablets and Wear my Magnetic Boots to Keep me from Falling off.

Offline blackdalek

  • Supporter
  • CPC6128
  • *
  • Posts: 232
  • Country: au
  • Fraser
    • Awards
Re: I think my 6128's expansion port is bad :(
« Reply #54 on: 07:07, 17 March 18 »
Ok Well done i think that you have fixed it

Let's not get ahead of ourselves :P

Forget everything you've just read from me in this thread since this morning :P

I have just realised that every measurement I took from pin 27 was actually pin 29 (M1) ...thanks to my short-sightedness and inability to count the correct number of spaces from the keyed slot on the middle of the expansion port :P
I'm pretty sure that was the source of all those 3.2/3.3V measurements I wrote down.
 

NEW test result from the ACTUAL pin 27 to power switch connector with a Z-Mem connected and power switch unplugged from the PCB...

27 to left pin of CP305 = 0.00 V

27 to right pin of CP305 = -5.15V

NEW test results with Z-Mem connected AND power switch connected and CPC turned on...

27 to 49 = 4.95V

27 to 2 = 4.92V (the 0.03V discrepancy could just be because of the way I was holding the probe on the tiny solder spot on the PCB)
« Last Edit: 07:10, 17 March 18 by blackdalek »
like
0
No reactions
CPC6128 modded with ABBA switch. External 5.25" floppy drive with side switch and Multiface 2. Now also sporting a joystick splitter and M4 WiFi board.

Offline Audronic

  • 6128 Plus
  • ******
  • Posts: 1.466
  • Country: au
  • I know RST3 . I now know a little More.
    • Awards
Re: I think my 6128's expansion port is bad :(
« Reply #55 on: 07:15, 17 March 18 »
That looks OK only a small Voltage drop


If you want to improve it the have a look in the Picture.


Ray

like
0
No reactions
Procrastinators Unite,
If it Ain't Broke PLEASE Don't Fix it.
I keep telling you I am Not Pedantic.
As I Live " Down Under " I Take my Gravity Tablets and Wear my Magnetic Boots to Keep me from Falling off.

Offline blackdalek

  • Supporter
  • CPC6128
  • *
  • Posts: 232
  • Country: au
  • Fraser
    • Awards
Re: I think my 6128's expansion port is bad :(
« Reply #56 on: 07:25, 17 March 18 »
Nice picture. That wire (the red line) looks like it also connects to R319, C207 and a solder spot in the middle of IC207... but I'll assume it's only meant to go direct from Pin 27 to Pin 1 of CP305.


As for a practical test... SymbOS is still crashing when both the M4 and Z-Mem cards plugged in, but not crashing when the M4 ONLY is plugged in.

So even though the voltage levels look good now, it's still not working as it should.

**Edit: Also, SymbOS loads without crashing when both the M4 and MF2 cards are plugged in. The crash now appears to happen exclusively when the Z-Mem card is attached.
« Last Edit: 07:33, 17 March 18 by blackdalek »
like
0
No reactions
CPC6128 modded with ABBA switch. External 5.25" floppy drive with side switch and Multiface 2. Now also sporting a joystick splitter and M4 WiFi board.

Offline Audronic

  • 6128 Plus
  • ******
  • Posts: 1.466
  • Country: au
  • I know RST3 . I now know a little More.
    • Awards
Re: I think my 6128's expansion port is bad :(
« Reply #57 on: 07:34, 17 March 18 »
Ok Last one for today.


Can you measure Pin 27 to 0 Volts (Pin2) with both devices connected.


If The Voltage has dropped below 4.85 add the Wire.between Pin 27 of expansion Port and Pin 1 of CP305.


Good luck


Ray
like
0
No reactions
Procrastinators Unite,
If it Ain't Broke PLEASE Don't Fix it.
I keep telling you I am Not Pedantic.
As I Live " Down Under " I Take my Gravity Tablets and Wear my Magnetic Boots to Keep me from Falling off.

Offline blackdalek

  • Supporter
  • CPC6128
  • *
  • Posts: 232
  • Country: au
  • Fraser
    • Awards
Re: I think my 6128's expansion port is bad :(
« Reply #58 on: 07:38, 17 March 18 »
With 2 cards connected, the voltage has not dropped below 4.85V

Is it time to ask @TotO his opinion on why SymbOS could be crashing while the Z-Mem is connected?

like
0
No reactions
CPC6128 modded with ABBA switch. External 5.25" floppy drive with side switch and Multiface 2. Now also sporting a joystick splitter and M4 WiFi board.

Offline Audronic

  • 6128 Plus
  • ******
  • Posts: 1.466
  • Country: au
  • I know RST3 . I now know a little More.
    • Awards
Re: I think my 6128's expansion port is bad :(
« Reply #59 on: 07:54, 17 March 18 »
? Are there any switches that are incorrectly set ? on the Z-mem.


Last thought have you ran a Memory test on the 1st 128 K.


Good night


Ray
like
0
No reactions
Procrastinators Unite,
If it Ain't Broke PLEASE Don't Fix it.
I keep telling you I am Not Pedantic.
As I Live " Down Under " I Take my Gravity Tablets and Wear my Magnetic Boots to Keep me from Falling off.

Offline blackdalek

  • Supporter
  • CPC6128
  • *
  • Posts: 232
  • Country: au
  • Fraser
    • Awards
Re: I think my 6128's expansion port is bad :(
« Reply #60 on: 08:00, 17 March 18 »
How do I run a memory test?

The Z-Mem has all its setting switches on same as they were when it arrived (top 2 switches are pushed to the right, left 2 switches are pushed up)

Chibi Akumas Ep1 also doesn't run without crashing when Z-Mem is connected.
like
0
No reactions
CPC6128 modded with ABBA switch. External 5.25" floppy drive with side switch and Multiface 2. Now also sporting a joystick splitter and M4 WiFi board.

Offline Audronic

  • 6128 Plus
  • ******
  • Posts: 1.466
  • Country: au
  • I know RST3 . I now know a little More.
    • Awards
Re: I think my 6128's expansion port is bad :(
« Reply #61 on: 08:11, 17 March 18 »
Memtest  disk
like
0
No reactions
Procrastinators Unite,
If it Ain't Broke PLEASE Don't Fix it.
I keep telling you I am Not Pedantic.
As I Live " Down Under " I Take my Gravity Tablets and Wear my Magnetic Boots to Keep me from Falling off.

Offline blackdalek

  • Supporter
  • CPC6128
  • *
  • Posts: 232
  • Country: au
  • Fraser
    • Awards
Re: I think my 6128's expansion port is bad :(
« Reply #62 on: 08:22, 17 March 18 »
Thank you.

Test.bin crashes after about 10 seconds with Z-Mem connected (I tried 3 times)

With no Z-Mem connected, the test.bin is still running stable while I am typing this post.
like
0
No reactions
CPC6128 modded with ABBA switch. External 5.25" floppy drive with side switch and Multiface 2. Now also sporting a joystick splitter and M4 WiFi board.

Offline Audronic

  • 6128 Plus
  • ******
  • Posts: 1.466
  • Country: au
  • I know RST3 . I now know a little More.
    • Awards
Re: I think my 6128's expansion port is bad :(
« Reply #63 on: 08:30, 17 March 18 »
Take a Photo of the Switches on the Z-Mem or a drawing so you can put it back to " Standard "


Operate each switch 5-10 times (With the Power Off) and do the test again.
Can you alter the z-mem settings for your 6128
? do the switches do ?
? Can you disable some of the memory ?


Ray
like
0
No reactions
Procrastinators Unite,
If it Ain't Broke PLEASE Don't Fix it.
I keep telling you I am Not Pedantic.
As I Live " Down Under " I Take my Gravity Tablets and Wear my Magnetic Boots to Keep me from Falling off.

Offline blackdalek

  • Supporter
  • CPC6128
  • *
  • Posts: 232
  • Country: au
  • Fraser
    • Awards
Re: I think my 6128's expansion port is bad :(
« Reply #64 on: 08:38, 17 March 18 »
The attached shows where the test.bin program ended (or stalled???) with no Z-Mem attached.

The 4 switches on the Z-Mem are labelled as follows:

CPC: "464" or  "6128"
RAM: "64K" or "SET"
"7FFE" or "OFF"
"7FFF" or "OFF"

Current settings are CPC "6128", RAM "SET", "7FFE" and "7FFF"


like
0
No reactions
CPC6128 modded with ABBA switch. External 5.25" floppy drive with side switch and Multiface 2. Now also sporting a joystick splitter and M4 WiFi board.

Offline Audronic

  • 6128 Plus
  • ******
  • Posts: 1.466
  • Country: au
  • I know RST3 . I now know a little More.
    • Awards
Re: I think my 6128's expansion port is bad :(
« Reply #65 on: 08:59, 17 March 18 »
Going Out now


turn off 7FFF
and try that


Bye


Ray
like
0
No reactions
Procrastinators Unite,
If it Ain't Broke PLEASE Don't Fix it.
I keep telling you I am Not Pedantic.
As I Live " Down Under " I Take my Gravity Tablets and Wear my Magnetic Boots to Keep me from Falling off.

Offline blackdalek

  • Supporter
  • CPC6128
  • *
  • Posts: 232
  • Country: au
  • Fraser
    • Awards
Re: I think my 6128's expansion port is bad :(
« Reply #66 on: 09:06, 17 March 18 »
Switching the 7FFF switch to "OFF" didn't help.

Thanks @Audronic for all your kind help today.

Have a great night!
like
0
No reactions
CPC6128 modded with ABBA switch. External 5.25" floppy drive with side switch and Multiface 2. Now also sporting a joystick splitter and M4 WiFi board.

Offline blackdalek

  • Supporter
  • CPC6128
  • *
  • Posts: 232
  • Country: au
  • Fraser
    • Awards
Re: I think my 6128's expansion port is bad :(
« Reply #67 on: 10:42, 29 March 18 »
Running the memory tester with only the Z-Mem plugged in directly to the expansion port generates random pixel garbage and frequent crashes and resets. I get the same results running it from the MotherX4 board with or without 5V power supply attached.

@totO I am not sure if this is because my expansion port is still bad or if something is wrong with my Z-Mem card  :-[

Can I post my Z-Mem card to one of our Australian technical boffins to examine it for me?

The M4 WiFi card and Multiface2 Card are both working without crashing now. They both co-exist happily together on the MotherX4 board. So the repair work I've done on the expansion port and power switch re-soldering has made some improvement at least.

The Z-Mem card crashing seems to be the only issue I am having now at the moment.
like
0
No reactions
CPC6128 modded with ABBA switch. External 5.25" floppy drive with side switch and Multiface 2. Now also sporting a joystick splitter and M4 WiFi board.

Offline Audronic

  • 6128 Plus
  • ******
  • Posts: 1.466
  • Country: au
  • I know RST3 . I now know a little More.
    • Awards
Re: I think my 6128's expansion port is bad :(
« Reply #68 on: 10:50, 29 March 18 »
Is it possible to switch off all of the Expanded memory on the Z-Mem ( I don't Have one).
and have it connected to see if the Faults continue.


Good Luck


Ray
 
like
0
No reactions
Procrastinators Unite,
If it Ain't Broke PLEASE Don't Fix it.
I keep telling you I am Not Pedantic.
As I Live " Down Under " I Take my Gravity Tablets and Wear my Magnetic Boots to Keep me from Falling off.

Offline blackdalek

  • Supporter
  • CPC6128
  • *
  • Posts: 232
  • Country: au
  • Fraser
    • Awards
Re: I think my 6128's expansion port is bad :(
« Reply #69 on: 11:53, 29 March 18 »
I've tried every possible combination of switches. I get garbage on screen and crashing every time any of the memory switches are turned on. I have no idea what the RAM: "64K" or "SET" switch does, but either setting makes no difference. Also the switch CPC: "464" or  "6128" makes no noticeable difference either.

Is it possible to switch off all of the Expanded memory on the Z-Mem ( I don't Have one).

I can post you mine for testing if you like... BTW, did you get your Z80 back OK?
« Last Edit: 12:03, 29 March 18 by blackdalek »
like
0
No reactions
CPC6128 modded with ABBA switch. External 5.25" floppy drive with side switch and Multiface 2. Now also sporting a joystick splitter and M4 WiFi board.

Offline Audronic

  • 6128 Plus
  • ******
  • Posts: 1.466
  • Country: au
  • I know RST3 . I now know a little More.
    • Awards
Re: I think my 6128's expansion port is bad :(
« Reply #70 on: 12:13, 29 March 18 »
Yes the Z80 has arrived, I have been busy with a major crash on my Mac and the Bl##dy NBN, change of service provider, new email address etc.


My thoughts would be Politely PM TotO for some help he may have some updated documentation to help with the switch positions.
He is a Member on this board.


I could have a look at it But Please ask TotO first.


Is the board well soldered, No connector pins bent  etc.


Ray
« Last Edit: 12:17, 29 March 18 by Audronic »
like
0
No reactions
Procrastinators Unite,
If it Ain't Broke PLEASE Don't Fix it.
I keep telling you I am Not Pedantic.
As I Live " Down Under " I Take my Gravity Tablets and Wear my Magnetic Boots to Keep me from Falling off.

Offline blackdalek

  • Supporter
  • CPC6128
  • *
  • Posts: 232
  • Country: au
  • Fraser
    • Awards
Re: I think my 6128's expansion port is bad :(
« Reply #71 on: 14:36, 03 April 18 »
Well, so far @TotO has not been in contact with me (I guess he's been away), and I have no other CPC to test with.... so can I post my Z-Mem card to you for testing Audronic? Or does someone closer in Queensland want to have a look at it for me? (I am on Darling Downs area Allora Qld)
like
0
No reactions
CPC6128 modded with ABBA switch. External 5.25" floppy drive with side switch and Multiface 2. Now also sporting a joystick splitter and M4 WiFi board.

Offline blackdalek

  • Supporter
  • CPC6128
  • *
  • Posts: 232
  • Country: au
  • Fraser
    • Awards
Re: I think my 6128's expansion port is bad :(
« Reply #72 on: 11:02, 05 April 18 »
Well, I'm still having issues with when connecting the Z-Mem card, so assuming the Z-Mem card is OK (it was tested before shipping) what else can I look at on my CPC6128 to troubleshoot expansion port issues.

Also, can I post my Z-Mem card to someone to test on their CPC just to rule out the possibility that the Z-Mem has somehow become damaged?
like
0
No reactions
CPC6128 modded with ABBA switch. External 5.25" floppy drive with side switch and Multiface 2. Now also sporting a joystick splitter and M4 WiFi board.

Offline blackdalek

  • Supporter
  • CPC6128
  • *
  • Posts: 232
  • Country: au
  • Fraser
    • Awards
Re: I think my 6128's expansion port is bad :(
« Reply #73 on: 17:02, 06 July 18 »
Still not found the cause of the problem with my Z-Mem. I don't know what happened to TotO - he seems to have disappeared for now...I have no other CPC to test the Z-Mem with. I really would like to get to the bottom of this and get it working.In short, everything seems to be working with my expansion port now with the exception of the Z-Mem which crashes the CPC consistently and randomly whenever it is connected.
like
0
No reactions
CPC6128 modded with ABBA switch. External 5.25" floppy drive with side switch and Multiface 2. Now also sporting a joystick splitter and M4 WiFi board.

Offline llopis

  • Supporter
  • 464 Plus
  • *
  • Posts: 303
  • Country: es
    • Noel's Retro Lab
    • Awards
Re: I think my 6128's expansion port is bad :(
« Reply #74 on: 17:18, 06 July 18 »
I don't know what happened to TotO - he seems to have disappeared for now
Just message him directly. He told me he had a really busy month of June, and now he may be available again. He's putting together an X-MEM for me right now.
like
0
No reactions