Author Topic: Sony PVM and the Plus machines  (Read 1219 times)

0 Members and 1 Guest are viewing this topic.

Offline beaker

  • 6128 Plus
  • ******
  • Posts: 810
  • Country: ie
  • Terrible at soldering...
    • index.php?action=treasury
  • Liked: 163
  • Likes Given: 244
Sony PVM and the Plus machines
« on: 01:51, 31 May 15 »
I plug in the locomotive cart and it's fine, hit F2 to go to burning rubber, the title screen is fine. Start the game and after a few seconds it loses sync but when it goes back to the main menu screen, it syncs fine. If I plug in the new SD cart the menu loads and after a couple of seconds I lose sync. If I plug in the original Burnin Rubber cart from my GX4000 it also looses Sync after starting the game. Copter 271 is fine until I get into the main game, the menu and briefing is fine, then that also loses sync.

Batman, now that works fine. As does Navy Seals, Switchblade and Robocop 2.

I've tried 2 different scart cables and my 464+ and 6128+ with the same results. It looks fine on the Plasma. I do have the original monitor which I can use but I quite like the Sony PVM.

Any idea why that would be? Can the game modify the frequency like in the x68000 or do some resolutions change the frequency slightly to upset it?

Thanks in advance

Offline robcfg

  • Supporter
  • 6128 Plus
  • *
  • Posts: 2.423
  • Country: se
  • 8-Bit Technomancer
    • index.php?action=treasury
  • Liked: 1102
  • Likes Given: 2686
Re: Sony PVM and the Plus machines
« Reply #1 on: 15:21, 31 May 15 »
Could it be a power problem? I'd check the psu and/or try a more powerful one to rule out power problems.

Offline arnoldemu

  • Supporter
  • 6128 Plus
  • *
  • Posts: 5.336
  • Country: gb
    • Unofficial Amstrad WWW Resource
  • Liked: 2283
  • Likes Given: 3478
Re: Sony PVM and the Plus machines
« Reply #2 on: 15:55, 31 May 15 »
I checked these games.

On all the CRTC settings remain unchanged, so they didn't reprogram the crtc at different points and created a display which is not 50Hz.

I did find something in common with Burning Rubber and Copter 271. It is the use of the Plus DMA.

Burning rubber uses it for the car noises i game. Copter 271 uses it in the menu and in game. So I expected copter 271 to be broken a lot.

Now Navy Seals uses it in game but briefly. If you press fire rapidly, does the tv unsync? I'm guessing because DMA is not active for long then no.

Batman is basically a CPC game so doesn't use plus features. Robocop 2 doesn't use DMA in game. Navy Seals does but very briefly.

My thoughts may appear crazy but I am wondering if the DMA fetch during HSYNC is causing the fetched pixels to be interpreted as colour/hsync and for your television it's loosing sync. I thought i read something somewhere about colour or black being important during hsync and vsync.

It all depends on what the Plus outputs at HSYNC/VSYNC time.

@gerald: Does the plus output black during HSYNC and VSYNC? Is there anything crazy appearing on hsync or colour for the problem games?
My games. My Games
My website with coding examples: Unofficial Amstrad WWW Resource

Offline beaker

  • 6128 Plus
  • ******
  • Posts: 810
  • Country: ie
  • Terrible at soldering...
    • index.php?action=treasury
  • Liked: 163
  • Likes Given: 244
Re: Sony PVM and the Plus machines
« Reply #3 on: 17:05, 31 May 15 »
Thanks for looking into this for me. Just an update, I've removed the component cables as it seems to share something on the TV as the button is marked RGB/Component and you have to switch using the menu, and it no longer has the sync issue in the games but the picture is blown out. I'd assumed that because the picture is fine with the component cables plugged in it was an impedance issue but looking at some forums I've now decided it just doesn't like syncing on luminance which was actually suggested to me back in March  :-[ I'll modify the cable in the next few days and see how it goes  :)

Offline beaker

  • 6128 Plus
  • ******
  • Posts: 810
  • Country: ie
  • Terrible at soldering...
    • index.php?action=treasury
  • Liked: 163
  • Likes Given: 244
Re: Sony PVM and the Plus machines
« Reply #4 on: 18:51, 31 May 15 »
That didn't work sadly. I swapped the yellow and purple wires around and I don't need to source from an external sync but the image is still blown out and it no longer works at all on the plasma screen so ignore my last comment  ;D

 [ You are not allowed to view attachments ]  [ You are not allowed to view attachments ]