CPCWiki forum

General Category => Technical support - Hardware related => Topic started by: geebus on 20:15, 13 October 21

Title: Very Odd disc drive read error CPC664
Post by: geebus on 20:15, 13 October 21
I've been working on a couple machines lately and one of them is a Schneider CPC664.
After getting it to boot, I serviced the drive and tested it on another machine. Made sure the head was clean, new belt and then set up the RPM.
Worked great on the other machine.
I put it back into the 664 and it wouldn't load anything. I tried loading the dsktest on my b drive and that wouldn't read either. Nor would a gotek work on said machine.
If i do a CAT command it generally shows whats on the disc. But if I try to actually load it I just get read errors.
I'm thinking that it's something to do with the CPC itself and not the drive as it worked on the other machines and the B drive also doesn't read.
I have some spare FD controller chips but I don't want to just replace them for the sake of it. In fact i'm not sure if they're the same as it's for the DDI interface. I'll check.

Does anyone have ANY idea on where I should even start to look for the issue? I have a scope and happy to use it.
Title: Re: Very Odd disc drive read error CPC664
Post by: geebus on 19:18, 15 October 21
A bit of an update. I thought i'd probe around the logic chips that work with the floppy drive control chip.
I found that on IC206 pins 13&12 were low meaning that output pin 11 should have been high (this going to side 1 select on the drive(s) active low). Looking at the schematic now, it looks like that is the desired outcome. But i'm confused as to how this is outputting a low signal from a NAND gate with two low inputs.
Similar thing is happening with 10&9 (tied to pins 4&5 which have the correct low signal out on pin 6). They're both high (although the signal looks faint on the scope screen). The output pin 8 is also high (again looking faint on the screen.
This time however I don't think it's correct (just checked an identical working 664 and it seems to be the same).
I have tested both 74ls38 chips and they've tested fine on the chip tester.

I thought R214 might have been the culprit making the signals on 4,5&8 go high. but that also rested fine.

Seeing as the AMSDOS ROM was socketed I thought i'd just check that. Same results with a newly burned ROM.

Checking IC202 I am getting signals that look fairly good from each of the pins.

I'm starting to wonder if the problem is with the upd765ac chip. I do have two replacements, but I don't have any 40 pin sockets and I would much rather know it was that, that was causing the problem rather than just ripping chips out to test new ones.
Powered by SMFPacks Menu Editor Mod