Author Topic: Weird Issue in Monitor GT64 Amstrad CPC464  (Read 589 times)

0 Members and 1 Guest are viewing this topic.

Offline carcuevas

  • CPC464
  • **
  • Posts: 8
  • Country: es
  • Liked: 0
  • Likes Given: 4
Weird Issue in Monitor GT64 Amstrad CPC464
« on: 14:08, 01 April 21 »
Hi all :)


First at all, Greetings to everybody, I did not imagine that still being such a big and active community for the CPCs ;-) 


Well, yesterday after 25+ years, I decided to give a try to the family Amstrad CPC464, and at the beginning was everything more than less ok, but suddenly the monitor started to do some weird stuff; like it would be out of Sync, but not the v-sync that it seems to be ok; and since and image is worthy more than 1000 words I recorded a video so you can see what's happening to me:



https://www.youtube.com/watch?v=sjWfe2tk_5U


Did any of you have the same issue? I am not sure if it is some problem with the Cable/DIN connector or some Capacitor.... ? what do you think?


Many thanks in advance :)




Offline Dagger

  • CPC664
  • ***
  • Posts: 124
  • Country: gb
  • Liked: 41
  • Likes Given: 29
Re: Weird Issue in Monitor GT64 Amstrad CPC464
« Reply #1 on: 14:19, 01 April 21 »
I have something similar with my green screen monitor. It's like that when I first powerup. Switching it on and off quickly normally sorts it. Will have to get it fixed properly at sometime though as something obviously is not right.
Life's a bitch. You marry one or two then you die !

Offline carcuevas

  • CPC464
  • **
  • Posts: 8
  • Country: es
  • Liked: 0
  • Likes Given: 4
Re: Weird Issue in Monitor GT64 Amstrad CPC464
« Reply #2 on: 15:12, 01 April 21 »
Ohh indeed it's helping !!! :)




Thanks very much... but it's kind of weird thing.... Wondering what it can be...   :-\

Offline Bryce

  • The Hardware Guy.
  • Supporter
  • 6128 Plus
  • *
  • Posts: 12.299
  • Country: wf
  • It's not broken, it just hasn't been fixed yet.
    • index.php?action=treasury
  • Liked: 4596
  • Likes Given: 481
Re: Weird Issue in Monitor GT64 Amstrad CPC464
« Reply #3 on: 19:58, 01 April 21 »
You need to clean the V-Hold variable resistor, too much dust / crap etc. If that doesn't solve it you need to replace some capacitors.

Bryce.

Offline carcuevas

  • CPC464
  • **
  • Posts: 8
  • Country: es
  • Liked: 0
  • Likes Given: 4
Re: Weird Issue in Monitor GT64 Amstrad CPC464
« Reply #4 on: 00:24, 02 April 21 »
Hi Bryce,


today I cleaned a bit the V-HOLD potentiometer. but still doing it... Also from first inspection, capacitors looked just fine, no leaks no selling...  :-\  it was fast inspection, I Will need more time, so I can discharge the CRT and capacitors so I can inspect this properly.... Do you know what capacitors I should check ?


Thanks :)

Offline awergh

  • CPC6128
  • ****
  • Posts: 297
  • Country: au
  • Liked: 179
  • Likes Given: 324
Re: Weird Issue in Monitor GT64 Amstrad CPC464
« Reply #5 on: 10:01, 02 April 21 »
I have a similar looking thing that happens with my GT64 if the DIN connector and cable is not positioned correctly.
Once its in the right spot it is all good, not sure if its exactly the same thing but a similar effect occurs.

Offline Bryce

  • The Hardware Guy.
  • Supporter
  • 6128 Plus
  • *
  • Posts: 12.299
  • Country: wf
  • It's not broken, it just hasn't been fixed yet.
    • index.php?action=treasury
  • Liked: 4596
  • Likes Given: 481
Re: Weird Issue in Monitor GT64 Amstrad CPC464
« Reply #6 on: 10:59, 02 April 21 »
Yes, cleaning the pins on the DIN connector could also possibly solve this issue.

Bryce.

Offline carcuevas

  • CPC464
  • **
  • Posts: 8
  • Country: es
  • Liked: 0
  • Likes Given: 4
Re: Weird Issue in Monitor GT64 Amstrad CPC464
« Reply #7 on: 23:47, 02 April 21 »
I cleaned the connector from the computer, but not the monitor one, I will give a try tomorrow and let's see if it helps :)


thanks guys :)

Offline carcuevas

  • CPC464
  • **
  • Posts: 8
  • Country: es
  • Liked: 0
  • Likes Given: 4
Re: Weird Issue in Monitor GT64 Amstrad CPC464
« Reply #8 on: 02:10, 05 April 21 »
uhmm actually didn't help, so I guess it should be there some problem with some capacitor or that variable resistor...

Offline carcuevas

  • CPC464
  • **
  • Posts: 8
  • Country: es
  • Liked: 0
  • Likes Given: 4
Re: Weird Issue in Monitor GT64 Amstrad CPC464
« Reply #9 on: 00:56, 08 April 21 »
Also I am hearing many times some noises from the speaker, like some statics, cracking and so... I think it can be related because when moving the power cable is changing the noise... So maybe, it's coming from the monitor... So again, it can be because of some capacitor not filtering as it should...  :-\  not sure....

Offline Bryce

  • The Hardware Guy.
  • Supporter
  • 6128 Plus
  • *
  • Posts: 12.299
  • Country: wf
  • It's not broken, it just hasn't been fixed yet.
    • index.php?action=treasury
  • Liked: 4596
  • Likes Given: 481
Re: Weird Issue in Monitor GT64 Amstrad CPC464
« Reply #10 on: 09:48, 08 April 21 »
Crackling sounds on the speaker probably means that the 5V power socket needs to be cleaned too.

Bryce.

Offline carcuevas

  • CPC464
  • **
  • Posts: 8
  • Country: es
  • Liked: 0
  • Likes Given: 4
Re: Weird Issue in Monitor GT64 Amstrad CPC464
« Reply #11 on: 17:40, 08 April 21 »

Thanks again Bryce, it looks like you really know this machine :) Interesting, I used the contact cleaner for the connectors in both ends, so I am not sure what I can do more for cleaning it, unless it would require to clean it inside the monitor, this I did not do ... ...

Offline Bryce

  • The Hardware Guy.
  • Supporter
  • 6128 Plus
  • *
  • Posts: 12.299
  • Country: wf
  • It's not broken, it just hasn't been fixed yet.
    • index.php?action=treasury
  • Liked: 4596
  • Likes Given: 481
Re: Weird Issue in Monitor GT64 Amstrad CPC464
« Reply #12 on: 17:52, 08 April 21 »
I meant the power socket this time, not the monitor socket. However, it may just be noise on the power grid or something like a fridge on the same phase in your house. Almost any spikes on the power line make it to the speaker.

"looks like you really know this machine" - I've fixed a few CPC's before (6 of them this week in fact), I'm like a fat-fingered version of Louis Rossman :D

Bryce.
« Last Edit: 17:54, 08 April 21 by Bryce »

Offline carcuevas

  • CPC464
  • **
  • Posts: 8
  • Country: es
  • Liked: 0
  • Likes Given: 4
Re: Weird Issue in Monitor GT64 Amstrad CPC464
« Reply #13 on: 01:33, 09 April 21 »

Actually it shouldn't be a lot of noise in the power grid, and I think there is no fridge/motor in the same phase normally...  today I realized that the noise it's happening mostly when the relay from the tape is released (even without tape) but since I cleaned once more the barrel connector and the socket  seems that it's not happening that  often anymore :)

've fixed a few CPC's before (6 of them this week in fact), I'm like a fat-fingered version of Louis Rossman
heheheh  :)  so you know them pretty well :)