Announce: uRTC-8 universal RTC for the PCW and other Z-80 computers

Started by JonB, 21:24, 01 October 19

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.


Hi all

Following discussion of a real time clock board for the PCW, I'm pleased to announce that work on the hardware design and software utility is now complete.

The documentation is available on the Wiki: http://www.cpcwiki.eu/index.php/URTC-8_Universal_RTC_for_Z80_computers

The basic price for the board, fully built and tested, is £37 plus shipping. Please read the wiki page to find out more.

At this time there is only a limited number of boards, but I can acquire more if the demand is there. Please let me know if you want one, and I will maintain a list. If you have uIDE-8 on your computer, you will need to add a third 40 way connector to your Z80 bus cable, if there isn't one there already. Orient it the same way round as the one your uIDE-8 is plugged into. If you don't have uIDE-8, you will need either a Z80 shim or PCW expansion board, plus a Z80 bus cable in addition to the uRTC board. See the uIDE wiki page for details of how to connect uRTC to the computer, and pretend that it is talking about uRTC rather than uIDE!



Demo video on the PCW (when it completes upload & processing):


Nice! Now I need to get a PCW...
would it work with the CPC as well somehow?


Not the 6128 as it uses 16 bit I/O addressing. 464 I'm not sure about.


Quote from: JonB on 20:01, 02 October 19
Not the 6128 as it uses 16 bit I/O addressing. 464 I'm not sure about.
It's 16 bit for all CPCs, Plus and GX4000. But for CPC there are about five other solutions (regarding RTCs).
http://futureos.de --> Get the revolutionary FutureOS (Update: 2023.11.30)
http://futureos.cpc-live.com/files/LambdaSpeak_RSX_by_TFM.zip --> Get the RSX-ROM for LambdaSpeak :-) (Updated: 2021.12.26)




I'll have one as well please. Even though I literally have no time whatsoever right now, which seems slightly ironic.  ;D


OK, I've built four units and will contact @GeoffB17, @torrind, @TynH and @Proteus for payment soon. I did have a fifth unit but one of the clock chips I bought was dead, so I have to wait for more to arrive before sending out any more. @Sucram, you're next.

Oh.. I found another bug in the uRTC.COM program, which I thought I'd squashed.. sigh.

By the way, I dropped the price to £34 plus shipping.   ;D


OK, I have fixed the bugs in uRTC.COM and will now ship the boards.

The wiki page has been updated with a download link. You want the latest for the PCW, which is (as of this post) v0.2.


Hi Jon,

This is how everything is connected.




[Context: Darren's having problems with his uRTC board...]

Hi Darren

As you know, I test every board before shipping in order to minimise the chance of problems when it is first used by the recipient.

The program (uRTC.COM) is waiting for the clock chip to deassert BUSY. If the chip is broken or not connected, this never happens, so the program is designed to time out and give the error message you are seeing. So either you have a bad connection or a defective LS668 or clock chip.

Please try the following in order to narrow it down.

  • Clamp the cable connectors in a vise, tightly. There is a (vague) chance that a wire isn't making full contact. I get this a lot with old IDE cables that have gone stiff with age. Make sure the cable clamp piece is hard up against the cable - no gaps allowed, especially on the connector side.
  • Ensure the chips are seated properly and the I/O selection is correctly set at 1011.
  • Pull the battery and re-try. You'll need to set the date/time and then see if you can read it back without power cycling the PCW.
  • Swap the LS668 on the uIDE for the one on the uRTC.

If none of these actions get your uRTC working, then I would conclude the clock chip has developed a fault. I don't know how this could have happened in transit, unless you have inadvertently connected the board while the PCW was switched on (which I doubt - I'm sure you know what you're about!). I am waiting for some more clock chips from China so I can send you another one when they arrive.

There is another thing to try. If you have the program SURVEY.COM, please run it and tell me what it says (with the uRTC connected, and again with it disconnected). Also try IOMAP.COM, both are in the attached ZIP file. Are you running on a 9512 or 8256/8512 series PCW? It occurred to me that the uRTC I/O addresses may be already in use on the 9512. As I have no more clock chips I cannot test on my 9512 at the moment.

[Edit: I ran SURVEY.COM on my 9512 and it looks like the default uRTC I/O addresses (B0h to BFh) are free, so that's not the problem.]



Hi Jon,

Thanks for the comprehensive response. OK so lots of strange stuff going on....

This is what I did:

1. I checked my home-made IDE cable - I don't have a vice and so used a pair of pliers - But after various tests tonight I've concluded its not working correctly and so I've hidden it at the back of my odds n sods drawer - never to be used again! I have taken my known working IDE cable currently being used by uIDE and added a new female connector - this seems to give better results but still uRTC doesn't work (when I say better results, I mean that survey.com doesn't crash when uRTC and / or uRTC are attached!!)

2. I swapped over the LS668's but this didn't make a difference (in fact the chip from uRTC placed into uIDE caused the C: drive to perform random beeps and display garbled directory entries, so I swapped them back.

3. I ran survey.com and iomap.com before and after uRTC was attached. HOWEVER, after doing so I noticed that if I ran survey.com with uRTC attached, it gave a value of 140 ports active and 139 disconnected as per the screenshots - BUT if I then ran survey.com again and again with uRTC connected, the value dropped from 140 to 139....

all very odd....

For info, uRTC is set to 1011 (reading left to right) and I'm running a PCW8256 with a memory upgrade to 512k

Ultimately it may be down to bad cable crimping by me, so I have ordered a ready-made cable from Ebay which should arrive in the next few days.

I'll let you know ???

[Edit - screenshots too large, so will send them separately.]




here are the remaining attachments - smaller in size....


OK Darren, thanks. It's telling that none of the I/O ports used by uRTC are seen (B0-BF) in the IOMAP report.

You're right, the crimp connectors are difficult to use when all you have is pliers (ask me how I know...), plus the connector itself always gets scuffed up.

I use a mini vise - one of these: https://www.amazon.co.uk/STANLEY-MAXSTEEL-Multi-Angle-Vice/dp/B001HBS0I0

Very cheap, not very accurately made (the thread on mine seems to be slightly bent so the jaws wobble slightly as I tighten it) but for the money it's spot on. And very, very useful.


ooooh!    ;D

[Edit:  Just placed an order for one......]


Just a note to say uRTC is live!!! ;D  - it was all down to DDCC (Darrens Dodgy Cable Crimping)

[Edit:  I cannot get INITDIR.COM to work. If I issue the command on any drive, it freezes the PCW and I have to do a hard reset. For info, I'm running CP/M+ version 1.7h
Any ideas please?]



Hello Darren,

I've got 1.7h somewhere, I'll have to try this.

However, some questions.

How long do you leave it before deciding that the machine is locked up, and what happens in the meantime?   Is there evidence of disk activity?  Please give a little (lot ?) more detail.

Which version of INITDIR are you using?  I assume there's a screen message as it loads/starts?   Or don't you even see that?

Which drive are you trying?   Are you trying to run the process on a uIDE drive?   There are a lot of files on some of JonB's drives, and the prog may need to do a lot of work.   When you say there was a problem for ANY drive, does that include the floppy drive, or M:?



Since the above, I've found I had already created a boot disk for 1.7h.

I've booted my PCW, and tried a few things.

I've run INITDIR OK on both B: (floppy) and on drive P: (one of the uIDE drives, which was empty anyway).   Both seemed to work fine, no hang up, lock, or whatever.   I notice that the INITDIR prog does not give any indic as to version, so maybe it's just a bog standard one, there is a date visible in the file of 15/12/82.  I think there is also a Y2K version of INITDIR?   More recent?

Or maybe the problem is nothing to do with the prog??



Hi Geoff,

Thanks for the response.

Not sure of the version of INITDIR, but it was the version as pointed to by Jon here:

[size=78%]Download link[/size]

I've tried running it on the A: drive, B: drive and uIDE C: drive some of these drives have many files (c:) the B: drive only had two files on it.
After running the command, I've waited up to 10mins with no activity - my PCW hangs and I have to perform a hard reset. No errors are generated and no disk activity seen.
WRT the A: and B: drives, they aren't floppy drives, but Gotek drives. Not sure if this is the issue, however as you have got uIDE P: drive to work, and I can't, maybe its not that?



I've downloaded the version of INITDIR that you're trying to use.

I've put this file, and the one I've just used (that seems to work OK) onto my PC and used the FC (File Compare) utility to compare them both.

Your version seems to be maybe 1 byte bigger, there is an extra byte at &H35FF.   The two files are identical up to then, and seem to be identical after.   I don't know how the extra byte has got in, or if this is actually a problem, but my version works and yours seems NOT.

Quickest way to check this, I'll put the file I have into a .ZIP and attach it to a following message.   Try this and see what difference it makes.



File attached.   This has been renamed as INITDIR.CPM by 22DISK, just rename it as .COM after extraction from ZIP.

This file is slightly larger due to junk on the end, the file has been copied by complete sectors, but this should not matter.



Er - actually, it's the file I had that has an extra byte.   So the file you have seems to have LOST a byte at offset &H35FE.

Worry more about what's what when we find if the file I've just sent you works now!!


Powered by SMFPacks Menu Editor Mod