Cannot make a working copy of MAIL232.COM

Started by GrantMeStrength, 07:39, 18 July 22

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.


I've been tinkering with the PCW 8256 (in fact, two different ones) and I'm hoping someone can help me with an issue around the MAIL232.COM program.

It took me too long to work out it was on the Locoscript disc, but marked at SYSTEM so it wouldn't show up with DIR (without options anyway). Once I found it, it works fine.

The problem I have is that I've a GoTek in my primary drive, and a higher density drive in the lower bay. MAIL232.COM launches fine from drive B, but when I try to copy it to either M: or A:, it seems to copy but it never launches properly. This happens on two separate machines. 

What am I doing wrong? I have to launch MAIL232 from the precious floppy disc every time - I'd like to copy it to the GoTek and launch it from there! (Also, any alternatives to MAIL232?)



Can't help you with the MAIL232 problem but I used MEX.COM "back in the day" (on a 6128) for file transfers and once configured correctly it worked fine.

You might find this of help:


Thanks! Maybe there's a GoTek disk image with that on it.. and maybe even MAIL232 as well now I think about it.



Don't know what's causing your problem, I've not seen anything like this before.   I've not got a Gotek.

I attach a .zip file of a .dsk image created within the Joyce emulater, this includes a version of Loco incl MAIL232.COM.   What does this do?   If you try to run the MAIL232 prog, what actually happens (what do you see on the screen)?



Just out of interest, I've tried a couple of things on my (real) PCW.

I've booted up CP/M, and used an old (real) Loco System disk that has MAIL232 on it.   All my 'working' Loco disks will have had this file removed to free up space.

Then, I've used NSWP to copy this file to M:.

I've then tried to run MAIL232 from M:, which seems to work fine, although the prog complains that there is no CPS8256 unit attached.  The prog then continues OK, and may well have problems later dep on what you've got attached, and what you try to do.

Do you have an active comms port?



Thanks Geoff for taking the time to reply.

First, yes, I have serial interfaces which work. Both are homemade (not my design though) and one is a straight to 9-pin RS232 port, the other to a WiFi interface (via an ESP microcontroller). Both use the original Amstrad design with a Zilog DART and an Intel PIO chip, and both work with CP/M "right out of the box". When CP/M boots, they are recognized in the startup message. When MAIL232 is launched, it works. Hardware handshaking is required when they work at 9600 baud.

Since posting, I've found a copy of MAIL232 (but I will try your disk image, thank you). I've also no access to the original PCW device (at my mum's house) and I am back with my other PCW. (I mean, who doesn't have a spare PCW?)

I can't work out why my copy of MAIL232 didn't work, but if I have the same problem again I will use some CP/M tools to examine the files and see what was up. My initial query was really to see if this was a known issue and I was missing something obvious!

I've just used the WiFi interface to connect to a telnet instance which means the PCW is (kinda) running Linux now. Fun stuff!


Hm, I've NOT got a 'spare' PCW - if my machine died, I'd have to find a way to repair it, or replace it.   Long ago, I had the usual problem with the A: rubber band, that got replaced.   Later, the stepper motor went, got it repaired (thanks again, Bryce).  Otherwise, it keeps on working (since I bought it new 1985).

No, I've no idea why MAIL232 was not working.  The first thing it will do is check for the SIO interface, that might have been a problem.  Don't know why you'd get nothing at all.  File corruption?  When I did what you said you'd done, all seems OK/normal.

I've got the CPS box, and I used it long ago, I'm sure with MAIL232.   I wrote my own file transfer progs, incl to link with a BBC.  More recently, I tried the hidden LIFE 'game' built into MAIL232, that was working.  I prob used the prog from A:, and prob from B: as well (I've got a 5.25" drive as B:).   No reason to think it would not work from any other drive.


Powered by SMFPacks Menu Editor Mod