CP/M boot files, Gotek, and uIDE

Started by lcww1, 00:20, 16 December 19

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.



This is my first forum post! I've been on this forum since I got a PCW 8256. I've replaced Drive A with a Gotek unit, and upgraded the RAM to 512k.

Most recently, I've bought uIDE and uRTC boards from JonB. These boards are working nicely, but I'm having a problem with the J15CPM3 boot file. I downloaded the J15CPM3.EMT boot file from the link on the uIDE wiki page, and renamed the file J15CPM3.EMS (otherwise the boot file appears not to be recognised by the PCW 8256). I've been moving files to and from the Gotek PCW disk images using cpmtools on a Mac.

Placing the J15CMP3.EMS file in a PCW disk image on the Gotek, the machine will boot, but the process hangs just before the A> prompt should appear. I've found that if I eject the disk image, the boot process comes back to life: I get a Drive not ready error. If I then remount the same CP/M boot disk image on the Gotek, and select the Retry option, the boot process continues, the uIDE driver is loaded, and all then appears to be well.

I'm wondering why the boot process hangs with the J15CPM3.EMS file. Has anyone else experienced this problem? I assume that this problem is something to do with the Gotek. I can see that there are others on this forum using a uIDE in a PCW with a Gotek, so I wonder if there is an alternative CP/M boot file out there that works better than the one linked to on the uIDE wiki?

Rummaging around on the web, I've not found any other PCW CP/M boot files that I could use with the uIDE. I did find one other account of a similar sounding boot problem with the J15CPM3 file tho' - [size=78%]https://hackaday.io/project/27549-the-pcw-project/log/69755-sd-card-drive-in-cpm[/size]

Any thoughts or advice on this issue would be most welcome!



Well, your setup is almost the same as mine, except that I don't have a Gotek, and I have a B: drive (usually a 5.25" floppy, but could be a 3.5" drive).

You don't say anything about a B: drive.  Do you have such?

On the basis of what you say, the process is sticking somewhere close to the point where the EMS system file is loading/setting up, and before it loads the .FID file that activates the uIDE drive.  This is BEFORE the A> prompt would usually appear, and I think before it would be looking for PROFILE.SUB, so I don't think it's anything to do with that.

The 1.15 system file (aka 2.15) is really a 9xxx system file, and one possibility is it's checking for a B: drive.   Another possibility might be if there are any other .FID or FIB files there, and the system is again looking for a B: drive, or is not sure that A: is there.   What files are on your boot image, and where did you get it from.   I would suggest that you need to check what other .FID or .FIB files are there, you need the one for the uIDE ONLY.

There is a somewhat earlier system file that does work, 1.07H and this might not include anything relating to 9xxx series systems but I'm not at all sure.

If the Gotek is set up correctly then it should present as A: without any problem - the boot process is starting anyway.

I forget which earlier thread it was, but there was someone else having a similar problem, getting a disk error, but things then OK after a retry.   I think that again was to do with recognising A: and B: at the correct time, also make sure you're booting from an A: format image.



The incompatibility between the Gotek and J15CPM3 is a well-known issue - basically, the Gotek reports 'drive ready' even when the drive motor is turned off. There are various hardware modifications to get round this, but the easiest fix is to use the earlier EMS file (1.07H), which doesn't do this check.


Further to John's message, here is the 1.07H .EMS file.



For what its worth,

I have twin Goteks in my 8256 and I found the same issue. Changing to version 1.7H cured the problem.




and welcome to the forum ICWW1, enjoy your stay!  ;D



Thanks a lot to everyone for these swift and helpful replies!

I very much appreciate this assistance - my googling had clearly been too narrowly focussed on PCW CP/M bootfiles, whereas a wider search would have pulled up the PCW Gotek motor signal issue.....

I'll have a go with the 1.07H bootfile at the weekend (thanks for posting that, Geoff), but I think I'll just modify the Gotek, as that looks to be straightforward.

At the moment, I have the Gotek fitted as drive A in the PCW, with no drive B, but I'd like to fit the otherwise redundant 3in floppy drive as drive B. Looking around the forum, this appears to be possible, though there do seem to be some issues with fitting a 180k 3" floppy as drive B which I'm not sure that I've properly understood, as yet.

And Darren - nice to see you here!



To use a 180k 3" drive as B: you'll need:

  • To configure it as drive 1 rather than drive 0, either by swapping the select lines in the cable or by finding and changing the option link on the drive itself.
  • B180.FIB on the boot disk
  • CP/M BIOS 1.14 or 1.15 (so you'd need to do one of the hardware mods on the Gotek).



Please note you may have a bit of trouble fitting the 180k drive as B:

Your usual version of Disckit may not let you format a 180k disk in B:.   The software will assume that B: is a 730k format.  Looking through John Elliot's data regarding Disckit, it looks like you may need to find a copy of Disckit v 4.2, which I understand may do the job, but I cannot see that I've ever seen one of that, and I'm not sure where you might find one.   I'll check anyway.

Of course, if you already have any A: formatted disks (for CF2, single sided) then they should work OK in the drive even if it's mounted as B:.




Further to the above, I checked various files I had and found that I had a 9512 dsk image containing:

J25CPM3.EMT - this is 2.15
B180.FIB (disabled as .XXX)

When I checked the DISCKIT I find that this is v.4.2

I tried to run the DISCKIT and it makes no mention of the format type, but maybe this would be dependant on the B180.FIB being loaded?

If you need any of these bits, do let me know.



John & Geoff - many thanks for this information on a 180k drive B - that is really helpful to me - I'll try things out this weekend and report back - thanks for offering the files Geoff, I'll let you know if I need any of those....


Regarding DISCKIT 4.2

The reference above to trying the prog was using the Joyce emulator.

I have now copied the prog onto my real PCW, and tried it there.   This was using the current normal setup, i.e. a 'normal' system file, the normal A: disk for the PCW 8256, and the currently attached 5.25 360k B: drive.

DISCKIT runs fine, no complaint, with the screen layout pretty much for my normal original DISCKIT.   However, if I select the FORMAT option, the initial screen indicates a 180k disk for A:, but does not specify anything for B:, so I'd guess it IS checking the drives and trying to determine what's there.

I did not proceed with FORMAT, however I went into VERIFY B: and this indicated that it was expecting a 180k disk in B:.   This is not unreasonable, as DISCKIT will not be aware of the 360k option, and it has decided that 180k is more reasonable (anyway, one side of the 360k DS format is 180k anyway).   When I proceeded with the VERIFY, the process stepped through 0 to 79, and then reported that the disk was verified OK.   It may have done both sides?

So, the prog could well be able to format a 180k disk in B: quite happily.   Regardless of system and FIB/FID loaded?   I'd be interested to know.


Sebastian Blanco

I have exactly the same problem when i use a modern modded 3.5 drive (hacked rdy signal usinga wire), this only fails when using the cpm 3 jic file exactly as it happens on your gotek drive.Using a vintage 3.5 drive that have jumpers for the ready signal works perfectly.
I was thinking if is possible to modify cpm 3 to boot anyway ?.


@Sebastian Blanco

What is the Brand and Model number of the 3.5" disk drive.

Thanks.   Ray
Procrastinators Unite,
If it Ain't Broke PLEASE Don't Fix it.
I keep telling you I am Not Pedantic.
As I Live " Down Under " I Take my Gravity Tablets and Wear my Magnetic Boots to Keep me from Falling off.



Have you tried the 1.07H system version attached above?  Does this help.

It may well be possible to patch the system file to avoid the check, but this is problematic.   It depends on the actual code, and it changes between versions, sometimes even there might be similar code in more than one place that will need changing, but the code in each place may not be identical.

Some time ago I needed to use my 5.25" drive to boot from, as my 3" drive had failed.  I had a problem and John Elliott advised how to patch system version 1.01 (VERY early version) and this worked fine in most regards.   I thought 1.04 might have been a bit better, but when I tried to find a similar patch for that it did not work, the code was different, and in more than one place.   I had to stick with 1.01.   But Bryce fixed my 3" drive (the HERO) so it became academic.  If 1.07 does work, stick with that.

Oh, what do you mean by 'jic file'?


Powered by SMFPacks Menu Editor Mod