Cyrus II Chess Game Not Reading

Started by PCW8256, 15:20, 25 March 21

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.


Hi All!
I bought a copy of Cirus II on a 3 inch disk (for my PCW8256). I bought it untested so had no idea whether it would work!I've tried running it but simply inserting in but the disk drive attempts to read it but it doesn't go any further than that! I've looked in my manual and couldn't find anything
Is it something I'm doing wrong or is it simply the disc is just faulty?Probably a really silly question... but this is my first Amstrad PC and I want to be able to learn!Thanks!


Does the PCW boot from a CP/M disk? If so, start CP/M, put the Cyrus II disk in and type DIR to see if it can be read.


Quote from: JohnElliott on 16:14, 25 March 21
Does the PCW boot from a CP/M disk? If so, start CP/M, put the Cyrus II disk in and type DIR to see if it can be read.
Thank you!! I've done that and there are system files on there!



If the PCW reports 'System Files' ONLY, then you need to use the DIRS (or DIRSYS) instead of DIR which will list the system files.

There are two ways the game might start.   There may be a file like '' which you start from the CP/M command prompt.   I have the 3-D Clock Chess that starts that way.

OR, there might be a file like 'chess.ems' which means that you need to boot the system using this disk.  So this system may not use CP/M at all, or the system includes a very cut down OS of its own.

Either way, once you've finished the game, you may need to reboot the computer as the software will have totally taken over the system.



Thanks for the reponse:
I've had a go at that this is what it came back with:A> DIR
I tried using '' and 'chess.ems' but they just come make no file.



That's not right?

There is an image to download of this on the PCW Wiki.   I've just downloaded this.   Just for information!

The disk should show two files:


which seems reasonable.

The CYRUS file is very small, I'd guess that this is just a 'loader'.

The other file is rather obscurely named, and I suspect that this is NOT supposed to be run directly.  This file is fairly large, and I'm sure that this is the meat of the system.

I'd assume that you run CYRUS which will give you a loading screen while the main prog loads, takes over the PCW's RAM, and prepares everything.   Then actually runs when it's ready.

Note that the disk has side A and B, they seem to be the same.   The disk is a CPC format, but one that the PCW should be OK with.

The game is clearly intended to run from CP/M, there is no .EMS 'system' file, so you need to load CP/M first.

The disk you describe sounds like it's been messed with.   There seems to be no sign of the correct files.   But check things separately on both side, in case the other side is better.

It is unlikely that a commercial disk would have the files set to 'System', as knowing about DIRSYS is more 'specialist'.

Also, I see that when you did a DIRS it reported that 'NON-SYSTEM Files Exist' so therefore the DIR should have given you something?   However, DISC.BAS is certainly NOT correct.

If you've got the pukka box (and manual) and a pukka disk with label, then you could get the images from the Wiki site and load the images onto the (maybe dud) disk??  Can you do that?

Just to be fair, it could wel bel that whoever sold the package had no clue as to what was on the disk, and no idea as to what might have happened with it, and no way to check the disk to check it was correct.   Hence selling it 'Untested'?




For extra information, please note that I've used the image I got within the Joyce emulator.

This works fine, a DIR shows one file ONLY, the CYRUS2.COM file, with System files.   So the large P3Q27RTX file must be marked System.  This is reasonable.

When I run the CYRUS .com file, it loads and works fine.  I played part way through a game.



Thank you very much!
I've loaded both sides and it says the same thing!I'm not sure how to load images to disks! Like I said I'm fairly new to everything but always up too learn how to do things!



I'm not sure why it would say 'the same thing'.   If you read another disk, does that say something different?   If you then read the CYRUS disk again, does that say the same as it said before, or the same as the other disk you just read (i.e. the CYRUS disk isn't reading properly).

I can write an image to a disk, but standard images ONLY.   The image I have for the CYRUS is an EXTENDED variant, and the progs I have to write an image cannot do them.   In this case, there seems to be some copy protection 'tricks' in the image, so this one prob NEEDS to be an EXTENDED image.  I have something that could convert an extended image to a standard image, but this will prob not work due to the copy protection tricks.

I assume that the actual disk you've got is the correct disk - i.e. with a CYRUS (or whatever) printed label?   If this is the case, then someone has written something onto the disk, and maybe even formatted it as well (or done a disk copy - which might explain how come the two sides are the same).  The image I have is NOT a 40 track image, it's less than half the disk.  This fact may be (part ?) of the copy protection.  There's some text in the loader prog (CYRUS.COM) which reports that it's a 'Pirate Copy' so this prog is checking something and has found something 'wrong' (or maybe something 'right' that should be 'wrong').

I'm sure we can salvage something though!



DISC.BAS is something you'd expect to see on a CPC disc, not a PCW disc.
There's a copy of Cyrus II Chess in the PCW Megapack; that has only one file on the disc (CYRUS.COM), which is in non-extended DSK format and doesn't seem to have copy protection. But the messages are all in French.


You have all the information in the PCWWiki. Includes original images of the disc in French and English. I hope that helps


Just out of interest, I tried to move the 2 files from the image (which works in the Joyce emulator) to a PCW/CP/M disk that I could use on the PCW.

Trying to run this gave the message that could be seen looking at the file, i.e. that this was a pirate copy.

I suppose it would be possible to study the code in the file and 'patch' it, or look at the code and work what specifically in the process is generating the 'error' and replicate that so that the 'error' doesn't happen, however, as I have another chess game that works fine (well, this one is a 'pukka' copy) it's not really worth it.

The image of cyrus2 seems to work, and I suppose that this image properly written to a disk would work as well.



Well, I've not dug too deep into this, but...

I had a quick look at the CYRUS.COM file which is 128 bytes, and does not appear to do very much, other than check something and print the 'Pirate' message or chain to the main prog.   Which is a Sys file, so it's 'hidden', and has a somewhat perverse name.  P3Q27RTX.COM.

So I wondered...

So I tried running the main prog straight off, i.e. no CYRUS.COM (in the Joyce emulator) and this seems to work.  Tried the same on the real PCW, and this works too.

So I guess you can just scrap the CYRUS.COM, rename the main file as CYRUS.COM, and away you go.

Is it THAT easy?



I think the loader (CYRUS.COM) is checking that free space on A: is 130k. If it is, it chains to the actual program (T5SQ11B3.COM in my copy). If not, it prints the copy protection message and returns to CP/M.


Just in case anyone's interested, I attach a (sort of) disassembly of the code in the 'loader'.

As per John's note, yes, it does a compare of the space remaining (the result comes back as 1040 x 128 byte logical sectors which is 130k).   First of all it does a Drive Reset though.

So I would assume that you will get the error if you try to use any part of the spare space on the disk?


Powered by SMFPacks Menu Editor Mod