Author Topic: pcw 8512 B drive differences  (Read 935 times)

0 Members and 1 Guest are viewing this topic.

Offline geebus

  • Amateur Geek
  • Supporter
  • CPC6128
  • *
  • Posts: 167
  • Country: scotland
    • Gee-k.net
  • Liked: 54
  • Likes Given: 45
pcw 8512 B drive differences
« on: 17:37, 05 August 20 »
Hi folks,Just wondering if anyone can tell me what the difference (apart from the drive capacity and head count) is between the a and b drive.
The reason I'm asking is that I'm trying to make the a drive in my 8256 into a b drive.
I'm using a gotek for the a drive and have cut the trace on the old a drive's pcb that tells the computer that it's a, then soldered the line to make it a b drive in on it's place instead.
Should i just leave the lines (a or b) unsoldered so that it's just "floating?" or is there something else i'm missing?
When i'm in CP/M and try access b: it gives me a BDOS function = 14it does try to access the drive though.
« Last Edit: 17:44, 05 August 20 by geebus »

Offline GeoffB17

  • 6128 Plus
  • ******
  • Posts: 753
  • Country: gb
  • PCW since '85
  • Liked: 160
  • Likes Given: 8
Re: pcw 8512 B drive differences
« Reply #1 on: 18:14, 05 August 20 »
Hello,

Which version of the system (JxxCPM3.EMS) are you using.?

At least part of the problem may be to do with the system.   The different versions may have something in the code that expects that A: is a single sided 173k drive, and B: is a double sided 730k.   It will complain if this is not so, or will have trouble accessing the disk, or both.

For a while, while my A: drive was broken, I was using my 360k B: drive as A: using single sided floppy disks to boot from.   With advice from John Elliott, I was able to 'patch' the very old 1.1 system file to be helpful, but later versions were not so obliging.   You've got the other side of the problem, i.e. the system will be seeing the B: drive as single sided when it OUGHT to be double sided and this will generate an error.

This is there for your protection, regarding getting A: and B: disks the wrong way around, but the test has been done in different ways over different versions and sometimes it's not as helpful as it might be.

Later versions of the system that use .FID mods can have a B180.FID file that may help.  I think I'll have such a file somewhere.

BDOS Function 14 is the 'Select Disk' function, so the error is telling you the disk isn't correct.   Which I assume IS because it's SS when it ought to be DS.   I don't think it's anything to do with the actual drive, it's the disk it's trying to read.

I've looked through some of my files, and found a B180.FIB.   The text in this says that B: is a 3" 180k disk.   This may help, but I thought that the .FIB files were just to to with the disk speed (?) parameters, but maybe not.

Geoff
« Last Edit: 18:31, 05 August 20 by GeoffB17 »

Offline geebus

  • Amateur Geek
  • Supporter
  • CPC6128
  • *
  • Posts: 167
  • Country: scotland
    • Gee-k.net
  • Liked: 54
  • Likes Given: 45
Re: pcw 8512 B drive differences
« Reply #2 on: 20:16, 05 August 20 »
Looks like I've got j11cpm3.
I've had a quick Google for the b180.fib and found more topics on cpcwiki with people having the exact same issue.
However, can't find the fib file anywhere yet.
I shall continue the search as it's only just began.
« Last Edit: 20:18, 05 August 20 by geebus »

Offline GeoffB17

  • 6128 Plus
  • ******
  • Posts: 753
  • Country: gb
  • PCW since '85
  • Liked: 160
  • Likes Given: 8
Re: pcw 8512 B drive differences
« Reply #3 on: 20:32, 05 August 20 »
Hello,

Sorry, but it's more complicated than that!

There are two J11cpm3 variants, one is a VERY old version, actually system 1.1 (as shown on the screen at startup) this would be an .EMS file, then there's system version 1.11, this would be an .EMT file.

Actually, neither of these would support .FIB/.FID files.   For this, you need system 1.07H (not 1.7) or something from 1.15 and after.   Then there's the problem that 1.15 (and after ??) seem to have a problem with Gotek, so you'd be better to try the 1.07H which seems to avoid the Gotek problem, but still supports the .FIB/.FID  files.

I can just pack the 1.07H and the B180.FIB into a .zip for you and you can give them a try.  I cannot promise that this will sort things, but if it does something it may suggest what else to try.  Hopefully another message to follow this?

Geoff

Offline GeoffB17

  • 6128 Plus
  • ******
  • Posts: 753
  • Country: gb
  • PCW since '85
  • Liked: 160
  • Likes Given: 8
Re: pcw 8512 B drive differences
« Reply #4 on: 21:05, 05 August 20 »
Files attached.

The file J17cpm3.ems is actually j17hcpm3 - that's what it should announce on loading.  If it doesn't, I've got something mixed up.

The file B180.FIB shows the right message it it, but I'm not too clear what difference the .FIB or .FID makes, so if .FIB does not work, try rename to .FID and see if that's any better.

Geoff

Offline geebus

  • Amateur Geek
  • Supporter
  • CPC6128
  • *
  • Posts: 167
  • Country: scotland
    • Gee-k.net
  • Liked: 54
  • Likes Given: 45
Re: pcw 8512 B drive differences
« Reply #5 on: 21:31, 05 August 20 »
Thanks Geoff,looks like there's not enough space on the disk for both of those files after removing the J11cpm3.
I'm continuing my google.Thanks for attaching those!

Offline GeoffB17

  • 6128 Plus
  • ******
  • Posts: 753
  • Country: gb
  • PCW since '85
  • Liked: 160
  • Likes Given: 8
Re: pcw 8512 B drive differences
« Reply #6 on: 22:38, 05 August 20 »
Oh?

Disk must have been near full then?   The .EMS file is only slightly bigger that the previous one, and the .FIB is only 400 bytes.  Or so.  Surely there was something you could remove, even if temporarily, to see if this solves the problem?

Geoff

Offline geebus

  • Amateur Geek
  • Supporter
  • CPC6128
  • *
  • Posts: 167
  • Country: scotland
    • Gee-k.net
  • Liked: 54
  • Likes Given: 45
Re: pcw 8512 B drive differences
« Reply #7 on: 11:11, 06 August 20 »
Yeah I was thinking of doing just that, however I'm not entirely sure what is best to remove to test it out. I could just start removing parts and testing it seeing as it's done via virtual disks and a gotek.

Offline geebus

  • Amateur Geek
  • Supporter
  • CPC6128
  • *
  • Posts: 167
  • Country: scotland
    • Gee-k.net
  • Liked: 54
  • Likes Given: 45
Re: pcw 8512 B drive differences
« Reply #8 on: 14:24, 06 August 20 »
Managed to get the patch to work using J15CPM3.EMS
It now shows the text "180k 3 inch drive" but still can't access it haha!
This is proving to be a lot more hassle than I thought it would be.

Offline PCWPIP

  • CPC464
  • **
  • Posts: 33
  • Country: us
  • Liked: 9
  • Likes Given: 0
Re: pcw 8512 B drive differences
« Reply #9 on: 20:57, 01 November 20 »

I also want to add the 180K 3" A drive the GOTEK replaced as drive B:.  Partially for storage, partially for nostalgia, but also so I can copy from physical disk to disk image on the GOTEK.

I know that if I just connect up the drive to the second set of power and ribbon cables it won't just happily work.  I believe that I need to make some additional modifications to make an A: drive work as B:, this very thread tells me that.  Failure to make changes will likely result in the system trying to access both drives at once (no drive mod) or getting a BDOS error when trying to access the drive (no B180.FIB).

However, when researching I have heard multiple things:

1) Cut a connection on the cable.  Not sure this is required.

2) Cut and Connect traces on the drive PCB to identify the drive as B: as the OP did.

3) Add a file to a boot disk that supports extensions (add B180.FIB to 1.07H or 2.09 boot disks).  I have B180.FIB (thanks Geoff) and a CP/M 2.09 boot disk so this should be OK.

I'm very wary of making hardware changes, so it'd be nice if it was just option 3) were required, but I expect not.

Surely someone else has done this before?  Can someone show us (preferably with pictures) what we need to do please?

I searched eBay and there are currently no B: drives available either, otherwise I'd try that.

I'd like to have more of a clue before I break out the soldering iron and f**k up a perfectly good drive. ;D

HELP!


Offline PCWPIP

  • CPC464
  • **
  • Posts: 33
  • Country: us
  • Liked: 9
  • Likes Given: 0
Re: pcw 8512 B drive differences
« Reply #10 on: 21:06, 01 November 20 »
FYI:

I am assuming these are the pins on a real A: drive that need altering?

Posted in another thread by the OP:

"Sorry for bringing an old topic back to the top of the pile. But hoping it stops someone trying to work out the same issue I was having.
I ended up on this topic as there was a lot of back and forth about trying to get a gotek to work on this machine.
I was searching high and low on why i couldn't get my gotek to work in my pcw8256.
It was going through the motions of selecting a file and then sitting at sector 1 (or whatever it is showing on the led display).
The green light wasn't showing either.

Turned out I had a header missing. needed one on the MO pins.
So if anyone else is seeing this in the future. For drive A jumpers S0 and M0. Drive B i'm assuming it'll be S1 and MO.
Really hope this stops some unnecessary hair pulling out for someone. "



Offline JohnElliott

  • CPC664
  • ***
  • Posts: 97
  • Country: gb
  • Liked: 36
  • Likes Given: 0
Re: pcw 8512 B drive differences
« Reply #11 on: 01:41, 03 November 20 »
B180.FIB won't work with CP/M 1.07H -- it needs CP/M 1.14, 1.15, 2.14 or 2.15. Unfortunately, if you want to use these versions with a Gotek device, you need to modify it to emulate the drive motor, thus.

Offline PCWPIP

  • CPC464
  • **
  • Posts: 33
  • Country: us
  • Liked: 9
  • Likes Given: 0
Re: pcw 8512 B drive differences
« Reply #12 on: 03:13, 04 November 20 »
John, if I have 2.09 with B180.FIB, what else do I need to do to get the A: drive working as B: on an 8256 with a working gotek?

Offline JohnElliott

  • CPC664
  • ***
  • Posts: 97
  • Country: gb
  • Liked: 36
  • Likes Given: 0
Re: pcw 8512 B drive differences
« Reply #13 on: 01:41, 05 November 20 »
I told you: CP/M 1.14 or 1.15 (2.14 or 2.15 will work if you don't need the dot-matrix printer to work). You'll need the Gotek modified to support motor emulation, and you'll need to switch the 180k drive from 0 to 1, either by changing the relevant link on the drive itself or by swapping the select lines in the cable.

Offline PCWPIP

  • CPC464
  • **
  • Posts: 33
  • Country: us
  • Liked: 9
  • Likes Given: 0
Re: pcw 8512 B drive differences
« Reply #14 on: 21:09, 05 November 20 »
Sorry to labor the point but if I try to solder anything it could catch fire  :D


Do you think I could use the Openfloppy version of Gotek instead?


https://www.simulant.uk/shop/retro-computers-games-consoles/Gotek-Floppy-Disk-Drive-Emulators/Floppy-Disk-Drive-USB-Emulator-OpenFlops-FlashFloppy-%20Gotek-upgrade


Looking at their implementation guide for PCW they state:

"Amstrad PCWPCW uses a 26-pin header with integrated power as described here (CPCWiki), requiring an adapter to connect to the Gotek 34-pin header plus power. Please note that this is NOT the same as the CPC 26-pin header, and if you use a CPC-compatible adapter or cable you may damage your Gotek or your PCW!Fixing Boot-Time HangsLater versions of LocoScript and CP/M require Drive A to correctly respond to the Motor signal (Gotek pin 16), by deasserting Ready (Gotek pin 34) when the motor is off. Unfortunately the Gotek usually ignores Motor, and the PCW will hang during boot waiting for the drive to respond correctly. This page (in Italian, so use Google Translate) explains how to modify the Gotek to fix this problem. Section 8.3 of this document gives more technical information on the floppy-drive probe logic which causes this issue.

Alternatively, an option for correct motor emulation is provided in FF.CFG: motor-delay = 200. Note that a standard Gotek needs a circuit modification to connect the motor signal. This is an alternative to the extra external circuitry described in the previous paragraph."

The page in Italian they reference is the very same one you kindly shared.

So I'm thinking that with this gotek (correcting the motor emulation), setting the A: drive to 1 by changing the link and using 1.15 with B180.FIB it should work.


What do you think?

I have J15CPM3.EMS but have been having difficulty getting the resulting boot disk to work.  I'll try to fudge this again unless I come across a pukka .dsk image.

Thanks for this.  I'm sure this will help the OP too.


Philip.
« Last Edit: 21:11, 05 November 20 by PCWPIP »

Offline GeoffB17

  • 6128 Plus
  • ******
  • Posts: 753
  • Country: gb
  • PCW since '85
  • Liked: 160
  • Likes Given: 8
Re: pcw 8512 B drive differences
« Reply #15 on: 22:13, 05 November 20 »
Any idea why your 1.15 boot isn't working?   And do you mean the image (or do I understand that you've not got the gotek working fully), or an actual disk that you've made from the image.

I've got an actual disk that I used to boot my PCW 8256 (+++) into 1.15, but I tend to use 1.07H now.   Worked fine, incl with the uIDE add-on.   I could make an image of that, and remove the uIDE bits.   If you're talking about the image (.dsk file) then if you send me that I could try it in Joyce, and/or repl the .EMS file in case it's got damaged?

Geoff

Offline JohnElliott

  • CPC664
  • ***
  • Posts: 97
  • Country: gb
  • Liked: 36
  • Likes Given: 0
Re: pcw 8512 B drive differences
« Reply #16 on: 22:35, 05 November 20 »
Note that the implementation guide isn't giving the whole story when it says

PCW uses a 26-pin header with integrated power as described here (CPCWiki), requiring an adapter to connect to the Gotek 34-pin header plus power. Please note that this is NOT the same as the CPC 26-pin header, and if you use a CPC-compatible adapter or cable you may damage your Gotek or your PCW!

The 3.5" PCWs (9256, 9512+, 10) use a 26-pin header with integrated power. The older 3" PCWs (8256, 8512, 9512) use the same 26-pin header as the CPC, with a separate power connector.

Offline PCWPIP

  • CPC464
  • **
  • Posts: 33
  • Country: us
  • Liked: 9
  • Likes Given: 0
Re: pcw 8512 B drive differences
« Reply #17 on: 23:21, 05 November 20 »
Geoff, my Gotek is working fine.  I'm just trying to get my ducks in a row ready to install my old 3" A: drive working as B:


I took a 1.07 CP/M .dsk image and used CPCDiskXP to remove the original .EMS file and replace it with J15CPM3.EMS.   When I try to boot from this .dsk image on the gotek it gets to about where I should get an A> prompt but it hangs there.  If I hit the gotek button to swap disk I get a read error, if I then switch back to the disk image and hit R the boot finishes and I get the prompt.


If I do a SHOW then it says there are 0 bytes free.  I suspect that the EMS file is a bit larger than the original and there is something amiss.   I am going to try and re-build an image with more free space and see what happens.


I attached the image that didn't work.  If you you could post your image i'll give that a try too.


Thanks.

Offline PCWPIP

  • CPC464
  • **
  • Posts: 33
  • Country: us
  • Liked: 9
  • Likes Given: 0
Re: pcw 8512 B drive differences
« Reply #18 on: 23:25, 05 November 20 »
Thank you John, a good distinction to note.  My current gotek ribbon & power adapters should take care of that.


Do you think that gotek with the configuration change will work?  I suppose I could email them to confirm?

Offline PCWPIP

  • CPC464
  • **
  • Posts: 33
  • Country: us
  • Liked: 9
  • Likes Given: 0
Re: pcw 8512 B drive differences
« Reply #19 on: 00:05, 06 November 20 »
I just tried rebuilding a 1.15 boot disc.  This time I used a copy of my 2.09 Start of Day disk which had around 9K free on disk 1.


It did much the same thing:


I booted and got a little over half a screen of horizontal lines, to the point the PCW would usually boot to a prompt.


I got a green screen, then a black screen, and it stays blank.


If I switch the gotek image I get the "Drive not ready -Retry, Ignore or Cancel?" message.


I switch the gotek back to the same image and hit R.


CP/M then starts to boot as usual with:


"CP/M Plus  Amstrad plc
v1.15. 61K TPA, 1 disc drive, 368K drive M:
Clock v2.00 installed
180K 3 inch Drive B:


A>setdef.... etc
etc"


And the boot continues as normal.  CLOCK.FID put a clock on the screen.  I put B180.FIB on the image and that seems to have worked.


However, that green/black screen hangup is weird.
« Last Edit: 00:15, 06 November 20 by PCWPIP »

Offline PCWPIP

  • CPC464
  • **
  • Posts: 33
  • Country: us
  • Liked: 9
  • Likes Given: 0
Re: pcw 8512 B drive differences
« Reply #20 on: 00:08, 06 November 20 »
P.S:  I wish I could get hold of a uIDE but I don't think they're being made any more.

Offline GeoffB17

  • 6128 Plus
  • ******
  • Posts: 753
  • Country: gb
  • PCW since '85
  • Liked: 160
  • Likes Given: 8
Re: pcw 8512 B drive differences
« Reply #21 on: 00:47, 06 November 20 »
Regarding the uIDE, you need to communicate with JonB about that.  Depending on which type you want, or are prepared to take, you might be lucky.  Really is a GREAT thing to have if you're wanting to do anything significant with the system.

From your description of the problem, it sounds like the point at which the system would be looking for/loading any FID/FIB files.  There would normally be a bit of a pause there.  Does it still do it if the CLOCK thing is not there?  Does it still do it if you use system 1.07H?

Geoff

Offline JohnElliott

  • CPC664
  • ***
  • Posts: 97
  • Country: gb
  • Liked: 36
  • Likes Given: 0
Re: pcw 8512 B drive differences
« Reply #22 on: 00:57, 06 November 20 »
I took a 1.07 CP/M .dsk image and used CPCDiskXP to remove the original .EMS file and replace it with J15CPM3.EMS.   When I try to boot from this .dsk image on the gotek it gets to about where I should get an A> prompt but it hangs there.  If I hit the gotek button to swap disk I get a read error, if I then switch back to the disk image and hit R the boot finishes and I get the prompt.
This is why the Gotek needs modifying. CP/M has turned off the drive motor and is waiting for the drive to report 'not ready'. An unmodified Gotek doesn't emulate this behaviour so CP/M just waits and waits and waits. Ejecting the disc image makes the drive report 'not ready' and allows CP/M to continue.

Offline PCWPIP

  • CPC464
  • **
  • Posts: 33
  • Country: us
  • Liked: 9
  • Likes Given: 0
Re: pcw 8512 B drive differences
« Reply #23 on: 01:38, 06 November 20 »
Oh, and the earlier versions of CP/M, that don't look for FID/FIB files don't have this issue?


That would explain it.

Offline GeoffB17

  • 6128 Plus
  • ******
  • Posts: 753
  • Country: gb
  • PCW since '85
  • Liked: 160
  • Likes Given: 8
Re: pcw 8512 B drive differences
« Reply #24 on: 01:39, 06 November 20 »
I take it you're using 1.07H and not 1.07, as 1.07 does not support the FIDs etc.

I tried the 1.15 image with Joyce and it works fine, so nothing seems to be 'damaged'.  I assume that the problem is more to do with what John says, but I thought that system 1.07H got around this problem, while 1.15 WOULD have this problem.

Looking at the 1.15 image file, I note that it's an 'Extended' image.   I accept that this seems to work, but is there any reason why you're using the (slightly more complex) Extended image?   I understand that this is to copy with possible oddities with the format connected with copy protection schemes, surely not relevant here.

Also, I see that the sector interleave on this disk is 9,5,1,6,2,etc which again is an extra (unnecessary ?) complexity.   Is this for some reason, or is this just what happened to be on the original disk you've worked from?  I would thing that the gotek would be perfectly OK with the 1,2,3,4 etc interleave, and this would make examining the image file easier?

Geoff