Author Topic: PCW 8512 No Display, disk drive noise  (Read 670 times)

0 Members and 1 Guest are viewing this topic.

Offline gelthor

  • CPC464
  • **
  • Posts: 4
  • Country: gb
  • Liked: 0
  • Likes Given: 0
PCW 8512 No Display, disk drive noise
« on: 22:46, 15 May 21 »
Hi all,


This is my first post, apologies if anyone has asked this question before.


I found a PCW 8512 in the box with the printer, keyboard and everything at a car boot sale recently for £40, which I thought was a pretty good deal. Unfortunately the machine doesn't work. When powered on, the CRT does not light up at all, both disk drive LED's are on constantly and the disk drive motors seem to run continuously. The keboard Shift Lock light does go on and off as normal when the button is pressed. The upper disk drive LED also seems to "pulse" on a regular basis. I took a video, see below:


https://photos.app.goo.gl/yHDyLXRfrZRLxLs39


Any ideas? Seems fairly profoundly dead but I guess could be a capacitors/power supply problem? I took it apart, cleaned the vast amount of dust from the inside, pressed down on the socketed chips on the CPU board (CPU itself and RAM) and checked that the internal fuse wasn't blown. It seemed fine although the filament inside is at quite an angle. (but did not seem broken)


Thanks in advance,
gelthor




Offline GeoffB17

  • 6128 Plus
  • ******
  • Posts: 795
  • Country: gb
  • PCW since '85, more CP/M than Loco
  • Liked: 169
  • Likes Given: 9
Re: PCW 8512 No Display, disk drive noise
« Reply #1 on: 17:03, 16 May 21 »
Welcome,

How familiar are you with the PCW?

When you turn the PCW on, the sreen should light up, but nothing else.   If the brightness control is wrongly set, then you may well see no difference, i.e. no visible lighting up.  Nothing happend until a disk is inserted.

There could well be a problem with the power supply, this is one of the regular problems that gets mentioned here.

The disk drives running is something different.   If they are running this suggests that the power may be OK.   Double check that the disk drives are connected properly, and the cables are connected the right way around.

Do you have system disks?

Are there any signs inside that anyone has been messing with it?  Strange wires, or lose wires?  A screw floating about?

There are others here that know far more than me about the electronics.

Geoff

Offline gelthor

  • CPC464
  • **
  • Posts: 4
  • Country: gb
  • Liked: 0
  • Likes Given: 0
Re: PCW 8512 No Display, disk drive noise
« Reply #2 on: 23:14, 19 May 21 »
Hi Geoff,


Sorry for the late reply, I thought I'd get an e-mail notification when someone replied to my post so didn't come back to check! I'm almost totally unfamiliar with the machine to be honest. I have lots of retro computers and consoles but this is my first Amstrad of any sort. I did open the PCW up at the weekend, good rid of most of the massive amount of dust that was in there, took out the CPU board and checked it as much as I could. There don't seem to be any loose connectons or anything rattling around. There weren't actually very many electrolitic capacitors in there but what there was looked good, no bulging or leaking that I could see. Sadly the cleaning and mild pressing down on the socketed chips didn't make any difference, it still just runs both disc drive motors constantly and there's nothing on the CRT, regardless of brightness settings. I don't have any discs (spelling it the old fashioned way because why not) for it at the moment but I've ordered a set of CPM/System disks for it from ebay. Will see if it behaves any differently with a disk but the lack of display makes me think the CRT might just not be working at all. Any advice from the guys on here is appreciated!


Cheers,
Andrew.

Offline gelthor

  • CPC464
  • **
  • Posts: 4
  • Country: gb
  • Liked: 0
  • Likes Given: 0
Re: PCW 8512 No Display, disk drive noise
« Reply #3 on: 23:31, 19 May 21 »
A small update....if I leave the machine on for 5 minutes or so the drive motors stop running and the computer gives me 3 beeps! Seems to be some sort of error code suggesting it has stopped searching for a disk. Still absolutely nothing on the display though. I guess could be a power supply problem, as in it's able to supply the right voltage/voltages to the CPU board but not to the CRT?

Offline GeoffB17

  • 6128 Plus
  • ******
  • Posts: 795
  • Country: gb
  • PCW since '85, more CP/M than Loco
  • Liked: 169
  • Likes Given: 9
Re: PCW 8512 No Display, disk drive noise
« Reply #4 on: 23:38, 19 May 21 »
Hello Andrew,

Thanks for the update.

Just to confirm, there is absolute minimal boot process within the hardware of the PCW.   Nothing happens until the system loads software from the disk.   However, if things are OK the screen colour should change from a dull (dark) colour to a brighter lit (but still blank) screen.   If a disk if being read, you will get lines (bars) appearing down the screen, and then the first text will appear.

What you describe COULD mean that there's a problem with the video, and/or the power supply, but the activity with the disks suggests that there is SOME power active.

Another problem, both disk drives involve a motor, and a rubber band connecting the motor to the disk spinning platform.   This rubber band is prone to corrode, and may crumble or turn to mush/goo, so the bands will need replacing.   Has this been done.   The repl bands are easy to find on the web.  If the drives are trying to work, but nor working properly, you may hear some noise from the drive as they spin with no effect.  I don't think they do this indefinitely mind you.

You can find and download the service manual for the PCW.  This could help you narrow down where the problem is.

My PCW, bought in 1985, is still working, although the A: drive needed some attention a few years ago.  I can swap between 5.25" or 3.5" B: drives.

Aha, just seen your extra note.   The three beeps suggests that things may be OK, but the system has not found a valid boot disk.   I'd hold off doing anything too drastic until you've checked the floppy drives (rubber bands) and got a boot disk.

Geoff

Offline gelthor

  • CPC464
  • **
  • Posts: 4
  • Country: gb
  • Liked: 0
  • Likes Given: 0
Re: PCW 8512 No Display, disk drive noise
« Reply #5 on: 21:07, 29 May 21 »
Hi Geoff/all,


Well, I received my boot disks, very nice "refurbished" and relabelled ones from a seller on ebay. When I power on the machine with a disk inserted it does attempt to read it, the disk drive LED flashes/turns on and off several times as if it's trying to read the disk. But it obviously fails as after a while I get the same 3 error beeps as before. The disk drive belts probably need replacing but the main thing is that the display is completely dead, does not light up at all. I even tried turning the lights off in the room while it was dark and adjusting the brightness control all the way from one end to the other several times and there is not a glimmer from the screen under any circumstances. Everything does look good inside but I guess this is probably a power supply problem? As in the CRT board is just not getting the voltages that it needs?


Cheers,


Andrew.

Online robcfg

  • Supporter
  • 6128 Plus
  • *
  • Posts: 2.412
  • Country: se
  • 8-Bit Technomancer
    • index.php?action=treasury
  • Liked: 1093
  • Likes Given: 2673
Re: PCW 8512 No Display, disk drive noise
« Reply #6 on: 21:37, 29 May 21 »
You can always check the service manuals here: http://habisoft.com/pcwwiki/doku.php?id=en:manuales_servicio


Do you have an oscilloscope?
« Last Edit: 01:42, 30 May 21 by robcfg »

Offline GeoffB17

  • 6128 Plus
  • ******
  • Posts: 795
  • Country: gb
  • PCW since '85, more CP/M than Loco
  • Liked: 169
  • Likes Given: 9
Re: PCW 8512 No Display, disk drive noise
« Reply #7 on: 01:09, 30 May 21 »
Hello,

On the basis of the detail that you now give, yes, it does sound as if the monitor is not working.   This could be because of a power problem, alternatively it could be something as simple as a connecting wire to the monitor no longer connecting.

You are still not certain that the disk drives are working.   Replacing the drive band should be the first step regardless, unless it is clear that the band there is new/OK.

I don't like the sound of your reference to the boot disk(s) being 'refurbished/relabelled'.  There should not be any need to do this.   This opens the door to silly problems, such as a disk has a boot sector that requires an .EMT system file, but someone has loaded it with files that include an .EMS system file.   Or vice versa.

Is there anyone within reach of you that could look at the disks and check them?   Ideally with a working PCW, but verious CPC setups could still be a help.   You don't say where you are in the UK.

For a copy of the service manual, this may be better: http://www.habisoft.com/pcwwiki/doku.php?id=en:manuales_servicio

Geoff
« Last Edit: 01:36, 30 May 21 by GeoffB17 »

Online robcfg

  • Supporter
  • 6128 Plus
  • *
  • Posts: 2.412
  • Country: se
  • 8-Bit Technomancer
    • index.php?action=treasury
  • Liked: 1093
  • Likes Given: 2673
Re: PCW 8512 No Display, disk drive noise
« Reply #8 on: 01:42, 30 May 21 »
For a copy of the service manual, this may be better: http://www.habisoft.com/pcwwiki/doku.php?id=en:manuales_servicio


Okeeeeeeey...


I used the [ url ] code add that url, but when I save the post, it just changes it to something different.


This is a case for @Gryzor  8)

Offline GeoffB17

  • 6128 Plus
  • ******
  • Posts: 795
  • Country: gb
  • PCW since '85, more CP/M than Loco
  • Liked: 169
  • Likes Given: 9
Re: PCW 8512 No Display, disk drive noise
« Reply #9 on: 02:02, 30 May 21 »
Oh?

Hmm???

Yes, I'd not noticed that.

I checked the link given originally, and it went somewhere else.  So I found a better link and used that, but I didn't notice it seemed to be the same link as previously given.   But when I tried the posted link in my post, it seemed then to go to the correct place.

As you say, something needs looking at.

Just to check, I've now tried the original link given, and this now goes to the correct place.   Has something JUST been fixed?

Geoff
« Last Edit: 02:04, 30 May 21 by GeoffB17 »

Online robcfg

  • Supporter
  • 6128 Plus
  • *
  • Posts: 2.412
  • Country: se
  • 8-Bit Technomancer
    • index.php?action=treasury
  • Liked: 1093
  • Likes Given: 2673
Re: PCW 8512 No Display, disk drive noise
« Reply #10 on: 02:06, 30 May 21 »
Yes, I just put the link instead of using the [ url ] tag...  ;)

Online Gryzor

  • Administrator
  • 6128 Plus
  • *****
  • Posts: 16.892
  • Country: gr
  • CPC-Wiki maintainer
    • CPCWiki
  • Liked: 4014
  • Likes Given: 7234

Offline tjohnson

  • Supporter
  • 6128 Plus
  • *
  • Posts: 1.006
  • Country: gb
    • index.php?action=treasury
  • Liked: 319
  • Likes Given: 289
Re: PCW 8512 No Display, disk drive noise
« Reply #12 on: 16:23, 31 May 21 »
Monitor sounds like it's dead it should be green until it starts the boot process and then youll get the black and green lines but I can't help with diagnosing why it's dead. If you get 3 beeps after using known good disks then your drive needs attention, probably just new belt and a clean.  I love those refurbished disk sets on ebay just copies of start of day disks onto blank disks with new fake labels made up I would guess.  Unlikely the disks they are on were ever really an original set of disks.