PCW newbie!

Started by TynH, 18:42, 15 February 19

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.


PS: gave up on the Spitfire. A blast to drive with the top down but the quality was simply appalling. Spares in particular. Upgraded to a Jensen Interceptor instead, much nicer car and far more reliable as well. Bit of a ,,gas guzzler" though!


Maybe it is the floppy? This is what side A sounds like:


Almost as if the disc wasn't even recognised.
Booting from side B sounds (and looks) more promising at first:



Well, for side A, I saw no sign of any disk activity light.  So the drive was not even trying.   Did hear the beeps at the end, I think there were 5?, which may be significant.

For Side B, I did see the disk activity light, so the drive tried.   But didn't find anything.   I think there were 3 beeps ONLY for B, which I think means that it's not reading anything, or maybe it found the boot sector OK but no system file?

After you'd tried B:, did you try A: again?   Worth keep trying, in case the stepper motor is dirty and need s few tried to free up the worm thread?

Anyway, in this situation, the number of beeps is significant, so please state the number.

So far, no clear evidence that the disk is faulty, or good.   Drive seems to be trying, but trying what?   You need a known, good, disk!  Maybe one of the others on the way may help.



Sorry to butt on but it's our possible to not from disk b on an 8512?


Quote from: tjohnson on 21:53, 26 February 19
Sorry to butt on but it's our possible to not from disk b on an 8512?

Only if you reverse the polarity of the neutron flow. Sorry what did you say?


Quote from: TynH on 23:03, 26 February 19

Only if you reverse the polarity of the neutron flow. Sorry what did you say?

Bloody phone swipe to type. 

Is it possible to boot a 8512 from the B drive?


AFAIK they always boot from drive A. Of course I only have a single drive model 8256 myself!
I seriously doubt you could manipulate the boot sequence though, it's pretty much hard coded.


Boots from drive A: only.

Oh sorry. There is only one drive and you are referring to the sides.  :picard:

Good description of the boot sequence: https://www.chiark.greenend.org.uk/~jacobn/cpm/pcwboot.html

and this: https://www.seasip.info/Unix/Joyce/hardware.pdf

Three beeps = bad floppy. Did you clean the heads when you replaced the drive belt?

I can see that it attempts boot with side B so you're OK as far as the motherboard, screen and (from the looks of it) drive are concerned. Just need a known good boot disk.


Thanks for mentioning it, I did a quick google for ,,Amstrad PCW" ,,error codes" and eventually found this:

Intriguing stuff, unfortunately I still don't have any discs known to be good.
I did clean the head with isopropanol and a Q-tip but tbh it didn't look like it was necessary.


Gave it another try (now that I read about hitting the space bar) and the drive now reliably attempts reading both sides of the disc. Ultimately giving up and emitting four beeps every time but on two attempts I even got a horizontal ,,load line" (as in: one).

Well, who knows? Maybe those Schneider discs will help shed some light on this.


Aha, progress.

My guess, based on long experience of such things and what you describe, is that the stepper motor is not stepping.   The worm thread has dust/muck in the thread.  Cleaning this is problematic, you can easily make things worse.   

What I suggest.   Keep trying.   Each time you try, if the process gets just a little bit further (i.e. more of the horizontal lines appear) then this IS the problem, and just keep on trying.   Also, as the machine warms up, it may get a little better again.

If it shows no sign of improvement, then maybe the stepper motor is 'broken'.   A little while back, mine ceased to work at all, and a certain miracle worker here fixed it!  The magic he used on mine may work on yours as well?



Good point, Geoff.

Only, I'm not sure I'd suggest getting the stepper motor to clear the blockage. It might get overloaded.

In general, you can move the head, either by rotating the worm drive shaft (recommended) or pushing the head's carriage (carefully). Then you can see if anything is going on - because it has to seek to Track 0 before attempting to read the boot sector(s). So move the thing away from Track 0 and see if it moves back when it is powered up.

This will also help clear any obstacles (gunk, or whatever) from the head movement mechanism. Actually, while you're in there, clean the worm drive with light oil. It's good practice. But beware the Write pin falling out.. http://www.cpcwiki.eu/index.php/Writepin

On the other hand... in my limited experience I have never had a problem like this (I have five different 3" drive units) and I think it is more likely to be the disk itself. Let's just hope his heads aren't misaligned...


One of my drives was Jammed, also had an issue with one drive spinning too slow and wouldn't reliably read a disk


Floppies finally arrived and even though I wasn't really expecting anything to happen...

Holy crap it's s working!
Well actually it's not... For some reason I couldn't navigate Locoscript properly and got stuck in a popup menu.
The reason why became apparent after rebooting into CP/M:

Pressing ,,STOP" terminated the keyboard outputting the character ,,k" but unfortunately this turned out to be the least of my problems:

Most of the keys don't work properly, ,,D" is ,,WD", ,,F" AND(!) ,,T" equal ,,TF", ,,J" is ,,ZJ" and others like the letter iI don't work at all.


dismantling the keyboard and cleaning up the membrane will probably fix that, easy to do.  I've cleaned a couple of keyboards by using the bath, put it in the airing cupboard to dry out, works a treat.


I'll try that, thanks.


Quote from: TynH on 15:55, 02 March 19
I'll try that, thanks.

A paintbrush to clean between the keys is useful , watch you don't lose any of the little springs  they shouldn't come off if you're are gentle


@TynH : Well done, you're nearly there. Geoff will be along soon to recommend your first PCW upgrade...  ;)


Took everything apart, luckily the plastic is a lot sturdier than the one used on the NC line of machines!
Now it wasn't the filthiest keyboard I've ever seen but giving it a more thorough clean certainly seemed like a good idea:

Bit of compressed air, isopropanol and distilled water to give everything a good clean:

Reassembled the keyboard and holding my breath while switching back on:

Flippin eck!

That really did the trick, ALL keys seem to be working perfectly!Thanks for all the fantastic help so far!



Just to clarify?

You were trying to boot from a disk, and it wasn't working.

You then got some more disks.

Is the machine now booting from the earlier disk, or is it booting from one of the new batch?

If one of the new ones, have you tried the first disk again?   Will the machine now at least read the disk?   Will it even boot from it now?



Ok so we're talking about these discs:

The first one in the upper left corner came from Locoscript.co.uk with Loco 2.0 (A) and CP/M 1.15 (B). This turned out to be a dud, never managed to boot from.
In the middle we have an original system disk from Schneider Computers with Loco 1 (A) and CP/M 1.14 (B). This seems to work just fine, yay!
The last one however is where it gets interesting again. Bought in a set of several unopened Maxell CF2s. Ok sealed or NOS doesn't necessarily mean they're fine but probably as good as it gets.
Anyway, ran a Diskit of the Schneider disk, which went fine at first. It soon became apparent however that the copy was unreliable. Loco won't load and even CP/M will give disk errors every now and then. Re-inserting the disk seems to help.

I still can't read the Locoscript.co.uk floppy. Side A just gives a disk error whereas side B also gives a disk error but lists the content after choosing the ,,Ignore" option. Haven't tried running any of it though.

The fact that the copy I made doesn't work seems to point towards drive related problems. Since the Schneider disk is slightly thicker than both the one provided by Locoscript.co.uk and my blank media Maxell, I'v been thinking about that little felt pad.
There IS a felt pad in there, it's not missing but without anything to go by I had now way of knowing whether it's still within spec.


P.S. Not sure how to proceed. In the end I'll want an easy way to transfer data to/from the Amstrad, which is why there's a Gotek emulator coming my way. So why fix the floppy drive?
And then of course there's the SECOND PCW, I bought off ebay... :doh:

Condition unknown, advertised as ,,not working" but it *is* a higher spec 8512 with more RAM and two floppy drives. Now a dual floppy machine would make a perfect candidate for a Gotek/3" hybrid!
Probably best to wait.


Well, what you're now describing sounds like an alignment problem.   The head is not hitting the data track perfectly.   As each sector is read, the checksum is checked, and some of them are failing.   How many?   The 'data error' and the ignore can sometimes be useful, but NOT if you're trying to read an executable prog.  Reading text, or anything that can be viewed and corrected, could be OK.

This may be, as said, due to alignment, and this can be adjusted but it's fiddly.   Some people can do it with a know good disk, others need some test equipment.   Other causes bad heads (incl head not making proper contact, which might be due to dud pressure pads.  Then back to the stepper motor not lineing the head up with the track.

Anyway, it seems more likely it IS the drive, and not the disks.

Do you have anyone handy with an OK drive?   This will prove things one way or another.   Send one to me, if it reads OK I'll make images ready for your Gotek device.



Thanks for the kind offer but that won't be necessary. The Schneider system disks are available for download online and I probably won't be using Loco 2.0. I have CP/M 1.15 as dsk image as well but maybe I'll explore z3plus instead. So there's really nothing on those three floppies that needs saving.
Also less of an argument to invest in having the drive serviced.


If the head is out of alignment and you format a good disk, it should work reliably on the same drive it was formatted on.

I would then expect the newly formatted disk to be unreliable in other drives.

What I'd do if I were you is to create a new boot disk and try to copy the CPM v1.5 system file to it, so you can boot into CP/M v1.5.

You will probably find that once you have your bulk setup done, transferring files to / from the PCW using Gotek images is cumbersome (this was my experience). My preferred method is Kermit and a serial interface (but then, I was developing the uIDE drivers so needed to be able to constantly transfer FIDs in development for testing).

If I didn't have a uIDE, I would use a Gotek or HxC but as a boot drive - definitely not as a file transfer medium.

Powered by SMFPacks Menu Editor Mod