PCW newbie!

Started by TynH, 18:42, 15 February 19

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.


Regarding the images.

No problems regarding the real PCW, as the uIDE drives mean I'm OK for space.

I also use the Joyce emulator on my PC, and this needs B: type images, which can be created easily within Joyce.   The system includes a .FID for accessing PC drives/folders as virtual HDs (just like the uIDE drives on the real thing).   I assume that B: images could be emailed to you easily if you need any?   How does the Gotek (technically an A:) cope with B: type images, maybe it gets confused as CP/M says it's drive A: (device 0) but the format info on the disk (sector 1) says it's a B: format??

But once the system is booted, you might flick an A/B switch and tell the machine that the Gotek is B:, select B: within CP/M, and happily use B: images with 4 times the capacity??

Maybe not much point, if Gotek A: gives you xxx virtual A: disks.   Even less point if (when) you get the uIDE drives active!!   13 @ 8Mb - gee - Thanks Jon!!



I suspect the Gotek may be appearing to the PCW as a 3.5" 720k drive. In which case, it might be best to try booting from a 720k disc image with an A35.FIB file on it.


To try this, you'll need to use one of system files J14 or J15 (v1.14 or 1.15, or they may show as 2.14 or 2.15).

And rename A35.XXX to A35.FIB.   Not sure of how this affects the Gotek, but it may be more a matter of setting something so that CP/M recognises the drive correctly.   Prob best done with the original disk image you received, which may have boot code that will work with a double-sided disk.   The boot code on a normal disk (A:) is coded to read a SS disk.  Only.



Wow, this is getting complicated.

I am surprised at the FID loading error and can tell you that if a FID is malformed, it is ignored. Found this out yesterday when checking the GET-XDRV.BAS program that is listed on the uIDE wiki page - it doesn't work with the later FID, so I've updated it. Anyway, when I say "ignored" I mean "with no error". So it must be something at a lower level and I think this point about the image size / type is bang on the money.

I know there are other people using GoTeks on a PCW, I wonder where they've gone? I do have a GoTek here but I haven't started using it yet (it's destined for a Superbrain II).

What happens if you put an image of a single sided disk on the Gotek? And does it have any sort of configuration that allows you to set the drive type, or is it getting that from the image file?


Well renaming the A35.XXX file didn't get me far. Renaming doesn't work (Disc I/O). Copying to M and renaming does. Copying it back does however not (Error: make file nonrecoverable - a35.$$$)
Trying to remove restrictions doesn't seen to work either:
set a35.*[rw] ,,Invalid file"

I also copied it to a regular disc image, also replacing the working j14 file with J15CPM3.EMS and rebooted.
It did boot but got stuck later. Forced yet another abort by deselecting the virtual disc. Machine froze but the status line was revealing:


Re Gotek behaviour

Ultimately it's going to be down to the software running on the Gotek: FlashFloppy.
I had a long hard look at the Github page earlier today but couldn't find anything helpful.
Doesn't seem to distinguish between different drive/image specs.



Just to clarify..

Your screen says '2 disk drives'.  What are they, and how are they connected?

The system is structured around certain rules, i.e. A: is SS and B: is DS, etc.  These rules might be bent a little, if certain provisions are made.   Still seems like your machine is finding things that it doesn't like, or cannot cope with.   Things that COULD be OK, if everything is consistent.

I don't think there is anything 'wrong' re the Gotek.   I suspect it's down to what the PCW expects to see, what the Gotek (and/or the image being used) actually presents, and how the PCW might be able to cope with any inconsistencies.

Any chance you could send me a copy of the boot disk you got, the one that gives problems.   I've got no interest in the files, already got everything, but I would like to look at the data/code in the boot sector.

Oh, the pic you show doesn't show the status line.   Just the startup text, but no A: prompt, so boot has not finished.   Is this booting from an actual disk, or from an image/Gotek?



Sorry for the misleading use of terminology! Since mine's a single drive 8256 (and working CP/M copies report this correctly) the ,,2 disc drives" statement is interesting. If the OS expects to find two DD 3.5" floppies, there's something quite wrong. TBH I'm beginning to suspect the disc image is actually meant for later series 9000 machines.

Happy to send you the image for further investigation!



Yes I'd like to see the file.  You could just ZIP it, and attach to your next message here.

The version of CP/M you got is certainly intended for a 9xxx series machine, but it will still work fine on an 8xxx one.   We're using it fine with the uIDE.   I don't know how different the boot code might be, which is one reason I'd like to see the image.

If your machine has just the one drive (I assume then that the Gotek is fitted as A: and there is no B:) I don't know why you get a message saying there are 2 drives.   The message is created on the fly, based on what the loaded system finds, and should be accurate.   There must be some reason why it sees 2 drives when there is in fact 1.   This fact may shed some light in the general problem.

One thing I can do is to reset the Joyce emulator from 8256 to 9512 and then try to boot from your image.   The emulator may have the same problem as your PCW?

As I noted in an earlier message, I boot my 8256 from an A: disk (178k) with the J15CPM3.EMS file  (the EMS or EMT is irrelevant and this can be renamed as needed to suit the boot sector code).   I've usually got my 5.25" B: attached, so I get '2 disk drives' showing ok.



Interesting stuff about booting an 8256 with a 9512+ image via floppy emulator:


The 8000 PCWs expect a boot sector with checksum 255, while the 9000s expect checksum 1. This is calculated by simply adding up all the bytes in the sector. When I look at the boot sector, there are zero bytes at the addresses & 000A to & 000E, so I wrote a & FE at & 000E.

Instead of beeping three times Joyce is now booting up - and is hanging. For a short card from the floppy emulator, back in, [R] etry and after the setdef [ALT] + [C] press to interrupt the PROFILE.SUB, because the 8000er the command DAISY is not good.



Thanks for image, which I've got through OK.

Initial look, XDPB info seems fine.   Boot sector code looks OK, but not compared yet.   I note that this code shows the *.EMT hardcoded, at some time (later) this changed to *.EM? I suspect.

Lot of deleted SYSTEM files in DIR, I guess you got rid of a lot you didn't immed need.

I'll try to boot it in Joyce later.



That's the file as sold, no modifications by me.


Well, not good news.

Given that I'm LOOKING for a problem, and thereby some hints how to fix something.

However, I've tried the image as a boot disk within Joyce, and it works perfectly.   The system has loaded fine, reported things as should be, given me the A: prompt, and the system operates as normal.   So, no hints.

I tried to rename A35.XXX to A35.FIB, and this works fine.  No complaints.

The only other thing I can see to do would be to create an A: image with the same files on (or most of them, there's not space for all) and make sure that the image is correct (as I see it) and test that Joyce boots it OK and send you the image to try.  If your machine is getting the idea that it's a 9512, when you make a new disk there you may be getting something not quite right?

Any use?

Edit:  I restarted the boot with A35.FIB present.   The FIB loaded fine, and reported
'Pinboard Computers 3.5 inch Drive A:'
Although this makes no difference to anything within the emulator.   A: worked fine before, still works fine.

I then restarted Joyce as an 8256 using a normal boot disk, and loaded your image as B:.   The image worked fine as B:



Most odd. I just thought I might be making some progress when this file booted with minor hiccups:

But unfortunately:

QuotePCW 2.1 Supplied with the PCW9512.

  • Support added for the PCW9512 and its daisywheel printer.
  • Does not include code to load *.FID drivers.
  • Floppy drive support altered to support a system with a 720k drive A:. Also some tweaks made to floppy interrupt handling, perhaps to cope with slight hardware differences.[/l][/l]


So, system was looking for PROFILE.SUB.   Is there a PROFILE.SUB on that boot disk?

The matter of the startup showing '2 disk drives' worries me.

If there is only one drive, then this is OK, but the system should recognise this.

When you get the A: prompt, and you then type B: and press enter, what happens.  Please describe in detail what you see on the screen.   You should get a B: prompt, and a message about swapping disk in the drive.

I'm wondering if there is something wrong with the wiring for your disk, so that the machine thinks both A: and B: are in fact there when in fact they're not, and insofar as they MIGHT be there, they are in fact different when the system logic assumes they are the same thing?



I tried a slightly different approach which (much to my surprise) seemed to work with another 1.15 image.
Gave it a shot with the one I sent you and voila:

Still had to temporarily unmount the image but on re-insertion ,,retried" which is apparently sufficient, go figure?
Not sure whether everything's working as it should but it's certainly some progress.


Well it's not that great, suddenly I seem to get a lot of disc errors on almost every other virtual disc. Rebooting into 1.2 or 1.4 immediately fixes this.


Aha - the screen image you show just now, shows '1 disk drive' and it shows the 'Drive is A:' in the bottom right of the screen.   When the system was showing '2 disk drives', what was it showing lower right?

You might have an intermitant cross connection between the two drive select lines?   When they're shorting, the computer thinks there are two drives, when they're not, it sees one only.   Between the system seeming to work, and it later not working again, was the cable, or anything, moved that might have caused a problem?   The problem with this 'guess' is that the actual lines in the cable are NOT adjacent, there is an unused line between them (at least) so it would need some major damage to cause such a problem.   Did you start trying to do anything to make an A/B switch, that might have gone wrong?



There doesn't appear to be anything wrong with the wiring as such. No switches, loose cables etc. At least I didn't spot anything. I definitely didn't move the machine either (apart from switching on and off a few times).
Maybe I never noticed but I don't remember seeing ,,two drives" before.


Any chance you could post some pics of how the Gotek is connected?

Also, there's a jumper on the Gotek, relating to which drive it is emulating.   I assume you've got this jumper on correctly for DS0 (i.e. A:) as opposed to DS1 which would be B:, and there's no chance of any 'short circuit' here.



Looked back thru your pics.

Pic in post #58 shows '1 disk drive
                 #79 says 2
                 #89 shows 1
                 #91 shows 1

So maybe the 2 in #79 is an oddity?  But it's come from somewhere???



Just tried to recreate the conditions as above by placing J15CPM3.EMS and A35.FID in a regular sized disk image but the error didn't reoccur. Briefly swapping the image file in and out allowed boot to finish by selecting (R)etry. As before this did lead to instability however with many disc images becoming unreliable. Not a magic wand it would seem.

TBH I can't muster the necessary enthusiasm to take the machine apart again just now. No pictures I'm afraid! Still waiting for the 8512 to arrive though, which should be here any day now. I'll probably swap the Gotek over then and take some pictures and all.


Here's a shot showing my Gotek by the seller:


If someone has a suggestion how to change the drive belt on an EME 232 without taking the drive apart I'm all ears. I managed to get the old one out but further disassembly has proven impossible without cutting wires.

Powered by SMFPacks Menu Editor Mod