General Category > NC100, NC200, PCW, PDA600 - the rest of the Family!

PCW16 Emulation under Mess

(1/2) > >>

I know that it is arnoldemu that has written the Mess driver for PCW16.

According to the messinfo, it seems that it must run quite well. But i can't pass the "Fatal OS checksum error" as i can't find any image file of OS Rescue System i'm able to mount under MESS.

I have the OS112 CFI (compressed image file) with which i have succeded in installing Roseanne under the emulator "Anne" (from "Joyce" emu), as it support CFI (mess doesn't seem to).
Under the emulator, i have copied it on another image file to have it uncompressed, it worked as i can install Roseanne from scratch under "Anne" with this image file.
Unfortunately, it is non standard (1481K instead of 1440K) so i can't mount it in mess.

Off Topic : I uncompressed it too using dsktool-1.0.2, i ended with a file of the same size and nearly the same content, just a change of 3 bytes in each header of each sector of the file, but i cant use it to install roseanne, so it must be flawed somewhere, eventhough i would have thought that i would have been more reliable than the first method i used.

I even tryied dumping it on a virtual floppy drive (using Imdisk Virtual Driver) : i end up with a 1440K readable under Winimage, from which i can see the whole file system and extract it, but it doesn't seem to work to install Roseanne under Mess eventhough i can at least succesfully mount the file.

So my question is : how did you succeded in installing it under Mess? As far as i Know, you can't directly mount a real floppy disk, so i don't see any solution left, unless you have a file i don't have!

Thanks in advance


nb : i just tested my 1440k image file in "anne", i can install the system with it too...

Perhaps there are some things i do wrong in Mess!

Last I saw, you could install the OS from the rescue disk to flash, but booting the OS from flash doesn't seem to work (MESS runs very slowly at some point, possibly due to MAME's rather sluggish handling of memory banking.

Actually, just tested it now, and it actually gets to the point of asking what application to run.  But mouse and keyboard input doesn't seem to work at all. :(

One other thing to note, the driver is marked as "not working".

EDIT: From the source:

--- Code: ---/* PeT 19.October 2000
   added/changed printer support
   not working reliable, seams to expect parallelport in epp/ecp mode
   epp/ecp modes in parallel port not supported yet
   so ui disabled */

--- End code ---
It does seem to be waiting for something on port 0x2e (2nd UART), not sure if that's related or not.  (Edit #2: it's not, the second UART is for the mouse)

mahlemiut, i hope i don't bother you but that would be great if you can give me the image file you flashed the OS with and explain me how you did it.I tried everything with my files, including the dip switch thing and i have no success.

Thanks in advance!

BTW, last time I was using it (many years ago).. it worked fine.
you had to install the OS, it would boot and you could use the wordprocessor etc.
So it's got broken since then.


--- Quote from: arnoldemu on 19:40, 29 March 12 ---BTW, last time I was using it (many years ago).. it worked fine.
you had to install the OS, it would boot and you could use the wordprocessor etc.
So it's got broken since then.

--- End quote ---

Yeah, that's what you wrote in the messinfo of the driver. That's why i assume you have a valid method to flash the bios.

(remember i do it succesfully on Anne, but not on mess).


[0] Message Index

[#] Next page

Go to full version
Powered by SMFPacks Reactions Mod
Powered by SMFPacks Alerts Pro Mod
Powered by SMFPacks Mentions Pro Mod