Author Topic: Setting PCW SIO baudrate with DEVICE  (Read 567 times)

0 Members and 1 Guest are viewing this topic.

Offline gertk

  • CPC464
  • **
  • Posts: 15
  • Country: nl
    • my website (not very active)
    • Awards
Setting PCW SIO baudrate with DEVICE
« on: 22:58, 09 August 21 »
Trying to get the second serial port of the Z80 DART/SIO chip working I have made a .FID file which adds the device 'WIFI' (second port is connected to an ESP8266).
I filled the jump table with the right values and the device is added to the list when I check with DEVICE command.Alas it should be possible to set the baudrate of the selected device but it seems the extra options are not recognized.
If I type in:
DEVICE WIFI [NOXON,1200]
The answer is:
Error at the '^'; invalid delimiter.The up arrow points at the space between WIFI and the [

If I try with
DEVICE AUXOUT:=WIFI [NOXON,1200]
The answer is:
Error at the '^'; Invalid physical device.The up arrow points at the opening [
BTW it does react the same if I fill in SIO instead of WIFI

According to the info I found FID_C_INIT is (also) called after changing the baudrate or mode with DEVICE.It looks like this is not supported ? (maybe that is why there is a SETSIO.COM program?)



like
0
No reactions

Offline JohnElliott

  • CPC664
  • ***
  • Posts: 131
  • Country: gb
    • Awards
Re: Setting PCW SIO baudrate with DEVICE
« Reply #1 on: 23:50, 09 August 21 »
SETSIO is necessary because the SIO has more options (eg stop bits and interrupt mode) which DEVICE doesn't support.
To set the speed of a device in DEVICE you need to have the device name up against the speed with no spaces. So
Code: [Select]
DEVICE SIO[2400]not
Code: [Select]
DEVICE SIO [2400].
like
0
No reactions

Offline gertk

  • CPC464
  • **
  • Posts: 15
  • Country: nl
    • my website (not very active)
    • Awards
Re: Setting PCW SIO baudrate with DEVICE
« Reply #2 on: 22:37, 10 August 21 »
SETSIO is necessary because the SIO has more options (eg stop bits and interrupt mode) which DEVICE doesn't support.
To set the speed of a device in DEVICE you need to have the device name up against the speed with no spaces. So
Code: [Select]
DEVICE SIO[2400]not
Code: [Select]
DEVICE SIO [2400].
Hmm, I thought I had tried all kinds of combinations, and according to my CPM3_CMD_ref manual there are spaces but indeed, with no spaces it accepts the options  :)   Modified the init code so I can set some baudrates and it looks like I have connection to the ESP alas, it is in the wrong mode: it just echoes my typed in characters (which is already quite a result) but the preprogrammed Wifi virtual modem software does not run. But that has nothing to do with the  PCW  :D
like
0
No reactions